package/bash-completion: bump to version 2.9

Remove patch (already on version)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2019-09-20 18:45:42 +02:00 committed by Peter Korsgaard
parent a7c4753998
commit 857c51b0e4
3 changed files with 2 additions and 40 deletions

View File

@ -1,35 +0,0 @@
From f9a1dfe7a3d0f35474b3f4ded05e3d97be5017bf Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.skytta@iki.fi>
Date: Fri, 25 May 2018 17:38:59 +0200
Subject: [PATCH] completions/Makefile.am: Use install-data-hook, not
install-data-local
-hook is run after the main rule, while -local might end up before.
https://www.gnu.org/software/automake/manual/html_node/Extending.html#index-hook-targets
Closes #212
[backported from ee6b37ad7ff5b309cbb9b886a871252abd9398fa]
Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
completions/Makefile.am | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/completions/Makefile.am b/completions/Makefile.am
index e442a9e..5c49796 100644
--- a/completions/Makefile.am
+++ b/completions/Makefile.am
@@ -993,8 +993,8 @@ symlinks: $(targetdir) $(DATA)
all-local: targetdir = .
all-local: symlinks
-install-data-local: targetdir = $(DESTDIR)$(bashcompdir)
-install-data-local: symlinks
+install-data-hook: targetdir = $(DESTDIR)$(bashcompdir)
+install-data-hook: symlinks
check-local:
ret=0
--
2.7.4

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 c01f5570f5698a0dda8dc9cfb2a83744daa1ec54758373a6e349bd903375f54d bash-completion-2.8.tar.xz
sha256 d48fe378e731062f479c5f8802ffa9d3c40a275a19e6e0f6f6cc4b90fa12b2f5 bash-completion-2.9.tar.xz
sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6 COPYING

View File

@ -4,15 +4,12 @@
#
################################################################################
BASH_COMPLETION_VERSION = 2.8
BASH_COMPLETION_VERSION = 2.9
BASH_COMPLETION_SITE = https://github.com/scop/bash-completion/releases/download/$(BASH_COMPLETION_VERSION)
BASH_COMPLETION_SOURCE = bash-completion-$(BASH_COMPLETION_VERSION).tar.xz
BASH_COMPLETION_LICENSE = GPL-2.0
BASH_COMPLETION_LICENSE_FILES = COPYING
# 0001-completions-Makefile.am-Use-install-data-hook-not-in.patch
BASH_COMPLETION_AUTORECONF = YES
# Install bash-completion.pc file
BASH_COMPLETION_INSTALL_STAGING = YES