package/python-pillow: bump to version 9.2.0
Drop patch which is now upstream. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
b438c1bead
commit
855ea9c935
@ -1,33 +0,0 @@
|
||||
From 9ea46247048f861f088f09541cd434aeb16e6f9c Mon Sep 17 00:00:00 2001
|
||||
From: James Hilliard <james.hilliard1@gmail.com>
|
||||
Date: Tue, 15 Mar 2022 23:31:59 -0600
|
||||
Subject: [PATCH] Search pkg-config system libs/cflags.
|
||||
|
||||
We need to search the system paths as well from pkg-config for
|
||||
some packages to be found properly.
|
||||
|
||||
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
||||
[james.hilliard1@gmail.com: backport from upstream commit
|
||||
9ea46247048f861f088f09541cd434aeb16e6f9c]
|
||||
---
|
||||
setup.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 9a05e5105..d41aedbd6 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -252,8 +252,8 @@ def _cmd_exists(cmd):
|
||||
def _pkg_config(name):
|
||||
try:
|
||||
command = os.environ.get("PKG_CONFIG", "pkg-config")
|
||||
- command_libs = [command, "--libs-only-L", name]
|
||||
- command_cflags = [command, "--cflags-only-I", name]
|
||||
+ command_libs = [command, "--libs-only-L", "--keep-system-libs", name]
|
||||
+ command_cflags = [command, "--cflags-only-I", "--keep-system-cflags", name]
|
||||
if not DEBUG:
|
||||
command_libs.append("--silence-errors")
|
||||
command_cflags.append("--silence-errors")
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,6 +1,6 @@
|
||||
# md5, sha256 from https://pypi.org/pypi/pillow/json
|
||||
md5 f0d347298e72b403fbc3198677f394bb Pillow-9.1.1.tar.gz
|
||||
sha256 7502539939b53d7565f3d11d87c78e7ec900d3c72945d4ee0e2f250d598309a0 Pillow-9.1.1.tar.gz
|
||||
md5 218bdb951f3e59e8b782e329ece3416d Pillow-9.2.0.tar.gz
|
||||
sha256 75e636fd3e0fb872693f23ccb8a5ff2cd578801251f3a4f6854c6a5d437d3c04 Pillow-9.2.0.tar.gz
|
||||
|
||||
# Locally computed sha256 checksums
|
||||
sha256 a6554cb737ba6c9b47d3301f78de03b4ed0d3f08d6cf9400714f3d4c894f6943 LICENSE
|
||||
|
@ -4,8 +4,8 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PYTHON_PILLOW_VERSION = 9.1.1
|
||||
PYTHON_PILLOW_SITE = https://files.pythonhosted.org/packages/43/6e/59853546226ee6200f9ba6e574d11604b60ad0754d2cbd1c8f3246b70418
|
||||
PYTHON_PILLOW_VERSION = 9.2.0
|
||||
PYTHON_PILLOW_SITE = https://files.pythonhosted.org/packages/8c/92/2975b464d9926dc667020ed1abfa6276e68c3571dcb77e43347e15ee9eed
|
||||
PYTHON_PILLOW_SOURCE = Pillow-$(PYTHON_PILLOW_VERSION).tar.gz
|
||||
PYTHON_PILLOW_LICENSE = HPND
|
||||
PYTHON_PILLOW_LICENSE_FILES = LICENSE
|
||||
|
Loading…
Reference in New Issue
Block a user