package/webkitgtk: security bump to version 2.36.5
Bugfix release, including the patch that can be now removed, and security patches for CVE-2022-32792, CVE-2022-32816, and CVE-2022-2294. Release notes: https://webkitgtk.org/2022/07/28/webkitgtk2.36.5-released.html Accompanying security advisory: https://webkitgtk.org/security/WSA-2022-0007.html Signed-off-by: Adrian Perez de Castro <aperez@igalia.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
a8b45de60c
commit
834aefa8da
@ -1,58 +0,0 @@
|
||||
From a780527a1b79538f1e1f5144e9b522d0927a2312 Mon Sep 17 00:00:00 2001
|
||||
From: Adrian Perez de Castro <aperez@igalia.com>
|
||||
Date: Wed, 13 Jul 2022 00:53:48 +0300
|
||||
Subject: [PATCH] Revert "Merge r295034 - WebKitTestRunner shouldn't link
|
||||
object files of JavaScriptCore and WebCore"
|
||||
|
||||
This reverts commit 7916fda00b347ff263fbfe72c065032d1d9b523c.
|
||||
|
||||
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
|
||||
[Upstream status: https://bugs.webkit.org/show_bug.cgi?id=241002]
|
||||
|
||||
---
|
||||
Source/JavaScriptCore/CMakeLists.txt | 12 +++++++++---
|
||||
Tools/WebKitTestRunner/CMakeLists.txt | 1 -
|
||||
Tools/WebKitTestRunner/PlatformGTK.cmake | 4 ++++
|
||||
Tools/WebKitTestRunner/PlatformWin.cmake | 4 ++++
|
||||
4 files changed, 17 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/Source/JavaScriptCore/CMakeLists.txt b/Source/JavaScriptCore/CMakeLists.txt
|
||||
index 95a1300ce1b3..238208eb1137 100644
|
||||
--- a/Source/JavaScriptCore/CMakeLists.txt
|
||||
+++ b/Source/JavaScriptCore/CMakeLists.txt
|
||||
@@ -456,7 +456,7 @@ if (MSVC AND NOT ENABLE_C_LOOP)
|
||||
COMMAND ${MASM_EXECUTABLE} ${LLINT_MASM_FLAGS} ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.obj ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.asm
|
||||
VERBATIM)
|
||||
list(APPEND JavaScriptCore_SOURCES ${JavaScriptCore_DERIVED_SOURCES_DIR}/LowLevelInterpreterWin.obj)
|
||||
- add_library(LowLevelInterpreterLib STATIC llint/LowLevelInterpreter.cpp)
|
||||
+ add_library(LowLevelInterpreterLib OBJECT llint/LowLevelInterpreter.cpp)
|
||||
else ()
|
||||
# As there's poor toolchain support for using `.file` directives in
|
||||
# inline asm (i.e. there's no way to avoid clashes with the `.file`
|
||||
@@ -465,7 +465,7 @@ else ()
|
||||
# an object file. We only need to do this for LowLevelInterpreter.cpp
|
||||
# and cmake doesn't allow us to introduce a compiler wrapper for a
|
||||
# single source file, so we need to create a separate target for it.
|
||||
- add_library(LowLevelInterpreterLib STATIC llint/LowLevelInterpreter.cpp
|
||||
+ add_library(LowLevelInterpreterLib OBJECT llint/LowLevelInterpreter.cpp
|
||||
${JavaScriptCore_DERIVED_SOURCES_DIR}/${LLIntOutput})
|
||||
endif ()
|
||||
|
||||
@@ -1496,7 +1496,13 @@ if (CMAKE_COMPILER_IS_GNUCXX AND GCC_OFFLINEASM_SOURCE_MAP)
|
||||
COMPILE_OPTIONS "-fno-lto")
|
||||
endif ()
|
||||
|
||||
-list(APPEND JavaScriptCore_PRIVATE_LIBRARIES LowLevelInterpreterLib)
|
||||
+# When building JavaScriptCore as an object library, we need to make sure the
|
||||
+# lowlevelinterpreter lib objects get propogated.
|
||||
+if (${JavaScriptCore_LIBRARY_TYPE} STREQUAL "OBJECT")
|
||||
+ list(APPEND JavaScriptCore_PRIVATE_LIBRARIES $<TARGET_OBJECTS:LowLevelInterpreterLib>)
|
||||
+else ()
|
||||
+ list(APPEND JavaScriptCore_SOURCES $<TARGET_OBJECTS:LowLevelInterpreterLib>)
|
||||
+endif ()
|
||||
|
||||
WEBKIT_COMPUTE_SOURCES(JavaScriptCore)
|
||||
list(APPEND JavaScriptCore_SOURCES
|
||||
--
|
||||
2.37.1
|
||||
|
@ -1,7 +1,7 @@
|
||||
# From https://webkitgtk.org/releases/webkitgtk-2.36.4.tar.xz.sums
|
||||
md5 bb5f96d54804e22fd52478665d1dac7a webkitgtk-2.36.4.tar.xz
|
||||
sha1 c4f2d3c8581d1abe2a959e99f2846bea5d5ddf3c webkitgtk-2.36.4.tar.xz
|
||||
sha256 b6bebe1f85a479d968c19e44a4704622ef8cef61636ad1b2406b77d16ae2e2a8 webkitgtk-2.36.4.tar.xz
|
||||
# From https://webkitgtk.org/releases/webkitgtk-2.36.5.tar.xz.sums
|
||||
md5 a876da9d8906468f4e1e3d08729cdeec webkitgtk-2.36.5.tar.xz
|
||||
sha1 49ff8873500a2ce82bad8879095277bb4dfd21de webkitgtk-2.36.5.tar.xz
|
||||
sha256 d5532fa884c943dc48f1911473dd663aba407a3b35caa7b04bac1419b41e5908 webkitgtk-2.36.5.tar.xz
|
||||
|
||||
# Hashes for license files:
|
||||
sha256 0b5d3a7cc325942567373b0ecd757d07c132e0ebd7c97bfc63f7e1a76094edb4 Source/WebCore/LICENSE-APPLE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
WEBKITGTK_VERSION = 2.36.4
|
||||
WEBKITGTK_VERSION = 2.36.5
|
||||
WEBKITGTK_SITE = https://www.webkitgtk.org/releases
|
||||
WEBKITGTK_SOURCE = webkitgtk-$(WEBKITGTK_VERSION).tar.xz
|
||||
WEBKITGTK_INSTALL_STAGING = YES
|
||||
|
Loading…
Reference in New Issue
Block a user