ftop: new package

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Gustavo Zacarias 2014-06-29 12:39:06 -03:00 committed by Peter Korsgaard
parent 8c1ff84efc
commit 82c9989691
4 changed files with 43 additions and 0 deletions

View File

@ -1118,6 +1118,7 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
endif
source "package/cpuload/Config.in"
source "package/dsp-tools/Config.in"
source "package/ftop/Config.in"
source "package/htop/Config.in"
source "package/iprutils/Config.in"
source "package/keyutils/Config.in"

12
package/ftop/Config.in Normal file
View File

@ -0,0 +1,12 @@
config BR2_PACKAGE_FTOP
bool "ftop"
depends on BR2_LARGEFILE
select BR2_PACKAGE_NCURSES
help
Ftop is to files what top is to processes.
The progress of all open files and file systems can be monitored.
https://code.google.com/p/ftop/
comment "ftop needs a toolchain w/ largefile"
depends on !BR2_LARGEFILE

View File

@ -0,0 +1,17 @@
Set tmp_buf and rate_buf to something ridiculously high to fix a buffer
overflow when COLUMNS is large. - JeR
(Taken from gentoo portage)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
--- a/src/ftop.c 2009-02-16 07:00:00.000000000 +0100
+++ b/src/ftop.c 2013-09-06 14:42:41.788852952 +0200
@@ -736,7 +736,7 @@
{
size_t i, j, bytes, bar_total;
char more_procs_ch, more_files_ch, expanded_ch;
- char tmp_buf[80], rate_buf[80];
+ char tmp_buf[2048], rate_buf[2048];
char *tmp_str;
snapshot *s, *s_prev;
file_info *tmp_file;

13
package/ftop/ftop.mk Normal file
View File

@ -0,0 +1,13 @@
################################################################################
#
# ftop
#
################################################################################
FTOP_VERSION = 1.0
FTOP_SITE = http://ftop.googlecode.com/files/
FTOP_DEPENDENCIES = ncurses
FTOP_LICENSE = GPLv3+
FTOP_LICENSE_FILES = COPYING
$(eval $(autotools-package))