package/libfuse3: bump to version 3.15.0

Drop local patch that has been upstreamed but add a new one to fix build
failure:
../meson.build:180:12: ERROR: Can not run test applications in this
cross environment.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Giulio Benetti 2023-06-13 21:09:09 +02:00 committed by Peter Korsgaard
parent 067a8864c5
commit 81cb8b7e10
5 changed files with 45 additions and 51 deletions

View File

@ -740,7 +740,6 @@ package/libftdi1/0002-CMakeLists.txt-fix-paths-when-FTDIPP-is-set.patch Upstream
package/libftdi1/0003-CMakeLists.txt-fix-static-build-with-libusb-and-lato.patch Upstream
package/libfuse/0001-fix-aarch64-build.patch Upstream
package/libfuse/0002-util-ulockmgr_server-c-conditionally-define-closefrom-fix-glibc-2-34.patch Upstream
package/libfuse3/0001-Fix-MS_LAZYTIME-not-defined-on-uclibc.patch Upstream
package/libgcrypt/0001-configure.ac-add-an-option-to-disable-tests.patch Upstream
package/libgdiplus/0001-Build-unit-tests-only-when-enable-unit-tests-is-pass.patch Upstream
package/libglfw/0001-Wayland-Remove-extra-cmake-modules-dependency.patch Upstream

View File

@ -1,48 +0,0 @@
From 56038446952516da5d4cf09e1192824031082943 Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Mon, 27 Mar 2023 21:08:57 +0200
Subject: [PATCH] Fix MS_LAZYTIME not defined on uclibc
[Upstream status: https://github.com/libfuse/libfuse/pull/753]
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
lib/mount.c | 5 +++++
util/fusermount.c | 6 ++++++
2 files changed, 11 insertions(+)
diff --git a/lib/mount.c b/lib/mount.c
index 1f1ee86..84e5c73 100644
--- a/lib/mount.c
+++ b/lib/mount.c
@@ -27,6 +27,11 @@
#include <sys/wait.h>
#include <sys/mount.h>
+/* uclibc doesn't define MS_LAZYTIME */
+#ifndef MS_LAZYTIME
+#define MS_LAZYTIME (1<<25)
+#endif
+
#ifdef __NetBSD__
#include <perfuse.h>
diff --git a/util/fusermount.c b/util/fusermount.c
index 6e72f0d..82cc420 100644
--- a/util/fusermount.c
+++ b/util/fusermount.c
@@ -25,6 +25,12 @@
#include <sys/wait.h>
#include <sys/stat.h>
#include <sys/mount.h>
+
+/* uclibc doesn't define MS_LAZYTIME */
+#ifndef MS_LAZYTIME
+#define MS_LAZYTIME (1<<25)
+#endif
+
#include <sys/fsuid.h>
#include <sys/socket.h>
#include <sys/utsname.h>
--
2.34.1

View File

@ -0,0 +1,43 @@
From b58a0014bff619f1810af49441d987d732c4244e Mon Sep 17 00:00:00 2001
From: Rudi Heitbaum <rudi@heitbaum.com>
Date: Tue, 13 Jun 2023 20:02:01 +1000
Subject: [PATCH] Wrapper around test applications for cross compiler
environment in meson.build (#804)
This enhances commit 7be56c57f93e3436b1fbd9ecc320de5c03a3e4b8 to allow build
fuse to be built using a cross compiler
Fixes:
../meson.build:180:12: ERROR: Can not run test applications in this cross environment.
Upstream: https://github.com/libfuse/libfuse/commit/b58a0014bff619f1810af49441d987d732c4244e
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
meson.build | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/meson.build b/meson.build
index 7aa4e0d..9707ea3 100644
--- a/meson.build
+++ b/meson.build
@@ -177,10 +177,12 @@ int main()
}
'''
-result = cc.run(detect_getmntent_needs_unescape)
-if result.compiled() and result.returncode() == 0 and result.stdout().strip() == 'needs escaping'
- message('getmntent does not unescape')
- add_project_arguments('-DGETMNTENT_NEEDS_UNESCAPING', language: 'c')
+if not meson.is_cross_build()
+ result = cc.run(detect_getmntent_needs_unescape)
+ if result.compiled() and result.returncode() == 0 and result.stdout().strip() == 'needs escaping'
+ message('getmntent does not unescape')
+ add_project_arguments('-DGETMNTENT_NEEDS_UNESCAPING', language: 'c')
+ endif
endif
# Write private test results into fuse_config.h (stored in build directory)
--
2.34.1

View File

@ -1,3 +1,3 @@
# Locally calculated sha256 checksums
sha256 99688d68a753ee97eed51d536b216b8ae5d7fe0236c1a45d439357903bfd4d88 libfuse3-3.14.1.tar.gz
sha256 1e79f1dd60eaf79645c21411c4a7028c97b5e745ea677ac5bda747c90497a785 libfuse3-3.15.0.tar.gz
sha256 b8832d9caaa075bbbd2aef24efa09f8b7ab66a832812d88c602da0c7b4397fad LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBFUSE3_VERSION = 3.14.1
LIBFUSE3_VERSION = 3.15.0
LIBFUSE3_SITE = $(call github,libfuse,libfuse,fuse-$(LIBFUSE3_VERSION))
LIBFUSE3_LICENSE = LGPL-2.1
LIBFUSE3_LICENSE_FILES = LICENSE