From 8113c8162bb78cc5a7081ee1cfa46ffe28ec6368 Mon Sep 17 00:00:00 2001
From: Martin Banky Buildroot
- usage and documentation by Thomas Petazzoni. Contributions from
- Karsten Kruse, Ned Ludd, Martin Herren and others. Buildroot usage and documentation
+ by Thomas Petazzoni. Contributions from Karsten Kruse, Ned Ludd, Martin
+ Herren and others. Buildroot is a set of Makefiles and patches that allows you to
- easily generate a cross-compilation toolchain, a root filesystem
- and a Linux kernel image for your target. Buildroot can be used
- for one, two or all of these options, independently. Buildroot is a set of Makefiles and patches that allows you to easily
+ generate a cross-compilation toolchain, a root filesystem and a Linux
+ kernel image for your target. Buildroot can be used for one, two or all
+ of these options, independently. Buildroot is useful mainly for people working with embedded systems.
- Embedded systems often use processors that are not the regular x86
- processors everyone is used to having in his PC. They can be PowerPC
- processors, MIPS processors, ARM processors, etc. Buildroot is useful mainly for people working with embedded systems.
+ Embedded systems often use processors that are not the regular x86
+ processors everyone is used to having in his PC. They can be PowerPC
+ processors, MIPS processors, ARM processors, etc. A compilation toolchain is the set of tools that allows you to
- compile code for your system. It consists of a compiler (in our
- case, A compilation toolchain is the set of tools that allows you to
+ compile code for your system. It consists of a compiler (in our case,
+ As said above, the compilation toolchain that comes with your system
- runs on and generates code for the processor in your host system. As your
- embedded system has a different processor, you need a cross-compilation
- toolchain — a compilation toolchain that runs on your host system but
- generates code for your target system (and target processor). For
- example, if your host system uses x86 and your target system uses ARM, the
- regular compilation toolchain on your host runs on x86 and generates code
- for x86, while the cross-compilation toolchain runs on x86 and generates
- code for ARM. As said above, the compilation toolchain that comes with your system
+ runs on and generates code for the processor in your host system. As
+ your embedded system has a different processor, you need a
+ cross-compilation toolchain — a compilation toolchain that runs on
+ your host system but generates code for your target system (and target
+ processor). For example, if your host system uses x86 and your target
+ system uses ARM, the regular compilation toolchain on your host runs on
+ x86 and generates code for x86, while the cross-compilation toolchain
+ runs on x86 and generates code for ARM. Even if your embedded system uses an x86 processor, you might be interested
- in Buildroot for two reasons: Even if your embedded system uses an x86 processor, you might be
+ interested in Buildroot for two reasons: You might wonder why such a tool is needed when you can compile
Buildroot
-
-
- About Buildroot
+ About Buildroot
- gcc
), binary utils like assembler and linker
- (in our case, binutils
) and a C standard library (for
- example GNU
- Libc, uClibc or dietlibc). The system
- installed on your development station certainly already has a
- compilation toolchain that you can use to compile an application that
- runs on your system. If you're using a PC, your compilation
- toolchain runs on an x86 processor and generates code for an x86
- processor. Under most Linux systems, the compilation toolchain
- uses the GNU libc (glibc) as the C standard library. This compilation
- toolchain is called the "host compilation toolchain".
- The machine on which it is running, and on which you're
- working, is called the "host system". The compilation toolchain
- is provided by your distribution, and Buildroot has nothing to do
- with it (other than using it to build a cross-compilation toolchain
- and other tools that are run on the development host). gcc
), binary utils like assembler and linker (in our case,
+ binutils
) and a C standard library (for example
+ GNU Libc,
+ uClibc or
+ dietlibc). The system installed
+ on your development station certainly already has a compilation
+ toolchain that you can use to compile an application that runs on your
+ system. If you're using a PC, your compilation toolchain runs on an x86
+ processor and generates code for an x86 processor. Under most Linux
+ systems, the compilation toolchain uses the GNU libc (glibc) as the C
+ standard library. This compilation toolchain is called the "host
+ compilation toolchain". The machine on which it is running, and on
+ which you're working, is called the "host system". The
+ compilation toolchain is provided by your distribution, and Buildroot
+ has nothing to do with it (other than using it to build a
+ cross-compilation toolchain and other tools that are run on the
+ development host).
-
gcc
, binutils
, uClibc
and all
- the other tools by hand.
- Of course doing so is possible. But, dealing with all of the configure options
- and problems of every gcc
or binutils
- version is very time-consuming and uninteresting. Buildroot automates this
- process through the use of Makefiles and has a collection of patches for
- each gcc
and binutils
version to make them work
- on most architectures. gcc
or
+ binutils
version is very time-consuming and uninteresting.
+ Buildroot automates this process through the use of Makefiles and has a
+ collection of patches for each gcc
and binutils
+ version to make them work on most architectures.
Moreover, Buildroot provides an infrastructure for reproducing - the build process of your kernel, cross-toolchain, and embedded root filesystem. Being able to - reproduce the build process will be useful when a component needs - to be patched or updated or when another person is supposed to - take over the project.
+ the build process of your kernel, cross-toolchain, and embedded root + filesystem. Being able to reproduce the build process will be useful when a + component needs to be patched or updated or when another person is supposed + to take over the project. -Buildroot releases are made approximately every 3 months. Direct Git access and daily snapshots are also available if you want more bleeding edge.
-Releases are available at http://buildroot.net/downloads/.
+Releases are available at + http://buildroot.net/downloads/.
-The latest snapshot is always available at http://buildroot.net/downloads/snapshots/buildroot-snapshot.tar.bz2, - and previous snapshots are also available at http://buildroot.net/downloads/snapshots/.
+The latest snapshot is always available at + http://buildroot.net/downloads/snapshots/buildroot-snapshot.tar.bz2, + and previous snapshots are also available at + http://buildroot.net/downloads/snapshots/.
To download Buildroot using Git you can simply follow - the rules described on the "Accessing Git" page (http://buildroot.net/git.html) - of the Buildroot website (http://buildroot.net). - For the impatient, here's a quick - recipe:
+ the rules described on the "Accessing Git" page + (http://buildroot.net/git.html) + of the Buildroot website + (http://buildroot.net). + For the impatient, here's a quick recipe: -+$ git clone git://git.buildroot.net/buildroot-Using Buildroot
+Using Buildroot
Buildroot has a nice configuration tool similar to the one you can find - in the Linux kernel (http://www.kernel.org/) or in Busybox + in the Linux kernel + (http://www.kernel.org/) or in Busybox (http://www.busybox.org/). Note that - you can (and should) build everything as a normal user. There is no need to be root to - configure and use Buildroot. The first step is to run the configuration - assistant:
+ you can (and should) build everything as a normal user. There is no need to + be root to configure and use Buildroot. The first step is to run the + configuration assistant:$ make menuconfig-to run the curses-based configurator, or
+to run the curses-based configurator, or
$ make xconfig-or +or
$ make gconfig @@ -169,22 +160,20 @@ orto run the Qt3 or GTK-based configurators.
-All of these "make" commands will need to build a configuration - utility, so you may need to install "development" packages for - relevant libraries used by the configuration utilities. - On Debian-like systems, the -
+libncurses5-dev
package is required to use the - menuconfig interface,libqt3-mt-dev
is - required to use the xconfig interface, and -libglib2.0-dev, libgtk2.0-dev and libglade2-dev
are - needed to used the gconfig interface.All of these "make" commands will need to build a configuration + utility, so you may need to install "development" packages for relevant + libraries used by the configuration utilities. On Debian-like systems, + the
-libncurses5-dev
package is required to use the + menuconfig interface,libqt3-mt-dev
is required to use + the xconfig interface, andlibglib2.0-dev, libgtk2.0-dev + and libglade2-dev
are needed to used the gconfig interface.For each menu entry in the configuration tool, you can find associated help - that describes the purpose of the entry.
+For each menu entry in the configuration tool, you can find associated + help that describes the purpose of the entry.
Once everything is configured, the configuration tool generates a
+ configuration. It will be used by the Makefiles to do what's needed..config
file that contains the description of your - configuration. It will be used by the Makefiles to do what's needed.Let's go:
@@ -192,6 +181,7 @@ or$ make+This command will generally perform the following steps:
Some of the above steps might not be performed if they are not selected in the Buildroot configuration. -
+ -Buildroot output is stored in a single directory,
- output/
. This directory contains several
- subdirectories:
Buildroot output is stored in a single directory, output/
.
+ This directory contains several subdirectories:
images/
where all the images (kernel image,
+ images/
where all the images (kernel image,
bootloader and root filesystem images) are stored.build/
where all the components except for the
- cross-compilation toolchain are built
- (this includes tools needed to run Buildroot on the host and packages compiled
- for the target). The build/
directory contains one
- subdirectory for each of these components.build/
where all the components except for the
+ cross-compilation toolchain are built (this includes tools needed to
+ run Buildroot on the host and packages compiled for the target). The
+ build/
directory contains one subdirectory for each of
+ these components.staging/
which contains a hierarchy similar to
- a root filesystem hierarchy. This directory contains the
- installation of the cross-compilation toolchain and all the
- userspace packages selected for the target. However, this
- directory is not intended to be the root filesystem for
- the target: it contains a lot of development files, unstripped
- binaries and libraries that make it far too big for an embedded
- system. These development files are used to compile libraries
- and applications for the target that depend on other
+ staging/
which contains a hierarchy similar to a root
+ filesystem hierarchy. This directory contains the installation of the
+ cross-compilation toolchain and all the userspace packages selected
+ for the target. However, this directory is not intended to be
+ the root filesystem for the target: it contains a lot of development
+ files, unstripped binaries and libraries that make it far too big for
+ an embedded system. These development files are used to compile
+ libraries and applications for the target that depend on other
libraries.target/
which contains almost the root
- filesystem for the target: everything needed is present except
- the device files in /dev/
(Buildroot can't create
- them because Buildroot doesn't run as root and does not want to
- run as root). Therefore, this directory should not be used on
- your target. Instead, you should use one of the images
- built in the images/
directory. If you need an
- extracted image of the root filesystem for booting over NFS,
- then use the tarball image generated in images/
and
- extract it as root.staging/
,
- target/
contains only the files and libraries needed
- to run the selected target applications: the development files
- (headers, etc.) are not present.target/
which contains almost the root
+ filesystem for the target: everything needed is present except the
+ device files in /dev/
(Buildroot can't create them
+ because Buildroot doesn't run as root and does not want to run as
+ root). Therefore, this directory should not be used on your target.
+ Instead, you should use one of the images built in the
+ images/
directory. If you need an extracted image of the
+ root filesystem for booting over NFS, then use the tarball image
+ generated in images/
and extract it as root.staging/
, target/
contains only the
+ files and libraries needed to run the selected target applications:
+ the development files (headers, etc.) are not present.host/
contains the installation of tools
- compiled for the host that are needed for the proper execution
- of Buildroot except for the cross-compilation toolchain which is
- installed under staging/
.toolchain/
contains the build directories for
- the various components of the cross-compilation toolchain.host/
contains the installation of tools compiled for
+ the host that are needed for the proper execution of Buildroot except
+ for the cross-compilation toolchain which is installed under
+ staging/
.toolchain/
contains the build directories for the
+ various components of the cross-compilation toolchain.If you intend to do an offline build and just want to download all sources that you previously selected in the configurator (menuconfig, xconfig or gconfig), then issue:
+$ make source+
You can now disconnect or copy the content of your dl
- directory to the build-host.
Buildroot supports building out of tree with a syntax similar - to the Linux kernel. To use it, add O=<directory> to the - make command line:
+Buildroot supports building out of tree with a syntax similar to the + Linux kernel. To use it, add O=<directory> to the make command + line:
$ make O=/tmp/build @@ -284,172 +269,164 @@ or $ cd /tmp/build; make O=$PWD -C path/to/buildroot-
All the output files will be located under
- /tmp/build
.
All the output files will be located under /tmp/build
.
When using out-of-tree builds, the Buildroot
- .config
and temporary files are also stored in the
- output directory. This means that you can safely run multiple
- builds in parallel using the same source tree as long as they use
- unique output directories.
When using out-of-tree builds, the Buildroot .config
and
+ temporary files are also stored in the output directory. This means that
+ you can safely run multiple builds in parallel using the same source
+ tree as long as they use unique output directories.
For ease of use, Buildroot generates a Makefile wrapper in the
- output directory - So after the first run, you no longer need to
- pass O=..
and -C ..
, simply run (in the
- output directory):
For ease of use, Buildroot generates a Makefile wrapper in the output
+ directory - So after the first run, you no longer need to pass
+ O=..
and -C ..
, simply run (in the output
+ directory):
$ make <target>-
Buildroot also honors some environment variables when they are passed
to make
or set in the environment:
HOSTCXX
, the host C++ compiler to useHOSTCC
, the host C compiler to useUCLIBC_CONFIG_FILE=<path/to/.config>
, path
- to the uClibc configuration file to use to compile uClibc if an
- internal toolchain is being builtBUSYBOX_CONFIG_FILE=<path/to/.config>
, path
- to the Busybox configuration fileBUILDROOT_DL_DIR
to override the directory in
- which Buildroot stores/retrieves downloaded filesHOSTCXX
, the host C++ compiler to useHOSTCC
, the host C compiler to useUCLIBC_CONFIG_FILE=<path/to/.config>
, path to
+ the uClibc configuration file to use to compile uClibc if an
+ internal toolchain is being builtBUSYBOX_CONFIG_FILE=<path/to/.config>
, path to
+ the Busybox configuration fileBUILDROOT_DL_DIR
to override the directory in which
+ Buildroot stores/retrieves downloaded filesAn example that uses config files located in the toplevel directory and in your $HOME:
+$ make UCLIBC_CONFIG_FILE=uClibc.config BUSYBOX_CONFIG_FILE=$HOME/bb.config
If you want to use a compiler other than the default gcc
or g++
for building helper-binaries on your host, then do
$ make HOSTCXX=g++-4.3-HEAD HOSTCC=gcc-4.3-HEAD-
There are a few ways to customize the resulting target filesystem:
output/target/
.
- You can simply make your changes here and run make afterwards — this will
- rebuild the target filesystem image. This method allows you to do anything
- to the target filesystem, but if you decide to completely rebuild your
- toolchain and tools, these changes will be lost. output/target/
.
+ You can simply make your changes here and run make afterwards —
+ this will rebuild the target filesystem image. This method allows you
+ to do anything to the target filesystem, but if you decide to
+ completely rebuild your toolchain and tools, these changes will be
+ lost.fs/skeleton/
. You can customize
- configuration files or other stuff here. However, the full file hierarchy
- is not yet present because it's created during the compilation process.
- Therefore, you can't do everything on this target filesystem skeleton, but
- changes to it do remain even if you completely rebuild the cross-compilation
- toolchain and the tools. target/generic/device_table.txt
- file which is used by the tools that generate the target filesystem image
- to properly set permissions and create device nodes.output/target/
just before the actual image
- is made. Simply rebuilding the image by running
- make should propagate any new changes to the image.
+ fs/skeleton/
. You can customize configuration files or other
+ stuff here. However, the full file hierarchy is not yet present
+ because it's created during the compilation process. Therefore, you
+ can't do everything on this target filesystem skeleton, but changes to
+ it do remain even if you completely rebuild the cross-compilation
+ toolchain and the tools.
+ target/generic/device_table.txt
file which is used by the
+ tools that generate the target filesystem image to properly set
+ permissions and create device nodes.output/target/
just before the actual image
+ is made. Simply rebuilding the image by running make should propagate
+ any new changes to the image.package/customize
can be used. You can put all the
files that you want to see in the final target root filesystem
in package/customize/source
and then enable this
special package in the configuration system.Busybox is very configurable, and - you may want to customize it. You can - follow these simple steps to do so. This method isn't optimal, but it's - simple and it works:
+Busybox is very configurable, + and you may want to customize it. You can follow these simple steps to + do so. This method isn't optimal, but it's simple and it works:
make busybox-menuconfig
.
The nice configuration tool appears, and you can
- customize everything. Otherwise, you can simply change the
package/busybox/busybox-<version>.config
file if you
know the options you want to change without using the configuration tool.
If you want to use an existing config file for busybox, then see - section environment variables.
+ section environment variables. -Just like BusyBox, uClibc offers a lot of configuration options. They allow you to select various - functionalities depending on your needs and limitations.
+ functionalities depending on your needs and limitations.The easiest way to modify the configuration of uClibc is to follow these steps:
make uclibc-menuconfig
.
The nice configuration assistant, similar to
the one used in the Linux kernel or Buildroot, appears. Make
- your configuration changes as appropriate. .config
file to
toolchain/uClibc/uClibc.config
or
toolchain/uClibc/uClibc.config-locale
. The former
is used if you haven't selected locale support in Buildroot
configuration, and the latter is used if you have selected
- locale support. Otherwise, you can simply change
toolchain/uClibc/uClibc.config
or
toolchain/uClibc/uClibc.config-locale
without running
- the configuration assistant.
If you want to use an existing config file for uclibc, then see - section environment variables.
+ section environment variables. -The Linux kernel configuration can be customized just like BusyBox and uClibc @@ -460,9 +437,7 @@ $ make HOSTCXX=g++-4.3-HEAD HOSTCC=gcc-4.3-HEAD
If you want to use an existing config file for Linux, then see section environment variables.
-One of the most common questions asked by Buildroot users is how to rebuild a given package or how to @@ -494,7 +469,6 @@ $ make HOSTCXX=g++-4.3-HEAD HOSTCC=gcc-4.3-HEAD following stamp files are relevant:
output/build/packagename-version/.stamp_configured
. If
removed, Buildroot will trigger the recompilation of the package
from the configuration step (execution of
@@ -503,25 +477,23 @@ $ make HOSTCXX=g++-4.3-HEAD HOSTCC=gcc-4.3-HEAD
output/build/packagename-version/.stamp_built
. If
removed, Buildroot will trigger the recompilation of the package
from the compilation step (execution of make
).For other packages, an analysis of the specific - package.mk file is needed. For example, the zlib Makefile - used to look like this (before it was converted to the generic - package infrastructure):
+For other packages, an analysis of the specific package.mk + file is needed. For example, the zlib Makefile used to look like this + (before it was converted to the generic package infrastructure):
-+$(ZLIB_DIR)/.configured: $(ZLIB_DIR)/.patched - (cd $(ZLIB_DIR); rm -rf config.cache; \ - [...] - ) - touch $@ + (cd $(ZLIB_DIR); rm -rf config.cache; \ + [...] + ) + touch $@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured - $(MAKE) -C $(ZLIB_DIR) all libz.a - touch -c $@ -+ $(MAKE) -C $(ZLIB_DIR) all libz.a + touch -c $@ +
If you want to trigger the reconfiguration, you need to
remove output/build/zlib-version/.configured
. If
@@ -532,30 +504,29 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
ported over the generic or the autotools infrastructure, making it
much easier to rebuild individual packages.
As mentioned above, Buildroot is basically a set of Makefiles that downloads,
- configures and compiles software with the correct options. It also includes
- patches for various software packages — mainly the ones involved in the
- cross-compilation tool chain (gcc
, binutils
and
- uClibc
).
As mentioned above, Buildroot is basically a set of Makefiles that
+ downloads, configures and compiles software with the correct options. It
+ also includes patches for various software packages — mainly the
+ ones involved in the cross-compilation tool chain (gcc
,
+ binutils
and uClibc
).
There is basically one Makefile per software package, and they are named with
- the .mk
extension. Makefiles are split into three main
- sections:
There is basically one Makefile per software package, and they are
+ named with the .mk
extension. Makefiles are split into
+ three main sections:
toolchain/
directory) contains
the Makefiles and associated files for all software related to the
cross-compilation toolchain: binutils
, ccache
,
gcc
, gdb
, kernel-headers
and
- uClibc
. uClibc
.
package/
directory) contains the
Makefiles and associated files for all user-space tools that Buildroot
can compile and add to the target root filesystem. There is one
- sub-directory per tool. target
directory) contains the
Makefiles and associated files for software related to the generation of
@@ -563,26 +534,24 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
ext2, jffs2, cramfs and squashfs. For each of them there is a
sub-directory with the required files. There is also a
default/
directory that contains the target filesystem
- skeleton. Each directory contains at least 2 files:
something.mk
is the Makefile that downloads, configures,
- compiles and installs the package something
. something
.
Config.in
is a part of the configuration tool
description file. It describes the options related to the
- package. The main Makefile performs the following steps (once the configuration is done):
staging
,
target
, build
, stamps
,
etc. in the output directory (output/
by default,
@@ -601,11 +570,9 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
trigger the compilation of the userspace packages (libraries,
programs), the kernel, the bootloader and the generation of the
root filesystem images, depending on the configuration.Creating your own board support in Buildroot allows you to have a convenient place to store your project's target filesystem skeleton @@ -614,7 +581,6 @@ $(ZLIB_DIR)/libz.a: $(ZLIB_DIR)/.configured
Follow these steps to integrate your board in Buildroot:
target/device/
named
after your company or organizationtarget/device/yourcompany/Config.in
file that looks like the following:
- +Of course, you should customize the different values to match your company/organization and your project. This file will create a @@ -652,11 +618,12 @@ endifmenuconfig BR2_TARGET_COMPANY - bool "Company projects" + bool "Company projects" if BR2_TARGET_COMPANY config BR2_TARGET_COMPANY_PROJECT_FOOBAR - bool "Support for Company project Foobar" - help - This option enables support for Company project Foobar + bool "Support for Company project Foobar" + help + This option enables support for Company project Foobar endif -+
target/device/yourcompany/Makefile.in
file that looks like the following:
- ++ifeq ($(BR2_TARGET_COMPANY_PROJECT_FOOBAR),y) include target/device/yourcompany/project-foobar/Makefile.in endif -+
target/device/yourcompany/project-foobar
as it
will simplify further definitions. Then, the file might define
one or several of the following variables:
-
- TARGET_SKELETON
to a directory that contains
- the target skeleton for your project. If this variable is
- defined, this target skeleton will be used instead of the
- default one. If defined, the convention is to define it to
- $(BOARD_PATH)/target_skeleton
so that the target
- skeleton is stored in the board specific directory.TARGET_SKELETON
to a directory that contains
+ the target skeleton for your project. If this variable is
+ defined, this target skeleton will be used instead of the
+ default one. If defined, the convention is to define it to
+ $(BOARD_PATH)/target_skeleton
so that the target
+ skeleton is stored in the board specific directory.configs/
directory. Your users will then be able
to run make something_defconfig
and get the right
configuration for your projectYou may want to compile for your target your own programs or other software - that are not packaged in Buildroot. In order to do this you can - use the toolchain that was generated by Buildroot.
+You may want to compile for your target your own programs or other + software that are not packaged in Buildroot. In order to do this you can + use the toolchain that was generated by Buildroot.
-The toolchain generated by Buildroot is located by default in
- output/staging/
. The simplest way to use it
- is to add output/staging/usr/bin/
to your PATH
- environment variable and then to use
- ARCH-linux-gcc
, ARCH-linux-objdump
,
- ARCH-linux-ld
, etc.
The toolchain generated by Buildroot is located by default in
+ output/staging/
. The simplest way to use it is to add
+ output/staging/usr/bin/
to your PATH environment variable and
+ then to use ARCH-linux-gcc
, ARCH-linux-objdump
,
+ ARCH-linux-ld
, etc.
Important: do not try to move a gcc-3.x toolchain to another
- directory — it won't work because there are some hardcoded paths in the
- gcc-3.x configuration. If you are using a current gcc-4.x, it
- is possible to relocate the toolchain — but then
- --sysroot
must be passed every time the compiler is
- called to tell where the libraries and header files are.
Important: do not try to move a gcc-3.x toolchain to another
+ directory — it won't work because there are some hardcoded paths
+ in the gcc-3.x configuration. If you are using a current gcc-4.x, it is
+ possible to relocate the toolchain — but then --sysroot
+ must be passed every time the compiler is called to tell where the
+ libraries and header files are.
It is also possible to generate the Buildroot toolchain in
- a directory other than output/staging
by using the
- Build options -> Toolchain and header file
- location
options. This could be useful if the toolchain
- must be shared with other users.
It is also possible to generate the Buildroot toolchain in a
+ directory other than output/staging
by using the
+ Build options -> Toolchain and header file location
options.
+ This could be useful if the toolchain must be shared with other users.
It might be useful to know that the various tarballs that are
- downloaded by the Makefiles are all stored in the
- DL_DIR
which by default is the dl
- directory. It's useful, for example, if you want to keep a complete
- version of Buildroot which is know to be working with the
- associated tarballs. This will allow you to regenerate the
- toolchain and the target filesystem with exactly the same
- versions.
DL_DIR
+ which by default is the dl
directory. It's useful, for
+ example, if you want to keep a complete version of Buildroot which is
+ know to be working with the associated tarballs. This will allow you to
+ regenerate the toolchain and the target filesystem with exactly the same
+ versions.
- If you maintain several Buildroot trees, it might be better to have
- a shared download location. This can be accessed by creating a symbolic link
- from the dl
directory to the shared download location:
If you maintain several Buildroot trees, it might be better to have a
+ shared download location. This can be accessed by creating a symbolic
+ link from the dl
directory to the shared download location:
ln -s <shared download location> dl @@ -745,90 +702,83 @@ ln -s <shared download location> dl create theBUILDROOT_DL_DIR
environment variable. If this is set, then the value of DL_DIR in the project is overridden. The following line should be added to -"~/.bashrc"
.+
"~/.bashrc"
.export BUILDROOT_DL_DIR <shared download location>-Using - an external toolchain
+Using an external toolchain
-It might be useful not to use the toolchain generated by -Buildroot, for example if you already have a toolchain that is known -to work for your specific CPU, or if the toolchain generation feature -of Buildroot is not sufficiently flexible for you (for example if you -need to generate a system with glibc instead of -uClibc). Buildroot supports using an external -toolchain.
+It might be useful not to use the toolchain generated by + Buildroot, for example if you already have a toolchain that is known + to work for your specific CPU, or if the toolchain generation feature + of Buildroot is not sufficiently flexible for you (for example if you + need to generate a system with glibc instead of + uClibc). Buildroot supports using an external + toolchain.
-To enable the use of an external toolchain, go in the -
+Toolchain
menu, and :To enable the use of an external toolchain, go in the +
-Toolchain
menu, and :
External binary toolchain
toolchain
- typeExternal toolchain path
- appropriately. It should be set to a path where a bin/ directory
- contains your cross-compiling toolsExternal toolchain prefix
so that the
- prefix, suffixed with -gcc
or -ld
will
- correspond to your cross-compiling toolsExternal binary toolchain
toolchain
+ typeExternal toolchain path
+ appropriately. It should be set to a path where a bin/ directory
+ contains your cross-compiling toolsExternal toolchain prefix
so that the
+ prefix, suffixed with -gcc
or -ld
will
+ correspond to your cross-compiling toolsIf you are using an external toolchain based on uClibc, the
-Core C library from the external toolchain
and
-Libraries to copy from the external toolchain
options
-should already have correct values. However, if your external
-toolchain is based on glibc, you'll have to change these values
-according to your cross-compiling toolchain.
If you are using an external toolchain based on uClibc, the
+ Core C library from the external toolchain
and
+ Libraries to copy from the external toolchain
options
+ should already have correct values. However, if your external
+ toolchain is based on glibc, you'll have to change these values
+ according to your cross-compiling toolchain.
To generate external toolchains, we recommend using Crosstool-NG. -It allows generating toolchains based on uClibc, glibc -and eglibc for a wide range of architectures and has good -community support.
+To generate external toolchains, we recommend using + Crosstool-NG. + It allows generating toolchains based on uClibc, glibc + and eglibc for a wide range of architectures and has good + community support.
-This section covers how new packages (userspace libraries or - applications) can be integrated into Buildroot. It also allows to - understand how existing packages are integrated, which is needed - to fix issues or tune their configuration.
+This section covers how new packages (userspace libraries or + applications) can be integrated into Buildroot. It also allows to + understand how existing packages are integrated, which is needed to fix + issues or tune their configuration.
Config.in
file.mk
file
-
+
First of all, create a directory under the package
- directory for your software, for example foo
.
foo
.
Some packages have been grouped by topic in a sub-directory:
- multimedia
, java
,
- databases
, editors
, x11r7
,
- games
. If your package fits in one of these
- categories, then create your package directory in these.
multimedia
, java
, databases
,
+ editors
, x11r7
, games
. If your
+ package fits in one of these categories, then create your package
+ directory in these.
- Config.in
fileConfig.in
fileThen, create a file named Config.in
. This file
will contain the option descriptions related to our
@@ -837,8 +787,8 @@ community support.
config BR2_PACKAGE_LIBFOO - bool "libfoo" - help + bool "libfoo" + help This is a comment that explains what libfoo is. http://foosoftware.org/libfoo/ @@ -848,8 +798,9 @@ config BR2_PACKAGE_LIBFOO things in your software. You can look at examples in other packages. The syntax of the Config.in file is the same as the one for the kernel Kconfig file. The documentation for this syntax is - available at http://lxr.free-electrons.com/source/Documentation/kbuild/kconfig-language.txt + available at + http://lxr.free-electrons.com/source/Documentation/kbuild/kconfig-language.txt +Finally you have to add your new
libfoo/Config.in
topackage/Config.in
(or in a category subdirectory if