package/mesa3d-demos: bump version to 9.0.0

Release notes:
https://lists.freedesktop.org/archives/mesa-announce/2023-March/000711.html

Rebased patch, switched tarball to xz.

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Bernd Kuhls 2023-07-09 09:55:43 +02:00 committed by Thomas Petazzoni
parent c1a7079a23
commit 80304d9911
3 changed files with 23 additions and 17 deletions

View File

@ -9,6 +9,8 @@ This patch is a port of [1] for the new meson build system.
https://git.busybox.net/buildroot/tree/package/mesa3d-demos/0001-demos-makes-opengl-an-optional-component.patch?h=2022.08
Signed-off-by: Julien Olivain <ju.o@free.fr>
[Bernd: rebased for version 9.0.0]
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
meson.build | 19 ++++++++++++-------
meson_options.txt | 1 +
@ -20,7 +22,7 @@ diff --git a/meson.build b/meson.build
index e1968fab..a15699d6 100644
--- a/meson.build
+++ b/meson.build
@@ -38,7 +38,10 @@ add_project_arguments(
@@ -39,7 +39,10 @@ add_project_arguments(
dep_m = cc.find_library('m', required : false)
dep_winmm = cc.find_library('winmm', required : false)
@ -30,30 +32,34 @@ index e1968fab..a15699d6 100644
+ add_project_arguments('-DEGL_NO_X11=1', language: 'c')
+endif
dep_epoll = dependency('epoll-shim', required : false)
dep_gles1 = dependency('glesv1_cm', required : get_option('gles1'))
dep_gles2 = dependency('glesv2', required : get_option('gles2'))
@@ -75,13 +78,15 @@ endif
@@ -87,15 +87,17 @@
dep_threads = dependency('threads')
-dep_glu = dependency('glu', required : dep_x11.found())
-if not dep_glu.found()
-dep_glu = dependency('glu', required : false)
-# GLU is part of OpenGL.Framework
-if not dep_glu.found() and host_machine.system() != 'darwin'
- _glu_name = 'GLU'
- if host_machine.system() == 'windows'
- _glu_name = 'glu32'
+if dep_gl.found()
+ dep_glu = dependency('glu', required : dep_x11.found())
+ if not dep_glu.found()
+ dep_glu = dependency('glu', required : false)
+ # GLU is part of OpenGL.Framework
+ if not dep_glu.found() and host_machine.system() != 'darwin'
+ _glu_name = 'GLU'
+ if host_machine.system() == 'windows'
+ _glu_name = 'glu32'
+ endif
+ dep_glu = cc.find_library(_glu_name, has_headers: 'GL/glu.h')
+ dep_glu = cc.find_library(_glu_name, has_headers: 'GL/glu.h',
+ required : dep_x11.found())
endif
- dep_glu = cc.find_library(_glu_name, has_headers: 'GL/glu.h')
- dep_glu = cc.find_library(_glu_name, has_headers: 'GL/glu.h',
- required : dep_x11.found())
endif
# GBM is needed for EGL on KMS
dep_glx = dependency('glx', required: false, disabler : true)
diff --git a/meson_options.txt b/meson_options.txt
index ddadd2e3..f5405698 100644
--- a/meson_options.txt
@ -64,7 +70,7 @@ index ddadd2e3..f5405698 100644
+option('gl', type : 'feature')
option('gles1', type : 'feature')
option('gles2', type : 'feature')
option('osmesa', type : 'feature')
option('glut', type : 'feature')
diff --git a/src/egl/meson.build b/src/egl/meson.build
index d1846921..42bf8ecd 100644
--- a/src/egl/meson.build

View File

@ -1,3 +1,3 @@
# From https://lists.freedesktop.org/archives/mesa-announce/2022-May/000677.html
sha256 cea2df0a80f09a30f635c4eb1a672bf90c5ddee0b8e77f4d70041668ef71aac1 mesa-demos-8.5.0.tar.bz2
sha512 df6a7f09638ca389d6e8bc569e599dcc59c9aa280bcfb95976d83e5cd3edfe74bb3a31f0953956dc16faa540ee5b09990e3377e1341d836fc527e50ace6e60b8 mesa-demos-8.5.0.tar.bz2
# From https://lists.freedesktop.org/archives/mesa-announce/2023-March/000711.html
sha256 3046a3d26a7b051af7ebdd257a5f23bfeb160cad6ed952329cdff1e9f1ed496b mesa-demos-9.0.0.tar.xz
sha512 af33ef72a521416e39d93370b2b4ccb768f08084c9e4c0aa62868210d9465c858e5cb8e5d23952295a3073946f609eb8723ee60b39dd9fb6696c4e45aafbb2c1 mesa-demos-9.0.0.tar.xz

View File

@ -4,9 +4,9 @@
#
################################################################################
MESA3D_DEMOS_VERSION = 8.5.0
MESA3D_DEMOS_SOURCE = mesa-demos-$(MESA3D_DEMOS_VERSION).tar.bz2
MESA3D_DEMOS_SITE = https://archive.mesa3d.org/demos/$(MESA3D_DEMOS_VERSION)
MESA3D_DEMOS_VERSION = 9.0.0
MESA3D_DEMOS_SOURCE = mesa-demos-$(MESA3D_DEMOS_VERSION).tar.xz
MESA3D_DEMOS_SITE = https://archive.mesa3d.org/demos
MESA3D_DEMOS_DEPENDENCIES = host-pkgconf
MESA3D_DEMOS_LICENSE = MIT