ntp: add patch to fix -fPIC issue
This commit adds a patch that fixes the build on AArch64 and MIPS of the ntp package, which was caused by some parts of ntp being built without -fPIC. Fixes: [aarch64] http://autobuild.buildroot.net/results/866b1d28595efd8b6becf83d0a64b596538d58b0 [mips] http://autobuild.buildroot.net/results/c2a945855172970736a8ffea9c564f029a023344 Thanks to Romain Naour for the initial analysis. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
2677210f54
commit
7fde83cdf0
23
package/ntp/0003-ntpq-fpic.patch
Normal file
23
package/ntp/0003-ntpq-fpic.patch
Normal file
@ -0,0 +1,23 @@
|
||||
ntpq/Makefile.am: add NTP_HARD_CFLAGS
|
||||
|
||||
Pass NTP_HARD_CFLAGS when building ntpq, like in all other ntp
|
||||
modules, to make sure -fPIC is passed.
|
||||
|
||||
Originally taken from
|
||||
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=494143c3b4921a5c8b8596d58f2c8b98296bf688.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: b/ntpq/Makefile.am
|
||||
===================================================================
|
||||
--- a/ntpq/Makefile.am
|
||||
+++ b/ntpq/Makefile.am
|
||||
@@ -23,7 +23,7 @@
|
||||
ntpq_LDADD += $(LDADD_NTP)
|
||||
noinst_HEADERS= ntpq.h
|
||||
noinst_LIBRARIES= libntpq.a
|
||||
-libntpq_a_CFLAGS= -DNO_MAIN_ALLOWED -DBUILD_AS_LIB
|
||||
+libntpq_a_CFLAGS= $(NTP_HARD_CFLAGS) -DNO_MAIN_ALLOWED -DBUILD_AS_LIB
|
||||
CLEANFILES=
|
||||
DISTCLEANFILES= .version version.c config.log $(man_MANS)
|
||||
ETAGS_ARGS= Makefile.am
|
@ -21,6 +21,7 @@ NTP_CONF_OPTS = \
|
||||
--with-crypto
|
||||
|
||||
# 0002-ntp-syscalls-fallback.patch
|
||||
# 0003-ntpq-fpic.patch
|
||||
NTP_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_TOOLCHAIN_HAS_SSP),y)
|
||||
|
Loading…
Reference in New Issue
Block a user