package/ncmpc: fix build with NLS

Fixes:
 - http://autobuild.buildroot.org/results/d53978fb30d77cb4d10921bf721eff3d066567ce

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2019-04-21 19:27:16 +02:00 committed by Thomas Petazzoni
parent 1764115e78
commit 7fc5380863
2 changed files with 44 additions and 1 deletions

View File

@ -0,0 +1,38 @@
From 21ad6bf2bcb0745c25a28637449a72eee883a8e2 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 21 Apr 2019 19:19:10 +0200
Subject: [PATCH] meson.build: link with lintl if needed
Fixes:
- http://autobuild.buildroot.org/results/d53978fb30d77cb4d10921bf721eff3d066567ce
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: not sent as upstream already rejected the first patch
on atomic: https://github.com/MusicPlayerDaemon/ncmpc/pull/45]
---
meson.build | 2 ++
1 file changed, 2 insertions(+)
diff --git a/meson.build b/meson.build
index 2e6defc..28e9d29 100644
--- a/meson.build
+++ b/meson.build
@@ -42,6 +42,7 @@ else
endif
conf.set('ENABLE_NLS', enable_nls)
if enable_nls
+ intl_dep = cc.find_library('intl', required: false)
conf.set_quoted('GETTEXT_PACKAGE', meson.project_name())
subdir('po')
endif
@@ -356,6 +357,7 @@ ncmpc = executable('ncmpc',
boost_dep,
pcre_dep,
curses_dep,
+ intl_dep,
lirc_dep,
libmpdclient_dep,
],
--
2.20.1

View File

@ -8,7 +8,12 @@ NCMPC_VERSION_MAJOR = 0
NCMPC_VERSION = $(NCMPC_VERSION_MAJOR).34
NCMPC_SOURCE = ncmpc-$(NCMPC_VERSION).tar.xz
NCMPC_SITE = http://www.musicpd.org/download/ncmpc/$(NCMPC_VERSION_MAJOR)
NCMPC_DEPENDENCIES = boost host-pkgconf libmpdclient ncurses
NCMPC_DEPENDENCIES = \
boost \
host-pkgconf \
libmpdclient \
ncurses \
$(TARGET_NLS_DEPENDENCIES)
NCMPC_LICENSE = GPL-2.0+
NCMPC_LICENSE_FILES = COPYING