package/pulseaudio: fix webrtc build
Update fourth patch to avoid the following build failure with webrtc
raised since commit a40a516c8a
:
../output-1/build/pulseaudio-16.1/src/modules/echo-cancel/meson.build:13:0: ERROR: No host machine compiler for 'src/modules/echo-cancel/webrtc.cc'
That is because we removed the C++ language from the global meson.build.
Add it back to the local meson.build in echo-cancel.
The echo-cancel module is always built, but the echo-cancel meson.build
is only included if webrtc-aec is enabled. We only enable it when
webrtc-audio-processing is selected, and that package depends on C++.
Therefore, it is safe to depend on C++ in the echo-cancel meson.build.
Fixes:
- http://autobuild.buildroot.org/results/e60d72268667ed57a254d7552fa2d785e2e21726
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
2bf6b06308
commit
7fc0c327e6
@ -1,4 +1,4 @@
|
||||
From 9de058e15a4caba4939a864fb7caf67e0164f07e Mon Sep 17 00:00:00 2001
|
||||
From ac88536d7c3fde3c22933368296c9029bb67b9fc Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Mon, 25 Jul 2022 21:49:25 +0200
|
||||
Subject: [PATCH] meson.build: fix build without C++
|
||||
@ -16,8 +16,9 @@ Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status:
|
||||
https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/737]
|
||||
---
|
||||
meson.build | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
meson.build | 3 ++-
|
||||
src/modules/echo-cancel/meson.build | 2 ++
|
||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index c5135330f..8248f263b 100644
|
||||
@ -37,6 +38,19 @@ index c5135330f..8248f263b 100644
|
||||
add_project_arguments('--coverage', language: ['c', 'cpp'])
|
||||
add_project_link_arguments('--coverage', language: ['c', 'cpp'])
|
||||
endif
|
||||
diff --git a/src/modules/echo-cancel/meson.build b/src/modules/echo-cancel/meson.build
|
||||
index 641cd35e7..3b998364e 100644
|
||||
--- a/src/modules/echo-cancel/meson.build
|
||||
+++ b/src/modules/echo-cancel/meson.build
|
||||
@@ -6,6 +6,8 @@
|
||||
# '-Wl,--unresolved-symbols=ignore-in-object-files' otherwise it fails
|
||||
# at link time.
|
||||
|
||||
+add_languages('cpp')
|
||||
+
|
||||
libwebrtc_util_sources = [
|
||||
'webrtc.cc'
|
||||
]
|
||||
--
|
||||
2.35.1
|
||||
GitLab
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user