xlib_libX11: verison bump to 1.4.2 and removed patch file xlib_libX11-1.3.2-keysymdef
[Peter: AUTORECONF and --with-keysymdef no longer needed] Signed-off-by: Allan W. Nielsen <a@awn.dk> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
625e29587d
commit
7f46b19544
@ -1,35 +0,0 @@
|
||||
[patch]: configure: add --with-keysymdef argument for cross compilation
|
||||
|
||||
Based on a similar patch from Openembedded.
|
||||
|
||||
The libX11 configure script hardcodes the location to keysymdef.h as
|
||||
<prefix>/include/X11/keysymdef.h, which is fine for native compilation,
|
||||
but breaks with cross compilation as that directory is a location on
|
||||
the target, not the build host.
|
||||
|
||||
Fix it by providing an explicit --with-keysymdef=<full-path-to-file>.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>Index: libX11-1.1.5/configure.ac
|
||||
===================================================================
|
||||
Index: xlib_libX11-1.3.2/configure.ac
|
||||
===================================================================
|
||||
--- xlib_libX11-1.3.2.orig/configure.ac 2009-10-23 22:55:03.000000000 +0200
|
||||
+++ xlib_libX11-1.3.2/configure.ac 2010-05-04 16:26:39.000000000 +0200
|
||||
@@ -280,8 +280,15 @@
|
||||
# Find keysymdef.h
|
||||
#
|
||||
AC_MSG_CHECKING([keysymdef.h])
|
||||
-dir=`pkg-config --variable=includedir xproto`
|
||||
-KEYSYMDEF="$dir/X11/keysymdef.h"
|
||||
+AC_ARG_WITH(keysymdef,
|
||||
+ AC_HELP_STRING([--with-keysymdef=DIR/keysymdef.h], [The location of keysymdef.h]),
|
||||
+ KEYSYMDEF=$withval, KEYSYMDEF="")
|
||||
+
|
||||
+if test x$KEYSYMDEF = x; then
|
||||
+ dir=`pkg-config --variable=includedir xproto`
|
||||
+ KEYSYMDEF="$dir/X11/keysymdef.h"
|
||||
+fi
|
||||
+
|
||||
if test -f "$KEYSYMDEF"; then
|
||||
AC_MSG_RESULT([$KEYSYMDEF])
|
||||
else
|
@ -4,16 +4,14 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
XLIB_LIBX11_VERSION = 1.3.2
|
||||
XLIB_LIBX11_VERSION = 1.4.2
|
||||
XLIB_LIBX11_SOURCE = libX11-$(XLIB_LIBX11_VERSION).tar.bz2
|
||||
XLIB_LIBX11_SITE = http://xorg.freedesktop.org/releases/individual/lib
|
||||
XLIB_LIBX11_AUTORECONF = YES
|
||||
XLIB_LIBX11_INSTALL_STAGING = YES
|
||||
XLIB_LIBX11_DEPENDENCIES = libxcb xutil_util-macros xlib_xtrans xlib_libXau xlib_libXdmcp xproto_kbproto xproto_xproto xproto_xextproto xproto_inputproto xproto_xf86bigfontproto xproto_xcmiscproto host-xproto_xproto
|
||||
XLIB_LIBX11_CONF_OPT = \
|
||||
--disable-malloc0returnsnull \
|
||||
--with-xcb \
|
||||
--with-keysymdef=$(STAGING_DIR)/usr/include/X11/keysymdef.h \
|
||||
--disable-specs
|
||||
|
||||
HOST_XLIB_LIBX11_CONF_OPT = \
|
||||
|
Loading…
Reference in New Issue
Block a user