qextserialport: new package
[Peter: adjust for BR changes] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
51f3425e3d
commit
7eca96e65f
@ -138,6 +138,7 @@ source "package/qt/Config.in"
|
||||
|
||||
if BR2_PACKAGE_QT
|
||||
comment "QT libraries and helper libraries"
|
||||
source "package/qextserialport/Config.in"
|
||||
source "package/qtuio/Config.in"
|
||||
endif
|
||||
|
||||
|
9
package/qextserialport/Config.in
Normal file
9
package/qextserialport/Config.in
Normal file
@ -0,0 +1,9 @@
|
||||
config BR2_PACKAGE_QEXTSERIALPORT
|
||||
bool "qextserialport"
|
||||
# Qt is a big library, we don't want to select it
|
||||
# automatically without the user knowing
|
||||
depends on BR2_PACKAGE_QT
|
||||
help
|
||||
A Qt library to manage serial ports
|
||||
|
||||
http://code.google.com/p/qextserialport/
|
15
package/qextserialport/qextserialport-main-include.patch
Normal file
15
package/qextserialport/qextserialport-main-include.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Create a main include file QExtSerialPort
|
||||
|
||||
This main include file will be installed in
|
||||
<QExtSerialPort/QExtSerialPort> so that Qt applications can use this
|
||||
library by including header files in a Qt-like style.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: qextserialport-ef4af2a2ee3f/src/QExtSerialPort
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ qextserialport-ef4af2a2ee3f/src/QExtSerialPort
|
||||
@@ -0,0 +1,2 @@
|
||||
+#include "qextserialport.h"
|
||||
+#include "qextserialenumerator.h"
|
17
package/qextserialport/qextserialport-no-examples.patch
Normal file
17
package/qextserialport/qextserialport-no-examples.patch
Normal file
@ -0,0 +1,17 @@
|
||||
Disable compilation of examples
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: qextserialport-ef4af2a2ee3f/qextserialport.pro
|
||||
===================================================================
|
||||
--- qextserialport-ef4af2a2ee3f.orig/qextserialport.pro
|
||||
+++ qextserialport-ef4af2a2ee3f/qextserialport.pro
|
||||
@@ -1,7 +1,4 @@
|
||||
#
|
||||
TEMPLATE = subdirs
|
||||
CONFIG += ordered
|
||||
-SUBDIRS = src \
|
||||
- examples/enumerator \
|
||||
- examples/event
|
||||
-
|
||||
+SUBDIRS = src
|
19
package/qextserialport/qextserialport-pkgconfig.patch
Normal file
19
package/qextserialport/qextserialport-pkgconfig.patch
Normal file
@ -0,0 +1,19 @@
|
||||
Add a pkgconfig file to ease usage with applications
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: qextserialport-ef4af2a2ee3f/qextserialport.pc
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ qextserialport-ef4af2a2ee3f/qextserialport.pc
|
||||
@@ -0,0 +1,10 @@
|
||||
+prefix=/usr
|
||||
+exec_prefix=${prefix}
|
||||
+libdir=${prefix}/lib
|
||||
+includedir=${prefix}/include/QExtSerialPort
|
||||
+
|
||||
+Name: QtExtSerialPort
|
||||
+Description: QtExtSerialPort library
|
||||
+Version: 1.2.0
|
||||
+Libs: -L${libdir} -lqextserialport
|
||||
+Cflags: -I${includedir}
|
35
package/qextserialport/qextserialport.mk
Normal file
35
package/qextserialport/qextserialport.mk
Normal file
@ -0,0 +1,35 @@
|
||||
#############################################################
|
||||
#
|
||||
# qextserialport
|
||||
#
|
||||
#############################################################
|
||||
|
||||
QEXTSERIALPORT_VERSION = ef4af2a2ee3f
|
||||
QEXTSERIALPORT_SITE = https://qextserialport.googlecode.com/hg/
|
||||
QEXTSERIALPORT_SITE_METHOD = hg
|
||||
|
||||
QEXTSERIALPORT_DEPENDENCIES = qt
|
||||
|
||||
QEXTSERIALPORT_INSTALL_STAGING = YES
|
||||
|
||||
define QEXTSERIALPORT_CONFIGURE_CMDS
|
||||
(cd $(@D); $(QT_QMAKE))
|
||||
endef
|
||||
|
||||
define QEXTSERIALPORT_BUILD_CMDS
|
||||
$(MAKE) -C $(@D)
|
||||
endef
|
||||
|
||||
define QEXTSERIALPORT_INSTALL_STAGING_CMDS
|
||||
mkdir -p $(STAGING_DIR)/usr/include/QExtSerialPort
|
||||
cp $(@D)/src/*.h $(STAGING_DIR)/usr/include/QExtSerialPort/
|
||||
cp $(@D)/src/QExtSerialPort $(STAGING_DIR)/usr/include/QExtSerialPort/
|
||||
cp -a $(@D)/src/build/*.so* $(STAGING_DIR)/usr/lib/
|
||||
cp $(@D)/qextserialport.pc $(STAGING_DIR)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define QEXTSERIALPORT_INSTALL_TARGET_CMDS
|
||||
cp -a $(@D)/src/build/*.so.* $(TARGET_DIR)/usr/lib
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user