tovid: new package
The tovid suite, also known simply as tovid, is a collection of shell and Python scripts for creating DVDs and (S)VCDs. It is pronounced "to vid" (because it converts to video disc formats). [Thomas: - remove largefile dependency - properly propagate mplayer and ffmpeg dependencies. - fix license: it's GPLv2+, not GPLv2.] Signed-off-by: Steve Kenton <skenton@ou.edu> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
d2a8a14b97
commit
7de0f6a677
@ -33,6 +33,7 @@ menu "Audio and video applications"
|
||||
source "package/pulseaudio/Config.in"
|
||||
source "package/sox/Config.in"
|
||||
source "package/tidsp-binaries/Config.in"
|
||||
source "package/tovid/Config.in"
|
||||
source "package/tstools/Config.in"
|
||||
source "package/twolame/Config.in"
|
||||
source "package/upmpdcli/Config.in"
|
||||
|
25
package/tovid/0001-manpage.patch
Normal file
25
package/tovid/0001-manpage.patch
Normal file
@ -0,0 +1,25 @@
|
||||
setup.py: disable man page to kill txt2tags SVN checkout dependency
|
||||
|
||||
Signed-off-by: Steve Kenton <skenton@ou.edu>
|
||||
|
||||
+diff -pruN tovid-3534.ori/setup.py tovid-3534/setup.py
|
||||
--- tovid-3534.ori/setup.py 2013-04-14 09:52:08.000000000 -0500
|
||||
+++ tovid-3534/setup.py 2015-03-21 09:39:14.880173176 -0500
|
||||
@@ -186,7 +186,7 @@ class BuildTovidInit (Command):
|
||||
|
||||
# Build tovid-init with regular 'build' command
|
||||
build.sub_commands.append(('build_tovid_init', None))
|
||||
-build.sub_commands.append(('build_docs', None))
|
||||
+#build.sub_commands.append(('build_docs', None))
|
||||
|
||||
# The actual setup
|
||||
setup(
|
||||
@@ -244,8 +244,6 @@ setup(
|
||||
'src/tovid.ini',
|
||||
]),
|
||||
# Manual page
|
||||
- ('share/man/man1',
|
||||
- ['docs/man/tovid.1']),
|
||||
# Desktop shortcut
|
||||
('share/applications',
|
||||
['tovidgui.desktop',
|
40
package/tovid/Config.in
Normal file
40
package/tovid/Config.in
Normal file
@ -0,0 +1,40 @@
|
||||
config BR2_PACKAGE_TOVID
|
||||
bool "tovid"
|
||||
depends on BR2_USE_MMU # fork()
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||
depends on BR2_INET_IPV6 # ffmpeg
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on BR2_USE_WCHAR
|
||||
depends on BR2_PACKAGE_PYTHON || BR2_PACKAGE_PYTHON3
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201305 # ffmpeg
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_NIOSII201405 # ffmpeg
|
||||
depends on BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS
|
||||
# The below dependencies are runtime dependencies only
|
||||
select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # procps_ng
|
||||
select BR2_PACKAGE_DVDAUTHOR
|
||||
select BR2_PACKAGE_DVDRW_TOOLS
|
||||
select BR2_PACKAGE_FFMPEG
|
||||
select BR2_PACKAGE_IMAGEMAGICK
|
||||
select BR2_PACKAGE_JPEG
|
||||
select BR2_PACKAGE_MJPEGTOOLS
|
||||
select BR2_PACKAGE_MPLAYER
|
||||
select BR2_PACKAGE_PROCPS_NG # pgrep and pkill
|
||||
select BR2_PACKAGE_SOX
|
||||
help
|
||||
The tovid suite, also known simply as tovid, is a collection
|
||||
of shell and Python scripts for creating DVDs and
|
||||
(S)VCDs. It is pronounced "to vid" (because it converts to
|
||||
video disc formats).
|
||||
|
||||
http://tovid.wikia.com/wiki/Installing_tovid
|
||||
|
||||
comment "tovid needs a toolchain w/ threads, IPv6, C++, wchar"
|
||||
depends on BR2_USE_MMU
|
||||
depends on BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS \
|
||||
|| !BR2_INET_IPV6 || !BR2_INSTALL_LIBSTDCPP \
|
||||
|| !BR2_USE_WCHAR
|
||||
|
||||
comment "tovid depends on python or python3"
|
||||
depends on !BR2_PACKAGE_PYTHON && !BR2_PACKAGE_PYTHON3
|
||||
depends on BR2_PACKAGE_MPLAYER_ARCH_SUPPORTS
|
14
package/tovid/tovid.mk
Normal file
14
package/tovid/tovid.mk
Normal file
@ -0,0 +1,14 @@
|
||||
################################################################################
|
||||
#
|
||||
# tovid
|
||||
#
|
||||
################################################################################
|
||||
|
||||
TOVID_SITE = http://tovid.googlecode.com/svn/trunk/tovid
|
||||
TOVID_SITE_METHOD = svn
|
||||
TOVID_VERSION = 3534
|
||||
TOVID_LICENSE = GPLv2+
|
||||
TOVID_LICENSE_FILES = COPYING
|
||||
TOVID_SETUP_TYPE = distutils
|
||||
|
||||
$(eval $(python-package))
|
Loading…
Reference in New Issue
Block a user