Revert "bctoolbox: fix typos and logic error"
This reverts commit 5c4d3560b9
.
Although the patch fixes the build error it does not set the flags for
Libs.private properly. A follow-up patch will provide a better solution
for this issue.
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
a3a2dbc409
commit
7dd52cabc3
@ -1,18 +0,0 @@
|
||||
Fix a typo in the variable name. Only check path for a single library name.
|
||||
|
||||
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
|
||||
|
||||
diff -Nur bctoolbox-0.4.0.orig/CMakeLists.txt bctoolbox-0.4.0/CMakeLists.txt
|
||||
--- bctoolbox-0.4.0.orig/CMakeLists.txt 2016-10-06 17:30:41.000000000 +0200
|
||||
+++ bctoolbox-0.4.0/CMakeLists.txt 2017-02-13 23:30:38.641288032 +0100
|
||||
@@ -103,8 +103,8 @@
|
||||
endif()
|
||||
|
||||
if(MBEDTLS_FOUND)
|
||||
- get_filename_component(mbedtls_library_path "${MBEDTLS_LIBRARIES}" PATH)
|
||||
- set(LIBS_PRIVATE "${LIBS_PRIVATE} -L${mbedlts_library_path}")
|
||||
+ get_filename_component(mbedtls_library_path "${MBEDTLS_LIBRARY}" PATH)
|
||||
+ set(LIBS_PRIVATE "${LIBS_PRIVATE} -L${mbedtls_library_path}")
|
||||
endif()
|
||||
if(POLARSSL_FOUND)
|
||||
get_filename_component(polarssl_library_path "${POLARSSL_LIBRARIES}" PATH)
|
Loading…
Reference in New Issue
Block a user