package/unifdef: add new package

A small package that does "Selectively remove C preprocessor conditionals".

The package will be needed for the upcoming webkitgtk 2.40.0 release.
I personally added it to get started with 2.39.2.

See: f76a7e30e5
Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
[Peter: use prefix=]
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas Devoogdt 2022-12-12 16:35:34 +01:00 committed by Peter Korsgaard
parent 3ddf15854d
commit 7dbe844bae
3 changed files with 54 additions and 0 deletions

View File

@ -0,0 +1,31 @@
From b5e4229918c13bc0c11a523105cdb3a464337b37 Mon Sep 17 00:00:00 2001
From: Thomas Devoogdt <thomas.devoogdt@barco.com>
Date: Mon, 12 Dec 2022 12:59:59 +0100
Subject: [PATCH] Makefile: fix error on install
ln: failed to create symbolic link '/home/thomas/Documents/buildroot/output/host/share/man/man1/unifdefall.1': File exists
Seen while trying to add this package to buildroot.org.
(upstream: https://github.com/fanf2/unifdef/pull/16)
Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 36c7028..485927a 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ install: unifdef unifdefall.sh unifdef.1
: manual
install -m 755 -d ${man1dest}
install -m 644 unifdef.1 ${man1dest}/
- ln -s unifdef.1 ${man1dest}/unifdefall.1
+ ln -f -s unifdef.1 ${man1dest}/unifdefall.1
clean:
rm -f unifdef version.h
--
2.38.1

View File

@ -0,0 +1,3 @@
# Locally computed
sha256 fba564a24db7b97ebe9329713ac970627b902e5e9e8b14e19e024eb6e278d10b unifdef-2.12.tar.gz
sha256 37ed46a39446b15b08af418fda23b75c27a769d5aad236d817ee7522cc9caeee COPYING

View File

@ -0,0 +1,20 @@
################################################################################
#
# unifdef
#
################################################################################
UNIFDEF_VERSION = 2.12
UNIFDEF_SITE = https://dotat.at/prog/unifdef
UNIFDEF_LICENSE = BSD-2-Clause
UNIFDEF_LICENSE_FILES = COPYING
define HOST_UNIFDEF_BUILD_CMDS
$(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D)
endef
define HOST_UNIFDEF_INSTALL_CMDS
$(HOST_CONFIGURE_OPTS) $(MAKE) -C $(@D) prefix=$(HOST_DIR) install
endef
$(eval $(host-generic-package))