package/assimp: bump to version 5.2.5

Replace disable -Werror patch with new cmake option:
-DASSIMP_WARNINGS_AS_ERRORS=OFF

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
James Hilliard 2022-10-07 06:47:03 -06:00 committed by Peter Korsgaard
parent bd9f138b5a
commit 7d843d9cc0
3 changed files with 3 additions and 41 deletions

View File

@ -1,39 +0,0 @@
From 5146e1c4d58174e302dbdcf2a85c2023be1cffc6 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Fri, 10 Dec 2021 15:15:30 +0100
Subject: [PATCH] code: disable -Werror
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Fixes:
.../build/assimp-5.1.3/code/PostProcessing/TriangulateProcess.cpp:285:50: error: argument 1 value 4294967294 exceeds maximum object size 2147483647 [-Werror=alloc-size-larger-than=]
285 | std::unique_ptr<bool[]> done(new bool[max_out]);
| ^
[...]
.../host/opt/ext-toolchain/powerpc-buildroot-linux-uclibc/include/c++/9.3.0/new:127:26: note: in a call to allocation function void* operator new [](std::size_t) declared here
127 | _GLIBCXX_NODISCARD void* operator new[](std::size_t) _GLIBCXX_THROW (std::bad_alloc)
| ^~~~~~~~
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
code/CMakeLists.txt | 2 --
1 file changed, 2 deletions(-)
diff --git a/code/CMakeLists.txt b/code/CMakeLists.txt
index e45bf8a2a..f71b6583d 100644
--- a/code/CMakeLists.txt
+++ b/code/CMakeLists.txt
@@ -1167,8 +1167,6 @@ TARGET_USE_COMMON_OUTPUT_DIRECTORY(assimp)
# enable warnings as errors ########################################
IF (MSVC)
TARGET_COMPILE_OPTIONS(assimp PRIVATE /WX)
-ELSE()
- TARGET_COMPILE_OPTIONS(assimp PRIVATE -Werror)
ENDIF()
# adds C_FLAGS required to compile zip.c on old GCC 4.x compiler
--
2.34.1

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 c9cbbc8589639cd8c13f65e94a90422a70454e8fa150cf899b6038ba86e9ecff assimp-5.2.1.tar.gz
sha256 b5219e63ae31d895d60d98001ee5bb809fb2c7b2de1e7f78ceeb600063641e1a assimp-5.2.5.tar.gz
sha256 147874443d242b4e2bae97036e26ec9d6b37f706174c1bd5ecfcc8c1294cef51 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
ASSIMP_VERSION = 5.2.1
ASSIMP_VERSION = 5.2.5
ASSIMP_SITE = $(call github,assimp,assimp,v$(ASSIMP_VERSION))
ASSIMP_LICENSE = BSD-3-Clause
ASSIMP_LICENSE_FILES = LICENSE
@ -39,6 +39,7 @@ ASSIMP_CXXFLAGS += -O0
endif
ASSIMP_CONF_OPTS += -DASSIMP_BUILD_TESTS=OFF \
-DASSIMP_WARNINGS_AS_ERRORS=OFF \
-DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) $(ASSIMP_CXXFLAGS)"
$(eval $(cmake-package))