Add irda-utils package, Courtesy of Benjamin Tietz
This commit is contained in:
parent
9538749582
commit
7c48a8c33b
@ -136,6 +136,7 @@ source "package/dropbear/Config.in"
|
|||||||
source "package/ethtool/Config.in"
|
source "package/ethtool/Config.in"
|
||||||
source "package/haserl/Config.in"
|
source "package/haserl/Config.in"
|
||||||
source "package/hostap/Config.in"
|
source "package/hostap/Config.in"
|
||||||
|
source "package/irda-utils/Config.in"
|
||||||
source "package/iperf/Config.in"
|
source "package/iperf/Config.in"
|
||||||
source "package/iproute2/Config.in"
|
source "package/iproute2/Config.in"
|
||||||
source "package/ipsec-tools/Config.in"
|
source "package/ipsec-tools/Config.in"
|
||||||
|
51
package/irda-utils/Config.in
Normal file
51
package/irda-utils/Config.in
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
menuconfig BR2_PACKAGE_IRDA_UTILS
|
||||||
|
bool "irda_utils"
|
||||||
|
default n
|
||||||
|
help
|
||||||
|
Tools for accessing the irda-Subsystem of the Linux-Kernel
|
||||||
|
|
||||||
|
if BR2_PACKAGE_IRDA_UTILS
|
||||||
|
config IRDA_IRATTACH
|
||||||
|
bool "irattach"
|
||||||
|
default y
|
||||||
|
help
|
||||||
|
To start the Irda-Subsystem in SIR-Mode you may need this
|
||||||
|
|
||||||
|
config IRDA_IRDAPING
|
||||||
|
bool "irdaping"
|
||||||
|
default n
|
||||||
|
help
|
||||||
|
what ping is for networks is irdaping for Irda
|
||||||
|
|
||||||
|
config IRDA_IRNETD
|
||||||
|
bool "irnetd"
|
||||||
|
default n
|
||||||
|
help
|
||||||
|
Needed for Networking over Irda
|
||||||
|
|
||||||
|
config IRDA_IRDADUMP
|
||||||
|
bool "irdadump"
|
||||||
|
default n
|
||||||
|
help
|
||||||
|
Like tcpdump, but for infrared connections
|
||||||
|
|
||||||
|
config IRDA_FINDCHIP
|
||||||
|
bool "findchip"
|
||||||
|
default n
|
||||||
|
|
||||||
|
config IRDA_PSION
|
||||||
|
bool "support psion-dongle"
|
||||||
|
default n
|
||||||
|
|
||||||
|
config IRDA_TEKRAM
|
||||||
|
bool "support tekram-dongle"
|
||||||
|
default n
|
||||||
|
|
||||||
|
config IRDA_SMCINIT
|
||||||
|
bool "support toshiba-laptops"
|
||||||
|
default n
|
||||||
|
help
|
||||||
|
Some Toshiba Laptops have buggy BIOSes which didn't initialize
|
||||||
|
Irda. This may help those.
|
||||||
|
|
||||||
|
endif
|
12
package/irda-utils/irda-utils-0.9.18-install_irnetd.patch
Normal file
12
package/irda-utils/irda-utils-0.9.18-install_irnetd.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Naur irda-utils-0.9.18.orig/irnetd/Makefile irda-utils-0.9.18/irnetd/Makefile
|
||||||
|
--- irda-utils-0.9.18.orig/irnetd/Makefile 2006-07-11 08:16:06.000000000 +0200
|
||||||
|
+++ irda-utils-0.9.18/irnetd/Makefile 2007-06-08 20:39:25.000000000 +0200
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
|
||||||
|
install: irnetd
|
||||||
|
$(prn_install)
|
||||||
|
- $(ECMD) install irnetd /usr/sbin/
|
||||||
|
+ $(ECMD) install irnetd $(ROOT)/usr/sbin/
|
||||||
|
|
||||||
|
|
||||||
|
clean:
|
57
package/irda-utils/irda.mk
Normal file
57
package/irda-utils/irda.mk
Normal file
@ -0,0 +1,57 @@
|
|||||||
|
#############################################################
|
||||||
|
#
|
||||||
|
# irda-utils
|
||||||
|
#
|
||||||
|
#############################################################
|
||||||
|
IRDA_UTILS_VERSION:=0.9.18
|
||||||
|
IRDA_UTILS_SOURCE:=irda-utils-$(IRDA_UTILS_VERSION).tar.gz
|
||||||
|
IRDA_UTILS_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/irda/$(IRDA_UTILS_SOURCE)
|
||||||
|
IRDA_UTILS_DIR:=$(BUILD_DIR)/irda-utils-$(IRDA_UTILS_VERSION)
|
||||||
|
|
||||||
|
ifeq ($(IRDA_IRATTACH),y)
|
||||||
|
IRDA_DIRS += irattach
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_IRDAPING),y)
|
||||||
|
IRDA_DIRS += irdaping
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_IRNETD),y)
|
||||||
|
IRDA_DIRS += irnetd
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_PSION),y)
|
||||||
|
IRDA_DIRS += psion
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_TEKRAM),y)
|
||||||
|
IRDA_DIRS += tekram
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_FINDCHIP),y)
|
||||||
|
IRDA_DIRS += findchip
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_IRDADUMP),y)
|
||||||
|
IRDA_DIRS += irdadump
|
||||||
|
endif
|
||||||
|
ifeq ($(IRDA_SMCINIT),y)
|
||||||
|
IRDA_DIRS += smcinit
|
||||||
|
endif
|
||||||
|
|
||||||
|
IRDA_UTILS_MAKE_OPT:=-e "DIRS=$(IRDA_DIRS)"
|
||||||
|
IRDA_UTILS_MAKE_ENV:=CC=$(TARGET_CC) LD=$(TARGET_LD) AR=$(TARGET_AR) RANLIB=$(TARGET_RANLIB) ROOT=$(TARGET_DIR) PREFIX=$(TARGET_DIR)
|
||||||
|
|
||||||
|
# Since there is no configure-script
|
||||||
|
|
||||||
|
$(IRDA_UTILS_DIR)/.configured: $(IRDA_UTILS_DIR)/.patched
|
||||||
|
touch $@
|
||||||
|
|
||||||
|
irda-utils: uclibc $(DL_DIR)/$(IRDA_UTILS_SOURCE) $(IRDA_UTILS_DIR)/.installed
|
||||||
|
|
||||||
|
irda-utils-clean: $(IRDA_UTILS_DIR)/.clean
|
||||||
|
|
||||||
|
irda-utils-dirclean: $(IRDA_UTILS_DIR)/.dirclean
|
||||||
|
|
||||||
|
#############################################################
|
||||||
|
#
|
||||||
|
# Toplevel Makefile options
|
||||||
|
#
|
||||||
|
#############################################################
|
||||||
|
ifeq ($(strip $(BR2_PACKAGE_IRDA_UTILS)),y)
|
||||||
|
TARGETS+=irda-utils
|
||||||
|
endif
|
Loading…
Reference in New Issue
Block a user