package/tovid: remove package
Build is broken: "It seems that you are using `distutils.command.build` to add new subcommands. Using `distutils` directly is considered deprecated, please use `setuptools.command.build`. By 2023-Dec-13, you need to update your project and remove deprecated calls or your builds will no longer be supported." The last commit for this package occured on May, 30th, 2016. The last issue was opened Jan, 31st, 2017 and was unanswered. Fixes: http://autobuild.buildroot.net/results/b57/b571d7838950e0b5ca67106cbcd9ba61b4f04a48/ Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
0368cd8163
commit
7be241b49c
@ -146,6 +146,12 @@ endif
|
||||
|
||||
comment "Legacy options removed in 2023.08"
|
||||
|
||||
config BR2_PACKAGE_TOVID
|
||||
bool "tovid removed"
|
||||
select BR2_LEGACY
|
||||
help
|
||||
tovid was removed
|
||||
|
||||
config BR2_PACKAGE_LIBASPLIB
|
||||
bool "libasplib removed"
|
||||
select BR2_LEGACY
|
||||
|
@ -2728,7 +2728,6 @@ F: package/dvdauthor/
|
||||
F: package/dvdrw-tools/
|
||||
F: package/memtest86/
|
||||
F: package/mjpegtools/
|
||||
F: package/tovid/
|
||||
F: package/udftools/
|
||||
F: package/xorriso/
|
||||
|
||||
|
@ -54,7 +54,6 @@ menu "Audio and video applications"
|
||||
source "package/speechd/Config.in"
|
||||
source "package/squeezelite/Config.in"
|
||||
source "package/tinycompress/Config.in"
|
||||
source "package/tovid/Config.in"
|
||||
source "package/tstools/Config.in"
|
||||
source "package/twolame/Config.in"
|
||||
source "package/udpxy/Config.in"
|
||||
|
@ -1,25 +0,0 @@
|
||||
setup.py: disable man page to kill txt2tags SVN checkout dependency
|
||||
|
||||
Signed-off-by: Steve Kenton <skenton@ou.edu>
|
||||
|
||||
+diff -pruN tovid-3534.ori/setup.py tovid-3534/setup.py
|
||||
--- tovid-3534.ori/setup.py 2013-04-14 09:52:08.000000000 -0500
|
||||
+++ tovid-3534/setup.py 2015-03-21 09:39:14.880173176 -0500
|
||||
@@ -186,7 +186,7 @@ class BuildTovidInit (Command):
|
||||
|
||||
# Build tovid-init with regular 'build' command
|
||||
build.sub_commands.append(('build_tovid_init', None))
|
||||
-build.sub_commands.append(('build_docs', None))
|
||||
+#build.sub_commands.append(('build_docs', None))
|
||||
|
||||
# The actual setup
|
||||
setup(
|
||||
@@ -244,8 +244,6 @@ setup(
|
||||
'src/tovid.ini',
|
||||
]),
|
||||
# Manual page
|
||||
- ('share/man/man1',
|
||||
- ['docs/man/tovid.1']),
|
||||
# Desktop shortcut
|
||||
('share/applications',
|
||||
['tovidgui.desktop',
|
@ -1,50 +0,0 @@
|
||||
config BR2_PACKAGE_TOVID
|
||||
bool "tovid"
|
||||
depends on BR2_USE_MMU # fork()
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # mpv
|
||||
depends on BR2_INSTALL_LIBSTDCPP
|
||||
depends on BR2_USE_WCHAR
|
||||
depends on BR2_PACKAGE_PYTHON3
|
||||
depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
|
||||
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # mpv
|
||||
depends on BR2_TOOLCHAIN_HAS_ATOMIC # mpv
|
||||
depends on BR2_TOOLCHAIN_HAS_SYNC_4 # mpv
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC # mpv
|
||||
# The below dependencies are runtime dependencies only
|
||||
select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # procps_ng
|
||||
select BR2_PACKAGE_DVDAUTHOR
|
||||
select BR2_PACKAGE_DVDRW_TOOLS
|
||||
select BR2_PACKAGE_FFMPEG
|
||||
select BR2_PACKAGE_IMAGEMAGICK
|
||||
select BR2_PACKAGE_JPEG
|
||||
select BR2_PACKAGE_MJPEGTOOLS
|
||||
select BR2_PACKAGE_MPV
|
||||
select BR2_PACKAGE_PROCPS_NG # pgrep and pkill
|
||||
select BR2_PACKAGE_SOX
|
||||
help
|
||||
The tovid suite, also known simply as tovid, is a collection
|
||||
of shell and Python scripts for creating DVDs and
|
||||
(S)VCDs. It is pronounced "to vid" (because it converts to
|
||||
video disc formats).
|
||||
|
||||
http://tovid.wikia.com/wiki/Installing_tovid
|
||||
|
||||
comment "tovid needs a toolchain w/ NPTL, C++, wchar, gcc >= 4.9"
|
||||
depends on BR2_USE_MMU
|
||||
depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
|
||||
depends on BR2_TOOLCHAIN_HAS_ATOMIC
|
||||
depends on BR2_TOOLCHAIN_HAS_SYNC_4
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
|
||||
|| !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 \
|
||||
|| !BR2_INSTALL_LIBSTDCPP \
|
||||
|| !BR2_USE_WCHAR
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC
|
||||
|
||||
comment "tovid depends on python3"
|
||||
depends on !BR2_PACKAGE_PYTHON3
|
||||
depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS
|
||||
depends on BR2_TOOLCHAIN_HAS_ATOMIC
|
||||
depends on BR2_TOOLCHAIN_HAS_SYNC_4
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || \
|
||||
!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
|
||||
depends on !BR2_TOOLCHAIN_EXTERNAL_SYNOPSYS_ARC
|
@ -1,3 +0,0 @@
|
||||
# Locally calculated
|
||||
sha256 c03a746a3592a656bab0be4045da114a4231eb0f858d6c18503dac64049fbe48 tovid-87c676f4aadb7303d2cd921380b054bafa4b85bb.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
@ -1,13 +0,0 @@
|
||||
################################################################################
|
||||
#
|
||||
# tovid
|
||||
#
|
||||
################################################################################
|
||||
|
||||
TOVID_VERSION = 87c676f4aadb7303d2cd921380b054bafa4b85bb
|
||||
TOVID_SITE = $(call github,tovid-suite,tovid,$(TOVID_VERSION))
|
||||
TOVID_LICENSE = GPL-2.0+
|
||||
TOVID_LICENSE_FILES = COPYING
|
||||
TOVID_SETUP_TYPE = distutils
|
||||
|
||||
$(eval $(python-package))
|
Loading…
Reference in New Issue
Block a user