package/python3: add optional support for berkeleydb
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
66ddec89e8
commit
7bd1b51d07
@ -0,0 +1,30 @@
|
||||
From cf4d7fd9f7cb6c1ced32ee323b2b5755640051b7 Mon Sep 17 00:00:00 2001
|
||||
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
Date: Sat, 11 Apr 2020 22:01:40 +0200
|
||||
Subject: [PATCH] Add an option to disable the berkeleydb module
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
---
|
||||
configure.ac | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 72c1d86e82..8c3912d237 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3326,6 +3326,12 @@ if test "$UUID" = "no"; then
|
||||
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _uuid"
|
||||
fi
|
||||
|
||||
+AC_ARG_ENABLE(berkeleydb,
|
||||
+ AS_HELP_STRING([--disable-berkeleydb], [disable berkeleydb]),
|
||||
+ [ if test "$enableval" = "no"; then
|
||||
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _dbm"
|
||||
+ fi])
|
||||
+
|
||||
AC_SUBST(PYDOC)
|
||||
|
||||
AC_ARG_ENABLE(pydoc,
|
||||
--
|
||||
2.25.0
|
||||
|
@ -46,6 +46,12 @@ config BR2_PACKAGE_PYTHON3_2TO3
|
||||
help
|
||||
code translation from python 2 to 3
|
||||
|
||||
config BR2_PACKAGE_PYTHON3_BERKELEYDB
|
||||
bool "berkeleydb"
|
||||
select BR2_PACKAGE_BERKELEYDB
|
||||
help
|
||||
berkeleydb module for Python3
|
||||
|
||||
config BR2_PACKAGE_PYTHON3_BZIP2
|
||||
bool "bz2 module"
|
||||
select BR2_PACKAGE_BZIP2
|
||||
|
@ -57,6 +57,12 @@ else
|
||||
PYTHON3_CONF_OPTS += --disable-lib2to3
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_PYTHON3_BERKELEYDB),y)
|
||||
PYTHON3_DEPENDENCIES += berkeleydb
|
||||
else
|
||||
PYTHON3_CONF_OPTS += --disable-berkeleydb
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_PYTHON3_READLINE),y)
|
||||
PYTHON3_DEPENDENCIES += readline
|
||||
else
|
||||
|
Loading…
Reference in New Issue
Block a user