uboot-mkimage: use correct host compiler/flags
As used elswwhere in BR. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
5e0d46138f
commit
7b819c32f8
@ -0,0 +1,29 @@
|
||||
[PATCH] Fix tools build with custom HOSTCFLAGS
|
||||
|
||||
We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
|
||||
overridden on the cmdline.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
config.mk | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
Index: u-boot-2011.03/config.mk
|
||||
===================================================================
|
||||
--- u-boot-2011.03.orig/config.mk
|
||||
+++ u-boot-2011.03/config.mk
|
||||
@@ -46,10 +46,12 @@
|
||||
|
||||
#########################################################################
|
||||
|
||||
-HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
|
||||
- $(HOSTCPPFLAGS)
|
||||
+HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
|
||||
HOSTSTRIP = strip
|
||||
|
||||
+# append CPPFLAGS even if CFLAGS has been overridden on cmdline
|
||||
+override HOSTCFLAGS += $(HOSTCPPFLAGS)
|
||||
+
|
||||
#
|
||||
# Mac OS X / Darwin's C preprocessor is Apple specific. It
|
||||
# generates numerous errors and warnings. We want to bypass it
|
@ -4,8 +4,9 @@ UBOOT_MKIMAGE_SITE = ftp://ftp.denx.de/pub/u-boot
|
||||
|
||||
define HOST_UBOOT_MKIMAGE_BUILD_CMDS
|
||||
$(MAKE) -C $(@D) \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
ARCH=$(U_BOOT_ARCH) \
|
||||
HOSTCC="$(HOSTCC)" \
|
||||
HOSTCFLAGS="$(HOST_CFLAGS)" \
|
||||
HOSTLDFLAGS="$(HOST_LDFLAGS)" \
|
||||
tools
|
||||
endef
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user