package/rpi-userland: install all of our .pc files the same way
Install bcm_host the same way we install egl.pc and glesv2.pc, using the cmake lists. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
127c9bcc13
commit
7b57bef618
@ -1,11 +0,0 @@
|
||||
prefix=/usr
|
||||
exec_prefix=${prefix}
|
||||
libdir=${exec_prefix}/lib
|
||||
includedir=${prefix}/include
|
||||
|
||||
Name: bcm_host
|
||||
Description: Broadcom VideoCore host API library
|
||||
Version: 1
|
||||
Libs: -L${libdir} -lbcm_host -lvcos -lvchiq_arm
|
||||
Cflags: -I${includedir} -I${includedir}/interface/vmcs_host/linux -I${includedir}/interface/vcos/pthreads -DUSE_VCHIQ_ARM
|
||||
|
@ -1,9 +1,10 @@
|
||||
Add .pc files for the OpenGLESv2 and EGL libraries
|
||||
Add .pc files for the OpenGLESv2, EGL and bcm_host libraries
|
||||
|
||||
Those pkg-config files make it easier for Qt5 to find those libraries
|
||||
and the appropriate link flags.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
|
||||
Index: b/interface/khronos/egl/egl.pc.in
|
||||
===================================================================
|
||||
@ -25,7 +26,7 @@ Index: b/interface/khronos/CMakeLists.txt
|
||||
===================================================================
|
||||
--- a/interface/khronos/CMakeLists.txt
|
||||
+++ b/interface/khronos/CMakeLists.txt
|
||||
@@ -73,3 +73,11 @@
|
||||
@@ -74,3 +74,11 @@
|
||||
|
||||
install(TARGETS EGL GLESv2 OpenVG WFC khrn_client DESTINATION lib)
|
||||
install(TARGETS EGL_static GLESv2_static khrn_static DESTINATION lib)
|
||||
@ -52,3 +53,30 @@ Index: b/interface/khronos/glxx/glesv2.pc.in
|
||||
+Version: 2.0
|
||||
+Libs: -L${libdir} -lGLESv2
|
||||
+Cflags: -I${includedir}/
|
||||
Index: b/host_applications/linux/libs/bcm_host/CMakeLists.txt
|
||||
===================================================================
|
||||
--- a/host_applications/linux/libs/bcm_host/CMakeLists.txt
|
||||
+++ b/host_applications/linux/libs/bcm_host/CMakeLists.txt
|
||||
@@ -20,3 +20,7 @@
|
||||
|
||||
install(TARGETS bcm_host DESTINATION lib)
|
||||
|
||||
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/bcm_host.pc.in"
|
||||
+ "${CMAKE_CURRENT_BINARY_DIR}/bcm_host.pc" @ONLY)
|
||||
+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/bcm_host.pc"
|
||||
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/lib/pkgconfig")
|
||||
Index: b/host_applications/linux/libs/bcm_host/bcm_host.pc.in
|
||||
===================================================================
|
||||
--- /dev/null
|
||||
+++ b/host_applications/linux/libs/bcm_host/bcm_host.pc.in
|
||||
@@ -0,0 +1,10 @@
|
||||
+prefix=/usr
|
||||
+exec_prefix=${prefix}
|
||||
+libdir=${exec_prefix}/lib
|
||||
+includedir=${prefix}/include
|
||||
+
|
||||
+Name: bcm_host
|
||||
+Description: Broadcom VideoCore host API library
|
||||
+Version: 1
|
||||
+Libs: -L${libdir} -lbcm_host -lvcos -lvchiq_arm
|
||||
+Cflags: -I${includedir} -I${includedir}/interface/vmcs_host/linux -I${includedir}/interface/vcos/pthreads -DUSE_VCHIQ_ARM
|
||||
|
@ -16,10 +16,4 @@ define RPI_USERLAND_POST_TARGET_CLEANUP
|
||||
endef
|
||||
RPI_USERLAND_POST_INSTALL_TARGET_HOOKS += RPI_USERLAND_POST_TARGET_CLEANUP
|
||||
|
||||
define RPI_USERLAND_POST_STAGING_PC_FILE
|
||||
install -D -m 0644 package/rpi-userland/bcm_host.pc \
|
||||
$(STAGING_DIR)/usr/lib/pkgconfig/bcm_host.pc
|
||||
endef
|
||||
RPI_USERLAND_POST_INSTALL_STAGING_HOOKS += RPI_USERLAND_POST_STAGING_PC_FILE
|
||||
|
||||
$(eval $(cmake-package))
|
||||
|
Loading…
Reference in New Issue
Block a user