flite: fix static linking against alsa
Fixes: http://autobuild.buildroot.net/results/3ff/3ff2217a4fccbddbdb2bc8ade68c88fc52848d36/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
c3e412f72e
commit
78271772e3
19
package/flite/flite-0002-fix-alsa-static.patch
Normal file
19
package/flite/flite-0002-fix-alsa-static.patch
Normal file
@ -0,0 +1,19 @@
|
||||
Use pkg-config to determine alsa link flags. This fixes static linking.
|
||||
|
||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
||||
|
||||
diff -Nuar flite-1.4-release.orig/configure.in flite-1.4-release/configure.in
|
||||
--- flite-1.4-release.orig/configure.in 2009-08-14 23:46:38.000000000 +0300
|
||||
+++ flite-1.4-release/configure.in 2014-04-30 18:52:33.253297236 +0300
|
||||
@@ -275,7 +275,10 @@
|
||||
#endif],
|
||||
[AUDIODRIVER="alsa"
|
||||
AUDIODEFS=-DCST_AUDIO_ALSA
|
||||
- AUDIOLIBS=-lasound])
|
||||
+ AUDIOLIBS=`pkg-config --libs alsa`
|
||||
+ if test "$shared" = false; then
|
||||
+ AUDIOLIBS=`pkg-config --libs --static alsa`
|
||||
+ fi])
|
||||
AC_CHECK_HEADER(mmsystem.h,
|
||||
[AUDIODRIVER="wince"
|
||||
AUDIODEFS=-DCST_AUDIO_WINCE
|
@ -11,6 +11,9 @@ FLITE_LICENSE = BSD-4c
|
||||
FLITE_LICENSE_FILES = COPYING
|
||||
|
||||
FLITE_INSTALL_STAGING = YES
|
||||
# Patching configure.in
|
||||
FLITE_AUTORECONF = YES
|
||||
FLITE_DEPENDENCIES = host-pkgconf
|
||||
|
||||
# Sadly, Flite does not support parallel build, especially when building its
|
||||
# shared libraries.
|
||||
|
Loading…
Reference in New Issue
Block a user