ltrace: update to current master
Lots of fixes have been made to ltrace, including the ones for fixing a build failure for MIPS architecture. Updating to current master will allow us to re-enable this package for MIPS and also remove some upstreamed patches. At the same time we add a patch made by Jérôme Pouiller to fix a bug introduced by 5ba9e10 ("Split type definitions from the bundled configs into their own files"). Two new configuration files are not installed. Therefore, ltrace fail with messages like : /usr/share/ltrace/libm.so.conf:333: error: unknown type around 'ldouble erfl(ldouble); That patch has been sent upstream. Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
1d242d23b7
commit
738159d8f6
@ -1,47 +0,0 @@
|
||||
[PATCH] events.c: add similar system headers workaround as trace.c
|
||||
|
||||
Needed for E.G. powerpc on uClibc.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
sysdeps/linux-gnu/events.c | 27 +++++++++++++++++++++++++++
|
||||
1 file changed, 27 insertions(+)
|
||||
|
||||
Index: ltrace-0.6.0/sysdeps/linux-gnu/events.c
|
||||
===================================================================
|
||||
--- ltrace-0.6.0.orig/sysdeps/linux-gnu/events.c
|
||||
+++ ltrace-0.6.0/sysdeps/linux-gnu/events.c
|
||||
@@ -11,6 +11,33 @@
|
||||
|
||||
#include "common.h"
|
||||
|
||||
+/* If the system headers did not provide the constants, hard-code the normal
|
||||
+ values. */
|
||||
+#ifndef PTRACE_EVENT_FORK
|
||||
+
|
||||
+#define PTRACE_OLDSETOPTIONS 21
|
||||
+#define PTRACE_SETOPTIONS 0x4200
|
||||
+#define PTRACE_GETEVENTMSG 0x4201
|
||||
+
|
||||
+/* options set using PTRACE_SETOPTIONS */
|
||||
+#define PTRACE_O_TRACESYSGOOD 0x00000001
|
||||
+#define PTRACE_O_TRACEFORK 0x00000002
|
||||
+#define PTRACE_O_TRACEVFORK 0x00000004
|
||||
+#define PTRACE_O_TRACECLONE 0x00000008
|
||||
+#define PTRACE_O_TRACEEXEC 0x00000010
|
||||
+#define PTRACE_O_TRACEVFORKDONE 0x00000020
|
||||
+#define PTRACE_O_TRACEEXIT 0x00000040
|
||||
+
|
||||
+/* Wait extended result codes for the above trace options. */
|
||||
+#define PTRACE_EVENT_FORK 1
|
||||
+#define PTRACE_EVENT_VFORK 2
|
||||
+#define PTRACE_EVENT_CLONE 3
|
||||
+#define PTRACE_EVENT_EXEC 4
|
||||
+#define PTRACE_EVENT_VFORK_DONE 5
|
||||
+#define PTRACE_EVENT_EXIT 6
|
||||
+
|
||||
+#endif /* PTRACE_EVENT_FORK */
|
||||
+
|
||||
static Event event;
|
||||
|
||||
Event *
|
41
package/ltrace/0002-Install-lib-types.conf
Normal file
41
package/ltrace/0002-Install-lib-types.conf
Normal file
@ -0,0 +1,41 @@
|
||||
Install lib*-types.conf
|
||||
|
||||
This patch was written by Jérôme Pouiller and has been already sent to
|
||||
upstream:
|
||||
|
||||
http://lists.alioth.debian.org/pipermail/ltrace-devel/2015-June/001328.html
|
||||
|
||||
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
|
||||
Install lib*-types.conf
|
||||
|
||||
Files etc/libpthread.so-types.conf and etc/libc.so-types.conf was introduced in
|
||||
commit 5ba9e10 ("Split type definitions from the bundled configs into their own
|
||||
files"). However, they was not installed.
|
||||
|
||||
So latrce failed with messages like :
|
||||
/usr/share/ltrace/libm.so.conf:333: error: unknown type around 'ldouble erfl(ldouble);
|
||||
|
||||
This patch declare these configuration files.
|
||||
|
||||
Signed-off-by: Jérôme Pouiller <jezz at sysmic.org>
|
||||
---
|
||||
Makefile.am | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index f63fa09..394d91c 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -72,7 +72,8 @@ dist_man5_MANS = ltrace.conf.5
|
||||
dist_doc_DATA = COPYING CREDITS INSTALL README TODO
|
||||
|
||||
dist_pkgdata_DATA = etc/syscalls.conf etc/libc.so.conf \
|
||||
- etc/libm.so.conf etc/libacl.so.conf etc/libpthread.so.conf
|
||||
+ etc/libm.so.conf etc/libacl.so.conf etc/libpthread.so.conf \
|
||||
+ etc/libpthread.so-types.conf etc/libc.so-types.conf
|
||||
|
||||
EXTRA_DIST = \
|
||||
debian/changelog \
|
||||
--
|
||||
1.8.5.6
|
@ -1,31 +0,0 @@
|
||||
From c01c6dc017b5ae2b6de7b690725890642b6bf857 Mon Sep 17 00:00:00 2001
|
||||
From: Alexandre Belloni <alexandre.belloni@free-electrons.com>
|
||||
Date: Tue, 29 Jul 2014 11:01:31 +0200
|
||||
Subject: [PATCH] PPC: fix PPC32 build
|
||||
|
||||
Compilation on PPC32 fails because STACK_FRAME_OVERHEAD is never defined
|
||||
in arch.h.
|
||||
|
||||
Define it to 112 on that platform to restore the same behaviour as
|
||||
before commit eea4ad2cce289753aaa35b4e0258a76d8f8f367c.
|
||||
|
||||
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
|
||||
---
|
||||
sysdeps/linux-gnu/ppc/arch.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/sysdeps/linux-gnu/ppc/arch.h b/sysdeps/linux-gnu/ppc/arch.h
|
||||
index 7918a136b016..d5ad759a755c 100644
|
||||
--- a/sysdeps/linux-gnu/ppc/arch.h
|
||||
+++ b/sysdeps/linux-gnu/ppc/arch.h
|
||||
@@ -57,6 +57,7 @@
|
||||
#else
|
||||
#define BREAKPOINT_VALUE { 0x7f, 0xe0, 0x00, 0x08 }
|
||||
#define ARCH_ENDIAN_BIG
|
||||
+# define STACK_FRAME_OVERHEAD 112
|
||||
# ifndef EF_PPC64_ABI
|
||||
# define EF_PPC64_ABI 3
|
||||
# endif
|
||||
--
|
||||
1.9.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LTRACE_VERSION = 0896ce554f80afdcba81d9754f6104f863dea803
|
||||
LTRACE_VERSION = be0c6870e08a3be43b3a0d210fb8dc7614b1e82f
|
||||
LTRACE_SITE = git://anonscm.debian.org/collab-maint/ltrace.git
|
||||
LTRACE_DEPENDENCIES = elfutils
|
||||
LTRACE_CONF_OPTS = --disable-werror
|
||||
|
Loading…
Reference in New Issue
Block a user