unionfs: new package
Add the unionfs FUSE unification filesystem. [Peter: whitespace/help text fix] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
dda08e492d
commit
7360f16a22
@ -212,6 +212,7 @@ source "package/sysstat/Config.in"
|
||||
source "package/ti-utils/Config.in"
|
||||
source "package/uboot-tools/Config.in"
|
||||
source "package/udev/Config.in"
|
||||
source "package/unionfs/Config.in"
|
||||
source "package/usb_modeswitch/Config.in"
|
||||
source "package/usbmount/Config.in"
|
||||
source "package/usbutils/Config.in"
|
||||
|
11
package/unionfs/Config.in
Normal file
11
package/unionfs/Config.in
Normal file
@ -0,0 +1,11 @@
|
||||
config BR2_PACKAGE_UNIONFS
|
||||
bool "unionfs (FUSE)"
|
||||
select BR2_PACKAGE_LIBFUSE
|
||||
depends on BR2_LARGEFILE
|
||||
help
|
||||
A userspace unionfs implementation.
|
||||
|
||||
http://podgorny.cz/moin/UnionFsFuse
|
||||
|
||||
comment "unionfs requires a toolchain with LARGEFILE support"
|
||||
depends on !BR2_LARGEFILE
|
15
package/unionfs/unionfs-make-mandir.patch
Normal file
15
package/unionfs/unionfs-make-mandir.patch
Normal file
@ -0,0 +1,15 @@
|
||||
Make the man directory if it's missing before installing the man page.
|
||||
Already upstream see http://hg.podgorny.cz/unionfs-fuse/rev/6ca07ad1b855
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
|
||||
diff -Nura unionfs-fuse-0.24.orig/Makefile unionfs-fuse-0.24/Makefile
|
||||
--- unionfs-fuse-0.24.orig/Makefile 2010-05-20 08:04:08.000000000 -0300
|
||||
+++ unionfs-fuse-0.24/Makefile 2012-01-11 08:08:02.382667776 -0300
|
||||
@@ -9,5 +9,6 @@
|
||||
|
||||
install: build
|
||||
install -d $(DESTDIR)$(PREFIX)$(BINDIR)
|
||||
+ install -d $(DESTDIR)$(PREFIX)/share/man/man8
|
||||
install -m 0755 src/unionfs $(DESTDIR)$(PREFIX)$(BINDIR)
|
||||
install -m 0644 man/unionfs-fuse.8 $(DESTDIR)$(PREFIX)/share/man/man8/
|
20
package/unionfs/unionfs.mk
Normal file
20
package/unionfs/unionfs.mk
Normal file
@ -0,0 +1,20 @@
|
||||
#############################################################
|
||||
#
|
||||
# unionfs
|
||||
#
|
||||
#############################################################
|
||||
|
||||
UNIONFS_VERSION = 0.24
|
||||
UNIONFS_SITE = http://podgorny.cz/unionfs-fuse/releases
|
||||
UNIONFS_SOURCE = unionfs-fuse-$(UNIONFS_VERSION).tar.bz2
|
||||
UNIONFS_DEPENDENCIES = libfuse
|
||||
|
||||
define UNIONFS_BUILD_CMDS
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
|
||||
endef
|
||||
|
||||
define UNIONFS_INSTALL_TARGET_CMDS
|
||||
$(MAKE) -C $(@D) PREFIX=/usr DESTDIR=$(TARGET_DIR) install
|
||||
endef
|
||||
|
||||
$(eval $(call GENTARGETS))
|
Loading…
Reference in New Issue
Block a user