package/lttng-libust: bump to version 2.13.1
Add a patch to disable building tests, building the tests can fail unless the package is reconfigured. Signed-off-by: Norbert Lange <nolange79@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
c94dd92c0f
commit
733bf73e3f
@ -0,0 +1,59 @@
|
||||
From a1f8509283ad29b5144bda6f6dba9f5eb7165adc Mon Sep 17 00:00:00 2001
|
||||
From: Norbert Lange <nolange79@gmail.com>
|
||||
Date: Thu, 23 Dec 2021 21:56:46 +0100
|
||||
Subject: [PATCH] configure.ac: add --disable-tests
|
||||
|
||||
Add configure option to disable tests.
|
||||
Upstream is not likely to accept it, see lttng-tools package.
|
||||
|
||||
Signed-off-by: Norbert Lange <nolange79@gmail.com>
|
||||
---
|
||||
Makefile.am | 5 ++++-
|
||||
configure.ac | 6 ++++++
|
||||
2 files changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 9ab93ccd..8a1c1dca 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -7,9 +7,12 @@ SUBDIRS = \
|
||||
src \
|
||||
tools \
|
||||
doc \
|
||||
- tests \
|
||||
extras
|
||||
|
||||
+if ENABLE_TESTS
|
||||
+SUBDIRS += tests
|
||||
+endif
|
||||
+
|
||||
dist_doc_DATA = \
|
||||
ChangeLog \
|
||||
LICENSE \
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index b6254228..fe5f2700 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -360,6 +360,11 @@ AE_FEATURE([python-agent],[build the LTTng UST Python agent])
|
||||
AE_FEATURE_DEFAULT_ENABLE
|
||||
AE_FEATURE([examples],[Do not build and install examples])
|
||||
|
||||
+# Build the tests
|
||||
+# Enabled by default
|
||||
+AE_FEATURE_DEFAULT_ENABLE
|
||||
+AE_FEATURE([tests],[Do not build tests])
|
||||
+
|
||||
# Man pages
|
||||
# Enabled by default
|
||||
AE_FEATURE_DEFAULT_ENABLE
|
||||
@@ -525,6 +530,7 @@ AC_DEFINE([LTTNG_UST_CTL_LIB_SONAME_MAJOR], [ust_ctl_lib_version_current], [Majo
|
||||
## ##
|
||||
|
||||
AM_CONDITIONAL([ENABLE_EXAMPLES], AE_IS_FEATURE_ENABLED([examples]))
|
||||
+AM_CONDITIONAL([ENABLE_TESTS], AE_IS_FEATURE_ENABLED([tests]))
|
||||
AM_CONDITIONAL([ENABLE_GEN_TP_EXAMPLES], [test "x$PYTHON" != "x"])
|
||||
AM_CONDITIONAL([ENABLE_JAVA_AGENT], AE_IS_FEATURE_ENABLED([java-agent-jul]) || AE_IS_FEATURE_ENABLED([java-agent-log4j]))
|
||||
AM_CONDITIONAL([ENABLE_JAVA_AGENT_WITH_JUL], AE_IS_FEATURE_ENABLED([java-agent-jul]))
|
||||
--
|
||||
2.34.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://lttng.org/files/lttng-ust/lttng-ust-2.12.1.tar.bz2.sha256
|
||||
sha256 48a3948b168195123a749d22818809bd25127bb5f1a66458c3c012b210d2a051 lttng-ust-2.12.1.tar.bz2
|
||||
# From https://lttng.org/files/lttng-ust/lttng-ust-2.13.2.tar.bz2.sha256
|
||||
sha256 5667bf0269e1e62e2d9cb974c456ff86e0401bd7aa3bfc8d5fdb97233249eddc lttng-ust-2.13.1.tar.bz2
|
||||
|
||||
# Hash for license file
|
||||
sha256 74125a84c2166300776980166e29de40d5f98d1a75e487f0bbc0c03b4cd2342e COPYING
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
LTTNG_LIBUST_SITE = http://lttng.org/files/lttng-ust
|
||||
LTTNG_LIBUST_VERSION = 2.12.1
|
||||
LTTNG_LIBUST_VERSION = 2.13.1
|
||||
LTTNG_LIBUST_SOURCE = lttng-ust-$(LTTNG_LIBUST_VERSION).tar.bz2
|
||||
LTTNG_LIBUST_LICENSE = LGPL-2.1, MIT (system headers), GPL-2.0 (liblttng-ust-ctl/ustctl.c used by lttng-sessiond)
|
||||
LTTNG_LIBUST_LICENSE_FILES = COPYING
|
||||
@ -14,7 +14,9 @@ LTTNG_LIBUST_DEPENDENCIES = liburcu util-linux
|
||||
LTTNG_LIBUST_CONF_OPTS = \
|
||||
--disable-man-pages \
|
||||
--disable-examples \
|
||||
--disable-tests \
|
||||
--with-lttng-system-rundir=/run/lttng
|
||||
LTTNG_LIBUST_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_PACKAGE_PYTHON),y)
|
||||
LTTNG_LIBUST_DEPENDENCIES += python
|
||||
|
Loading…
Reference in New Issue
Block a user