package/libxslt: fix build with latest libxml2

Build is broken since bump of libxml2 to version 2.9.11 in commit
a241dcec41 because libxslt calls the
following command "${XML_CONFIG} --libs print" which will return an
error code since
2a357ab99e

Fixes:
 - http://autobuild.buildroot.org/results/47ceb8c24c9ead8a450b7fea3266f760d6b77b4f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2021-05-14 22:28:38 +02:00 committed by Peter Korsgaard
parent 9c108afab8
commit 7320e5dd62
2 changed files with 33 additions and 0 deletions

View File

@ -0,0 +1,31 @@
From 90c34c8bb90e095a8a8fe8b2ce368bd9ff1837cc Mon Sep 17 00:00:00 2001
From: Nick Wellnhofer <wellnhofer@aevum.de>
Date: Fri, 15 Nov 2019 11:53:11 +0100
Subject: [PATCH] Fix xml2-config check in configure script
A 'print' option has never been supported. After a recent change to
libxml2, invalid options cause xml2-config to fail.
[Retrieved from:
https://gitlab.gnome.org/GNOME/libxslt/-/commit/90c34c8bb90e095a8a8fe8b2ce368bd9ff1837cc]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 3da57b18..585b9d7c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -548,7 +548,7 @@ dnl make sure xml2-config is executable,
dnl test version and init our variables
dnl
-if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs print > /dev/null 2>&1
+if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs > /dev/null 2>&1
then
AC_MSG_CHECKING(for libxml libraries >= $LIBXML_REQUIRED_VERSION)
XMLVERS=`$XML_CONFIG --version`
--
GitLab

View File

@ -10,6 +10,8 @@ LIBXSLT_INSTALL_STAGING = YES
LIBXSLT_LICENSE = MIT
LIBXSLT_LICENSE_FILES = COPYING
LIBXSLT_CPE_ID_VENDOR = xmlsoft
# We're patching configure.ac
LIBXSLT_AUTORECONF = YES
LIBXSLT_CONF_OPTS = \
--with-gnu-ld \