package/python-aiologstash: migrate to flit build backend

We need to add a patch which selects the correct flit build
backend.

As flit is configured as the pep517 build backend for aiologstash
we need to migrate from setuptools to flit prior to migrating
setuptools to pep517 as the frontend will not fall back to using
setuptools once migrated.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
This commit is contained in:
James Hilliard 2024-02-13 14:14:53 -07:00 committed by Arnout Vandecappelle
parent 05f315c83b
commit 72c08122c0
2 changed files with 32 additions and 1 deletions

View File

@ -0,0 +1,31 @@
From 3c4d1203eb9ee3dbe79b096d587c9baaf8b802ed Mon Sep 17 00:00:00 2001
From: James Hilliard <james.hilliard1@gmail.com>
Date: Fri, 11 Mar 2022 13:26:31 -0700
Subject: [PATCH] Fix flit_core build requires/backend.
Only flit_core should be required by pyproject.toml, the regular flit
package is the pep517 frontend which is not what should be set for the
build system.
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Upstream: https://github.com/aio-libs/aiologstash/pull/258
---
pyproject.toml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index 7bdaebb..252a660 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
-requires = ["flit"]
-build-backend = "flit.buildapi"
+requires = ["flit_core"]
+build-backend = "flit_core.buildapi"
[tool.flit.metadata]
module = "aiologstash"
--
2.34.1

View File

@ -7,7 +7,7 @@
PYTHON_AIOLOGSTASH_VERSION = 2.0.0
PYTHON_AIOLOGSTASH_SOURCE = aiologstash-$(PYTHON_AIOLOGSTASH_VERSION).tar.gz
PYTHON_AIOLOGSTASH_SITE = https://files.pythonhosted.org/packages/1c/dc/382861d5d25ccc976d02118922598fc4547f74f3287793e270ed614d8176
PYTHON_AIOLOGSTASH_SETUP_TYPE = setuptools
PYTHON_AIOLOGSTASH_SETUP_TYPE = flit
PYTHON_AIOLOGSTASH_LICENSE = MIT
PYTHON_AIOLOGSTASH_LICENSE_FILES = LICENSE