package/libnvme: bump to version 1.7

Drop local patches that have been upstreamed.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Giulio Benetti 2023-12-20 00:18:04 +01:00 committed by Peter Korsgaard
parent 620a88f755
commit 7150660668
4 changed files with 2 additions and 118 deletions

View File

@ -1,70 +0,0 @@
From ca47ba3119365eafac0ab25a86cab9d9a1b29bd4 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Sat, 30 Sep 2023 06:38:53 +0100
Subject: [PATCH] test: handle POSIX ioctl prototype
glibc has the following prototype for ioctl: int ioctl(int fd, unsigned long request, ...)
POSIX (inc. musl) has the following for ioctl: int ioctl(int fd, int request, ...)
Check which prototype is used in <sys/ioctl.h> to avoid a conflict and conditionally
define the right one for the system.
Upstream: https://github.com/linux-nvme/libnvme/commit/ca47ba3119365eafac0ab25a86cab9d9a1b29bd4
Bug: https://bugs.gentoo.org/914921
Signed-off-by: Sam James <sam@gentoo.org>
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
meson.build | 10 ++++++++++
test/ioctl/mock.c | 6 +++++-
2 files changed, 15 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 6fcf1da..2c979cc 100644
--- a/meson.build
+++ b/meson.build
@@ -230,6 +230,16 @@ conf.set(
),
description: 'Is network address and service translation available'
)
+conf.set(
+ 'HAVE_GLIBC_IOCTL',
+ cc.compiles(
+ '''#include <sys/ioctl.h>
+ int ioctl(int fd, unsigned long request, ...);
+ ''',
+ name: 'ioctl has glibc-style prototype'
+ ),
+ description: 'Is ioctl the glibc interface (rather than POSIX)'
+)
if cc.has_function_attribute('fallthrough')
conf.set('fallthrough', '__attribute__((__fallthrough__))')
diff --git a/test/ioctl/mock.c b/test/ioctl/mock.c
index e917244..5d2ac94 100644
--- a/test/ioctl/mock.c
+++ b/test/ioctl/mock.c
@@ -114,7 +114,11 @@ void end_mock_cmds(void)
} \
})
+#ifdef HAVE_GLIBC_IOCTL
int ioctl(int fd, unsigned long request, ...)
+#else
+int ioctl(int fd, int request, ...)
+#endif
{
struct mock_cmds *mock_cmds;
bool result64;
@@ -141,7 +145,7 @@ int ioctl(int fd, unsigned long request, ...)
result64 = true;
break;
default:
- fail("unexpected %s %lu", __func__, request);
+ fail("unexpected %s %lu", __func__, (unsigned long) request);
}
check(mock_cmds->remaining_cmds,
"unexpected %s command", mock_cmds->name);
--
2.34.1

View File

@ -1,46 +0,0 @@
From ff742e792725c316ba6de0800188bf36751bd1d1 Mon Sep 17 00:00:00 2001
From: Sam James <sam@gentoo.org>
Date: Sat, 30 Sep 2023 06:43:39 +0100
Subject: [PATCH] meson: make building tests conditional
Just like we do for docs.
Upstream: https://github.com/linux-nvme/libnvme/commit/ff742e792725c316ba6de0800188bf36751bd1d1
Signed-off-by: Sam James <sam@gentoo.org>
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
meson.build | 4 +++-
meson_options.txt | 1 +
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 2c979cc..a9263b5 100644
--- a/meson.build
+++ b/meson.build
@@ -273,7 +273,9 @@ subdir('internal')
subdir('ccan')
subdir('src')
subdir('libnvme')
-subdir('test')
+if get_option('tests')
+ subdir('test')
+endif
subdir('examples')
subdir('doc')
diff --git a/meson_options.txt b/meson_options.txt
index a1ed79f..251ae11 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -6,6 +6,7 @@ option('rstdir', type : 'string', value : '', description : 'directory for ReST
option('docs', type : 'combo', choices : ['false', 'html', 'man', 'rst', 'all'], description : 'install documentation')
option('docs-build', type : 'boolean', value : false, description : 'build documentation')
+option('tests', type : 'boolean', value : true, description : 'build tests')
option('python', type : 'feature', value: 'auto', description : 'Generate libnvme python bindings')
option('openssl', type : 'feature', value: 'auto', description : 'OpenSSL support')
--
2.34.1

View File

@ -1,3 +1,3 @@
# Locally calculated sha256 checksums
sha256 0dd8ba8b655abe78c09833edb66632aa6bee82aebf117dd252ded968deaaeec7 libnvme-1.6.tar.gz
sha256 93febccd2e4201a6a9c696a0208a7227adfd1649ad0523754c1885503890e77c libnvme-1.7.tar.gz
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBNVME_VERSION = 1.6
LIBNVME_VERSION = 1.7
LIBNVME_SITE = $(call github,linux-nvme,libnvme,v$(LIBNVME_VERSION))
LIBNVME_LICENSE = LGPL-2.1
LIBNVME_LICENSE_FILES = COPYING