package/jose: disable man pages

Disable man pages to avoid the following build failure if a non-working
a2x is found on the system raised since bump to version 11 in commit
b72b849ad5:

/usr/bin/a2x -f manpage -D /nvmedata/autobuild/instance-23/output-1/build/jose-11/build /nvmedata/autobuild/instance-23/output-1/build/jose-11/doc/man/jose.1.adoc
/nvmedata/autobuild/instance-23/output-1/host/bin/python3: Error while finding module specification for 'asciidoc.a2x' (ModuleNotFoundError: No module named 'asciidoc')

Fixes:
 - http://autobuild.buildroot.org/results/ae69f7fd1258d99a5b08eeb8c67904be53eabf15

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2022-08-14 20:12:34 +02:00 committed by Yann E. MORIN
parent 69cbdbe887
commit 70db731a79
2 changed files with 65 additions and 0 deletions

View File

@ -0,0 +1,64 @@
From 506132d3edc8d062f65fdacf007a15613d27e5c5 Mon Sep 17 00:00:00 2001
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
Date: Wed, 6 Apr 2022 09:49:48 -0300
Subject: [PATCH] man: add option to skip building man pages
Add a 'skip_manpages' option to meson, so that man pages do not get
built.
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
[Retrieved from: https://github.com/latchset/jose/pull/115]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
meson.build | 24 +++++++++++++-----------
meson_options.txt | 1 +
2 files changed, 14 insertions(+), 11 deletions(-)
create mode 100644 meson_options.txt
diff --git a/meson.build b/meson.build
index 1edfbe7..9b40efb 100644
--- a/meson.build
+++ b/meson.build
@@ -37,7 +37,6 @@ zlib = dependency('zlib')
threads = dependency('threads')
jansson = dependency('jansson', version: '>=2.10')
libcrypto = dependency('libcrypto', version: '>=1.0.2')
-a2x = find_program('a2x', required: false)
mans = []
@@ -63,14 +62,17 @@ pkg.generate(
requires: 'jansson',
)
-if a2x.found()
- foreach m : mans
- custom_target(m.split('/')[-1], input: m + '.adoc', output: m.split('/')[-1],
- command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
- install_dir: join_paths(get_option('mandir'), 'man' + m.split('.')[-1]),
- install: true
- )
- endforeach
-else
- warning('Will not build man pages due to missing dependencies!')
+if not get_option('skip_manpages')
+ a2x = find_program('a2x', required: false)
+ if a2x.found()
+ foreach m : mans
+ custom_target(m.split('/')[-1], input: m + '.adoc', output: m.split('/')[-1],
+ command: [a2x, '-f', 'manpage', '-D', meson.current_build_dir(), '@INPUT@'],
+ install_dir: join_paths(get_option('mandir'), 'man' + m.split('.')[-1]),
+ install: true
+ )
+ endforeach
+ else
+ warning('Will not build man pages due to missing dependencies!')
+ endif
endif
diff --git a/meson_options.txt b/meson_options.txt
new file mode 100644
index 0000000..0885515
--- /dev/null
+++ b/meson_options.txt
@@ -0,0 +1 @@
+option('skip_manpages', type: 'boolean', value: false, description: 'Do not build manpages')

View File

@ -11,5 +11,6 @@ JOSE_LICENSE = Apache-2.0
JOSE_LICENSE_FILES = COPYING
JOSE_INSTALL_STAGING = YES
JOSE_DEPENDENCIES = host-pkgconf zlib jansson openssl
JOSE_CONF_OPTS = -Dskip_manpages=true
$(eval $(meson-package))