added vice
This commit is contained in:
parent
9fc65734f8
commit
70b2460ed9
7
package/vice/Config.in
Normal file
7
package/vice/Config.in
Normal file
@ -0,0 +1,7 @@
|
||||
config BR2_PACKAGE_VICE
|
||||
bool "vice"
|
||||
default n
|
||||
help
|
||||
VICE is a Commodore emulator
|
||||
|
||||
http://www.viceteam.org/online
|
20
package/vice/vice-1.22-remove-bzero.patch
Normal file
20
package/vice/vice-1.22-remove-bzero.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/src/network.c 2007-07-15 18:49:24.000000000 -0400
|
||||
+++ b/src/network.c 2008-03-01 21:29:40.000000000 -0500
|
||||
@@ -742,7 +742,7 @@ int network_start_server(void)
|
||||
|
||||
#ifdef HAVE_IPV6
|
||||
if (netplay_ipv6) {
|
||||
- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
|
||||
+ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
|
||||
server_addr6.sin6_port = htons(server_port);
|
||||
server_addr6.sin6_family = PF_INET6;
|
||||
server_addr6.sin6_addr=in6addr_any;
|
||||
@@ -853,7 +853,7 @@ int network_connect_client(void)
|
||||
}
|
||||
#ifdef HAVE_IPV6
|
||||
if (netplay_ipv6) {
|
||||
- bzero((char*)&server_addr6, sizeof(struct sockaddr_in6));
|
||||
+ memset((char*)&server_addr6, 0, sizeof(struct sockaddr_in6));
|
||||
server_addr6.sin6_port = htons(server_port);
|
||||
server_addr6.sin6_family = PF_INET6;
|
||||
memcpy(&server_addr6.sin6_addr, server_hostent->h_addr, server_hostent->h_length);
|
18
package/vice/vice.mk
Normal file
18
package/vice/vice.mk
Normal file
@ -0,0 +1,18 @@
|
||||
#############################################################
|
||||
#
|
||||
# vice
|
||||
#
|
||||
#############################################################
|
||||
VICE_VERSION = 1.22
|
||||
VICE_SOURCE = vice-$(VICE_VERSION).tar.gz
|
||||
VICE_SITE = http://www.viceteam.org/online
|
||||
VICE_AUTORECONF = NO
|
||||
VICE_INSTALL_STAGING = NO
|
||||
VICE_INSTALL_TARGET = YES
|
||||
|
||||
VICE_CONF_OPT = --without-resid --with-alsa CFLAGS="-O0"
|
||||
|
||||
VICE_DEPENDENCIES = uclibc
|
||||
|
||||
$(eval $(call AUTOTARGETS,package,vice))
|
||||
|
Loading…
Reference in New Issue
Block a user