python: bump to 2.7.10

Patches are simply refreshed, except
004-sysconfigdata-install-location.patch where a minor conflict
resolution was needed.

[Peter: fixup .hash as pointed out by Arnout]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas Petazzoni 2015-06-16 23:36:11 +02:00 committed by Peter Korsgaard
parent d98eed3222
commit 7076e6f61c
24 changed files with 38 additions and 39 deletions

View File

@ -69,8 +69,8 @@ Index: b/configure.ac
AC_MSG_ERROR([python$PACKAGE_VERSION interpreter not found])
fi
AC_MSG_RESULT($interp)
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/plat-$(MACHDEP) '$interp
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pysysconfigdatadir.txt && echo $(abs_builddir)/`cat pysysconfigdatadir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/plat-$(MACHDEP) '$interp
- PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pybuilddir.txt && echo $(abs_builddir)/`cat pybuilddir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
+ PYTHON_FOR_BUILD='_PYTHON_PROJECT_BASE=$(abs_builddir) _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(shell test -f pysysconfigdatadir.txt && echo $(abs_builddir)/`cat pysysconfigdatadir.txt`:)$(srcdir)/Lib:$(srcdir)/Lib/$(PLATDIR) '$interp
fi
elif test "$cross_compiling" = maybe; then
AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])

View File

@ -39,7 +39,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -736,6 +736,17 @@
@@ -739,6 +739,17 @@
;;
esac

View File

@ -2,7 +2,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -3346,7 +3346,7 @@
@@ -3353,7 +3353,7 @@
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)

View File

@ -33,9 +33,9 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2284,6 +2284,8 @@
@@ -2290,6 +2290,8 @@
AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
PKG_PROG_PKG_CONFIG
+AC_SUBST(DISABLED_EXTENSIONS)
+

View File

@ -10,7 +10,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -882,6 +882,7 @@
@@ -885,6 +885,7 @@
# Other platforms follow
if test $enable_shared = "yes"; then
@ -18,7 +18,7 @@ Index: b/configure.ac
AC_DEFINE(Py_ENABLE_SHARED, 1, [Defined if Python is built as a shared library.])
case $ac_sys_system in
BeOS*)
@@ -942,6 +943,7 @@
@@ -945,6 +946,7 @@
esac
else # shared is disabled
@ -26,7 +26,7 @@ Index: b/configure.ac
case $ac_sys_system in
CYGWIN*)
BLDLIBRARY='$(LIBRARY)'
@@ -1918,6 +1920,9 @@
@@ -1921,6 +1923,9 @@
AC_SUBST(BLDSHARED)
AC_SUBST(CCSHARED)
AC_SUBST(LINKFORSHARED)
@ -36,7 +36,7 @@ Index: b/configure.ac
# SO is the extension of shared libraries `(including the dot!)
# -- usually .so, .sl on HP-UX, .dll on Cygwin
AC_MSG_CHECKING(SO)
@@ -4581,7 +4586,7 @@
@@ -4588,7 +4593,7 @@
AC_SUBST(ENSUREPIP)
# generate output files

View File

@ -14,7 +14,7 @@ Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -456,9 +456,9 @@
@@ -445,9 +445,9 @@
if not cross_compiling:
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')

View File

@ -79,7 +79,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2628,6 +2628,12 @@
@@ -2634,6 +2634,12 @@
fi

View File

@ -40,7 +40,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2627,6 +2627,11 @@
@@ -2633,6 +2633,11 @@
AC_CHECK_FUNCS(pthread_atfork)
fi
@ -56,7 +56,7 @@ Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -2222,6 +2222,12 @@
@@ -2211,6 +2211,12 @@
# turn off warnings when deprecated modules are imported
import warnings
warnings.filterwarnings("ignore",category=DeprecationWarning)
@ -69,7 +69,7 @@ Index: b/setup.py
setup(# PyPI Metadata (PEP 301)
name = "Python",
version = sys.version.split()[0],
@@ -2242,9 +2248,7 @@
@@ -2231,9 +2237,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install

View File

@ -52,7 +52,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2639,6 +2639,12 @@
@@ -2645,6 +2645,12 @@
AS_HELP_STRING([--disable-test-modules], [disable test modules]),
[ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
@ -69,7 +69,7 @@ Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -2223,10 +2223,11 @@
@@ -2212,10 +2212,11 @@
import warnings
warnings.filterwarnings("ignore",category=DeprecationWarning)

View File

@ -12,7 +12,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2627,6 +2627,15 @@
@@ -2633,6 +2633,15 @@
AC_CHECK_FUNCS(pthread_atfork)
fi

View File

@ -48,7 +48,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2636,6 +2636,15 @@
@@ -2642,6 +2642,15 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
fi

View File

@ -36,7 +36,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2645,6 +2645,15 @@
@@ -2651,6 +2651,15 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _tkinter"
fi

View File

@ -43,7 +43,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2292,13 +2292,21 @@
@@ -2298,13 +2298,21 @@
AC_SUBST(DISABLED_EXTENSIONS)
# Check for use of the system expat library
@ -74,7 +74,7 @@ Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -1474,7 +1474,7 @@
@@ -1463,7 +1463,7 @@
#
# More information on Expat can be found at www.libexpat.org.
#

View File

@ -10,7 +10,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2644,6 +2644,12 @@
@@ -2650,6 +2650,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _sqlite3"
fi

View File

@ -13,7 +13,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2650,6 +2650,12 @@
@@ -2656,6 +2656,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _codecs_kr _codecs_jp _codecs_cn _codecs_tw _codecs_hk"
fi])

View File

@ -10,7 +10,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2656,6 +2656,12 @@
@@ -2662,6 +2662,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
fi])

View File

@ -49,7 +49,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2656,6 +2656,28 @@
@@ -2662,6 +2662,28 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
fi])

View File

@ -10,7 +10,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2656,6 +2656,12 @@
@@ -2662,6 +2662,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} nis"
fi])

View File

@ -9,7 +9,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2662,6 +2662,12 @@
@@ -2668,6 +2668,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl"
fi])

View File

@ -9,7 +9,7 @@ Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2668,6 +2668,12 @@
@@ -2674,6 +2674,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} bz2"
fi])

View File

@ -32,7 +32,7 @@ Index: b/setup.py
===================================================================
--- a/setup.py
+++ b/setup.py
@@ -2223,7 +2223,7 @@
@@ -2212,7 +2212,7 @@
import warnings
warnings.filterwarnings("ignore",category=DeprecationWarning)

View File

@ -8,11 +8,11 @@ Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>
configure.ac | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/configure.ac b/configure.ac
index e8cb52a..579e05b 100644
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -2717,6 +2717,12 @@ if test "$CURSES" = "no"; then
@@ -2726,6 +2726,12 @@
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
fi
@ -25,6 +25,3 @@ index e8cb52a..579e05b 100644
AC_SUBST(PYDOC)
AC_ARG_ENABLE(pydoc,
--
2.1.0

View File

@ -1,2 +1,4 @@
# Locally calculated after checking pgp signature
sha256 90d27e14ea7e03570026850e2e50ba71ad20b7eb31035aada1cf3def8f8d4916 Python-2.7.9.tar.xz
# From https://www.python.org/downloads/release/python-2710/
md5 c685ef0b8e9f27b5e3db5db12b268ac6 Python-2.7.10.tar.xz
# Locally calculated
sha256 1cd3730781b91caf0fa1c4d472dc29274186480161a150294c42ce9b5c5effc0 Python-2.7.10.tar.xz

View File

@ -5,7 +5,7 @@
################################################################################
PYTHON_VERSION_MAJOR = 2.7
PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).9
PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).10
PYTHON_SOURCE = Python-$(PYTHON_VERSION).tar.xz
PYTHON_SITE = http://python.org/ftp/python/$(PYTHON_VERSION)
PYTHON_LICENSE = Python software foundation license v2, others