erlang-p1-xmpp: new package
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
ded9546447
commit
704cca3ef5
@ -871,6 +871,7 @@ F: package/erlang-p1-stun/
|
||||
F: package/erlang-p1-tls/
|
||||
F: package/erlang-p1-utils/
|
||||
F: package/erlang-p1-xml/
|
||||
F: package/erlang-p1-xmpp/
|
||||
F: package/erlang-p1-yaml/
|
||||
F: package/erlang-p1-zlib/
|
||||
F: package/nginx-dav-ext/
|
||||
|
@ -520,6 +520,7 @@ menu "Erlang libraries/modules"
|
||||
source "package/erlang-p1-tls/Config.in"
|
||||
source "package/erlang-p1-utils/Config.in"
|
||||
source "package/erlang-p1-xml/Config.in"
|
||||
source "package/erlang-p1-xmpp/Config.in"
|
||||
source "package/erlang-p1-yaml/Config.in"
|
||||
source "package/erlang-p1-zlib/Config.in"
|
||||
endmenu
|
||||
|
16
package/erlang-p1-xmpp/0001-fix-includes.patch
Normal file
16
package/erlang-p1-xmpp/0001-fix-includes.patch
Normal file
@ -0,0 +1,16 @@
|
||||
Without this patch, rebar fails to find include file fxml.hrl.
|
||||
|
||||
Signed-off-by: Christophe Romain <cromain@process-one.net>
|
||||
|
||||
diff --git a/include/xmpp.hrl b/include/xmpp.hrl
|
||||
index afa5f61..678858e 100644
|
||||
--- a/include/xmpp.hrl
|
||||
+++ b/include/xmpp.hrl
|
||||
@@ -26,7 +26,7 @@
|
||||
-include("ns.hrl").
|
||||
-include("jid.hrl").
|
||||
-include("xmpp_codec.hrl").
|
||||
--include("fxml.hrl").
|
||||
+-include_lib("p1_xml/include/fxml.hrl").
|
||||
|
||||
-type stanza() :: iq() | presence() | message().
|
@ -0,0 +1,18 @@
|
||||
Without this patch, dependencies would be downloaded and compiled
|
||||
by rebar at build time.
|
||||
|
||||
Signed-off-by: Christophe Romain <cromain@process-one.net>
|
||||
|
||||
diff --git a/rebar.config b/rebar.config
|
||||
index 79494b7..8d769f1 100644
|
||||
--- a/rebar.config
|
||||
+++ b/rebar.config
|
||||
@@ -24,9 +24,6 @@
|
||||
{i, "../fast_xml/include"},
|
||||
{i, "deps/fast_xml/include"}]}.
|
||||
|
||||
-{deps, [{fast_xml, ".*", {git, "https://github.com/processone/fast_xml", {tag, "1.1.22"}}},
|
||||
- {stringprep, ".*", {git, "https://github.com/processone/stringprep", {tag, "1.0.8"}}}]}.
|
||||
-
|
||||
{cover_enabled, true}.
|
||||
{cover_export_enabled, true}.
|
8
package/erlang-p1-xmpp/Config.in
Normal file
8
package/erlang-p1-xmpp/Config.in
Normal file
@ -0,0 +1,8 @@
|
||||
config BR2_PACKAGE_ERLANG_P1_XMPP
|
||||
bool "erlang-p1-xmpp"
|
||||
select BR2_PACKAGE_ERLANG_P1_XML
|
||||
select BR2_PACKAGE_ERLANG_P1_STRINGPREP
|
||||
help
|
||||
XMPP library for Erlang.
|
||||
|
||||
https://github.com/processone/xmpp
|
2
package/erlang-p1-xmpp/erlang-p1-xmpp.hash
Normal file
2
package/erlang-p1-xmpp/erlang-p1-xmpp.hash
Normal file
@ -0,0 +1,2 @@
|
||||
# Locally calculated
|
||||
sha256 e7b5db5ab6204f5bc6ebf91a183ebeae2b43ca6372dd2506599a8e8168a99c50 erlang-p1-xmpp-1.1.9.tar.gz
|
16
package/erlang-p1-xmpp/erlang-p1-xmpp.mk
Normal file
16
package/erlang-p1-xmpp/erlang-p1-xmpp.mk
Normal file
@ -0,0 +1,16 @@
|
||||
################################################################################
|
||||
#
|
||||
# erlang-p1-xmpp
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ERLANG_P1_XMPP_VERSION = 1.1.9
|
||||
ERLANG_P1_XMPP_SITE = $(call github,processone,xmpp,$(ERLANG_P1_XMPP_VERSION))
|
||||
ERLANG_P1_XMPP_LICENSE = Apache-2.0
|
||||
ERLANG_P1_XMPP_LICENSE_FILES = LICENSE.txt
|
||||
ERLANG_P1_XMPP_INSTALL_STAGING = YES
|
||||
ERLANG_P1_XMPP_DEPENDENCIES = erlang-p1-xml erlang-p1-stringprep \
|
||||
host-erlang-p1-xml
|
||||
|
||||
$(eval $(rebar-package))
|
||||
$(eval $(host-rebar-package))
|
Loading…
Reference in New Issue
Block a user