xconfig: Save the configuration properly in qconf

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2009-07-21 18:21:32 +02:00
parent 69f982cdad
commit 6cd6353ff9
2 changed files with 20 additions and 2 deletions

View File

@ -7,11 +7,11 @@
gconf.c | 4 -
gconf.glade | 2
mconf.c | 39 +++++++++----------
qconf.cc | 3 -
qconf.cc | 5 +-
util.c | 105 +++++++++++++++++++++++++++++++++++++++++++++++++++-
zconf.tab.c_shipped | 2
zconf.y | 2
12 files changed, 239 insertions(+), 103 deletions(-)
12 files changed, 241 insertions(+), 103 deletions(-)
Index: config/Makefile
===================================================================
@ -741,6 +741,22 @@ Index: config/qconf.cc
setCaption(title);
width = configSettings->readNumEntry("/window width", d->width() - 64);
@@ -1612,6 +1611,7 @@
{
if (!conf_get_changed()) {
e->accept();
+ conf_write_autoconf();
return;
}
QMessageBox mb("qconf", _("Save configuration?"), QMessageBox::Warning,
@@ -1622,6 +1622,7 @@
switch (mb.exec()) {
case QMessageBox::Yes:
conf_write(NULL);
+ conf_write_autoconf();
case QMessageBox::No:
e->accept();
break;
Index: config/util.c
===================================================================
--- config.orig/util.c

View File

@ -1611,6 +1611,7 @@ void ConfigMainWindow::closeEvent(QCloseEvent* e)
{
if (!conf_get_changed()) {
e->accept();
conf_write_autoconf();
return;
}
QMessageBox mb("qconf", _("Save configuration?"), QMessageBox::Warning,
@ -1621,6 +1622,7 @@ void ConfigMainWindow::closeEvent(QCloseEvent* e)
switch (mb.exec()) {
case QMessageBox::Yes:
conf_write(NULL);
conf_write_autoconf();
case QMessageBox::No:
e->accept();
break;