perl: fix static build with gdbm + gettext

see http://autobuild.buildroot.org/results/d1f/d1f133ca3693b6653eed4fc513effc0bbdcfd9c9/

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Francois Perrad 2017-01-17 16:04:03 +01:00 committed by Thomas Petazzoni
parent 570c8d2ae6
commit 6c9fe3c1c8

View File

@ -0,0 +1,20 @@
fix static build with gdbm + gettext
see doc http://perldoc.perl.org/ExtUtils/MakeMaker.html#LIBS
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
index: b/ext/GDBM_File/Makefile.PL
===================================================================
--- a/ext/GDBM_File/Makefile.PL
+++ b/ext/GDBM_File/Makefile.PL
@@ -2,7 +2,7 @@ use ExtUtils::MakeMaker;
use ExtUtils::Constant 0.11 'WriteConstants';
WriteMakefile(
NAME => 'GDBM_File',
- LIBS => ["-lgdbm", "-ldbm"],
+ LIBS => ["-lgdbm -lintl", "-lgdbm", "-ldbm"],
XSPROTOARG => '-noprototypes', # XXX remove later?
VERSION_FROM => 'GDBM_File.pm',
realclean => {FILES=> 'const-c.inc const-xs.inc'},