stunnel: remove broken package
It doesn't build as there's no dependency on openssl, and it hasn't seen any real updates since it got added in 2006, so simply remove it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
6ef440ba0d
commit
6c51938781
2
CHANGES
2
CHANGES
@ -21,6 +21,8 @@
|
||||
luafilesystem, lzo, netcat, php, proftpd, qt, samba,
|
||||
startup-notification, sysvinit, util-linux
|
||||
|
||||
Removed packages: stunnel
|
||||
|
||||
Issues resolved (http://bugs.uclibc.org):
|
||||
|
||||
#635: util-linux fails to build in 2009.08
|
||||
|
@ -420,7 +420,6 @@ source "package/ser2net/Config.in"
|
||||
source "package/socat/Config.in"
|
||||
source "package/spawn-fcgi/Config.in"
|
||||
source "package/squid/Config.in"
|
||||
source "package/stunnel/Config.in"
|
||||
source "package/tcpdump/Config.in"
|
||||
source "package/tcpreplay/Config.in"
|
||||
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
|
||||
|
@ -1,12 +0,0 @@
|
||||
comment "stunnel has no inherent support for AVR32"
|
||||
depends on BR2_avr32 && BR2_PACKAGE_STUNNEL
|
||||
|
||||
config BR2_PACKAGE_STUNNEL
|
||||
bool "stunnel"
|
||||
help
|
||||
Stunnel is a utility that utilised OpenSSL to wrap plaintext
|
||||
TCP communications with SSL. Can be used to secure a
|
||||
programmes insecure network communications.
|
||||
|
||||
http://www.stunnel.org/
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- stunnel-4.16/configure.ac.orig 2006-08-20 04:28:14.000000000 +0800
|
||||
+++ stunnel-4.16/configure.ac 2006-11-24 10:17:01.053905560 +0800
|
||||
@@ -45,8 +45,10 @@
|
||||
AC_DEFINE(socklen_t, int))
|
||||
|
||||
AC_MSG_NOTICE([**************************************** PTY device files])
|
||||
-AC_CHECK_FILE("/dev/ptmx", AC_DEFINE(HAVE_DEV_PTMX))
|
||||
-AC_CHECK_FILE("/dev/ptc", AC_DEFINE(HAVE_DEV_PTS_AND_PTC))
|
||||
+#AC_CHECK_FILE("/dev/ptmx", AC_DEFINE(HAVE_DEV_PTMX))
|
||||
+#AC_CHECK_FILE("/dev/ptc", AC_DEFINE(HAVE_DEV_PTS_AND_PTC))
|
||||
+AC_DEFINE(HAVE_DEV_PTMX)
|
||||
+AC_DEFINE(HAVE_DEV_PTS_AND_PTC)
|
||||
|
||||
AC_MSG_NOTICE([**************************************** entropy])
|
||||
|
@ -1,82 +0,0 @@
|
||||
#############################################################
|
||||
#
|
||||
# stunnel
|
||||
#
|
||||
#############################################################
|
||||
STUNNEL_VERSION:=4.16
|
||||
STUNNEL_SOURCE:=stunnel-$(STUNNEL_VERSION).tar.gz
|
||||
STUNNEL_SITE:=http://www.stunnel.org/download/stunnel/src
|
||||
STUNNEL_CAT:=$(ZCAT)
|
||||
STUNNEL_DIR:=$(BUILD_DIR)/stunnel-$(STUNNEL_VERSION)
|
||||
|
||||
$(DL_DIR)/$(STUNNEL_SOURCE):
|
||||
$(call DOWNLOAD,$(STUNNEL_SITE),$(STUNNEL_SOURCE))
|
||||
|
||||
stunnel-source: $(DL_DIR)/$(STUNNEL_SOURCE)
|
||||
|
||||
$(STUNNEL_DIR)/.unpacked: $(DL_DIR)/$(STUNNEL_SOURCE)
|
||||
$(STUNNEL_CAT) $(DL_DIR)/$(STUNNEL_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
$(CONFIG_UPDATE) $(STUNNEL_DIR)
|
||||
toolchain/patch-kernel.sh $(STUNNEL_DIR) package/stunnel stunnel\*.patch
|
||||
touch $(STUNNEL_DIR)/*
|
||||
touch $(STUNNEL_DIR)/.unpacked
|
||||
|
||||
$(STUNNEL_DIR)/.configured: $(STUNNEL_DIR)/.unpacked
|
||||
(cd $(STUNNEL_DIR); rm -rf config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
$(TARGET_CONFIGURE_ARGS) \
|
||||
ac_cv_file___dev_ptmx_=yes \
|
||||
ac_cv_file___dev_ptc_=no \
|
||||
./configure $(QUIET) \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--sbindir=/usr/sbin \
|
||||
--libdir=/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--sysconfdir=/etc \
|
||||
--datadir=/usr/share \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--with-random=/dev/urandom \
|
||||
--disable-libwrap \
|
||||
--with-ssl=$(STAGING_DIR)/usr/ \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
)
|
||||
touch $(STUNNEL_DIR)/.configured
|
||||
|
||||
$(STUNNEL_DIR)/src/stunnel: $(STUNNEL_DIR)/.configured
|
||||
$(MAKE) CC="$(TARGET_CC)" -C $(STUNNEL_DIR)
|
||||
|
||||
$(TARGET_DIR)/usr/bin/stunnel: $(STUNNEL_DIR)/src/stunnel
|
||||
install -c $(STUNNEL_DIR)/src/stunnel $(TARGET_DIR)/usr/bin/stunnel
|
||||
$(STRIPCMD) $(TARGET_DIR)/usr/bin/stunnel > /dev/null 2>&1
|
||||
ifeq ($(BR2_CROSS_TOOLCHAIN_TARGET_UTILS),y)
|
||||
mkdir -p $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils
|
||||
install -c $(TARGET_DIR)/usr/bin/stunnel \
|
||||
$(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils/stunnel
|
||||
endif
|
||||
|
||||
stunnel: $(TARGET_DIR)/usr/bin/stunnel
|
||||
|
||||
stunnel-clean:
|
||||
-$(MAKE) -C $(STUNNEL_DIR) clean
|
||||
rm -f $(TARGET_DIR)/usr/bin/stunnel
|
||||
|
||||
stunnel-dirclean:
|
||||
rm -rf $(STUNNEL_DIR)
|
||||
|
||||
|
||||
#############################################################
|
||||
#
|
||||
# Toplevel Makefile options
|
||||
#
|
||||
#############################################################
|
||||
ifeq ($(BR2_PACKAGE_STUNNEL),y)
|
||||
TARGETS+=stunnel
|
||||
endif
|
Loading…
Reference in New Issue
Block a user