package/lightning: bump version to 2.2.1

And restore support for MIPS64, which is supported by Lightning.

Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Paul Cercueil 2023-05-18 12:20:20 +02:00 committed by Peter Korsgaard
parent 2e511e791d
commit 6b26999abc
5 changed files with 6 additions and 47 deletions

View File

@ -893,7 +893,6 @@ package/libwebsock/0002-fix-ssl.patch Upstream
package/libwebsock/0003-fix-incorrect-inline.patch Upstream
package/libwebsockets/0001-lib-tls-CMakeLists.txt-fix-build-without-threads.patch Upstream
package/libyuv/0001-i386-sse2.patch Upstream
package/lightning/0001-lib-jit_disasm.c-fix-build.patch Upstream
package/lighttpd/0001-Modify-the-default-lighttpd-configuration-file-to-ha.patch Upstream
package/lighttpd/S50lighttpd EmptyLastLine Indent Shellcheck Variables
package/linknx/0001-configure-ac-tweak-CPPUNIT-conditional.patch Upstream

View File

@ -1,42 +0,0 @@
From 0d828c96c373c34b201ca7ea37b61c1e3b0485cd Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Mon, 19 Dec 2022 23:55:31 +0100
Subject: [PATCH] lib/jit_disasm.c: fix build
Fix the following build failure raised since
http://git.savannah.gnu.org/cgit/lightning.git/commit/?id=837c7a1e8d08fb9294578dc84694077f4d6106f9:
jit_disasm.c: In function 'fprintf_styled':
jit_disasm.c:57:27: error: parameter name omitted
57 | static int fprintf_styled(void *, enum disassembler_style, const char* fmt, ...)
| ^~~~~~
jit_disasm.c:57:35: error: parameter name omitted
57 | static int fprintf_styled(void *, enum disassembler_style, const char* fmt, ...)
| ^~~~~~~~~~~~~~~~~~~~~~~
Fixes:
- http://autobuild.buildroot.org/results/e15e01e98e0d8c873efd3f512b671d98e4daf6c0
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: make it a backport now it's applied upstream]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
lib/jit_disasm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lib/jit_disasm.c b/lib/jit_disasm.c
index 58a269b..68c966d 100644
--- a/lib/jit_disasm.c
+++ b/lib/jit_disasm.c
@@ -54,7 +54,7 @@ static FILE *disasm_stream;
#endif
#if BINUTILS_2_38
-static int fprintf_styled(void *, enum disassembler_style, const char* fmt, ...)
+static int fprintf_styled(void * stream, enum disassembler_style style, const char* fmt, ...)
{
va_list args;
int r;
--
2.25.1

View File

@ -1,12 +1,14 @@
comment "lightning needs a toolchain w/ dynamic library, threads"
depends on BR2_sparc || BR2_i386 || BR2_x86_64 || BR2_mips || \
BR2_mipsel || BR2_arm || BR2_powerpc || BR2_RISCV_64
BR2_mipsel || BR2_arm || BR2_powerpc || BR2_RISCV_64 || \
BR2_mips64 || BR2_mips64el
depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
config BR2_PACKAGE_LIGHTNING
bool "lightning"
depends on BR2_sparc || BR2_i386 || BR2_x86_64 || BR2_mips || \
BR2_mipsel || BR2_arm || BR2_powerpc || BR2_RISCV_64
BR2_mipsel || BR2_arm || BR2_powerpc || BR2_RISCV_64 || \
BR2_mips64 || BR2_mips64el
depends on !BR2_STATIC_LIBS
depends on BR2_TOOLCHAIN_HAS_THREADS
help

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 4e3984ff1ccf0ba30a985211d40fc5c06b25f014ebdf3d80d0fe3d0c80dd7c0e lightning-2.2.0.tar.gz
sha256 98671681d5684770ccb06a07fa3b8f032a454bdb56eafc18e6fab04459ea3caa lightning-2.2.1.tar.gz
sha256 a853c2ffec17057872340eee242ae4d96cbf2b520ae27d903e1b2fef1a5f9d1c COPYING.LESSER

View File

@ -4,7 +4,7 @@
#
################################################################################
LIGHTNING_VERSION = 2.2.0
LIGHTNING_VERSION = 2.2.1
LIGHTNING_SITE = $(BR2_GNU_MIRROR)/lightning
LIGHTNING_LICENSE = LGPL-3.0+
LIGHTNING_LICENSE_FILES = COPYING.LESSER