jhead: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
43a54d0846
commit
674cbf25f6
@ -107,6 +107,7 @@ menu "Graphic libraries and applications (graphic/text)"
|
||||
|
||||
comment "Graphic applications"
|
||||
source "package/gnuplot/Config.in"
|
||||
source "package/jhead/Config.in"
|
||||
source "package/rrdtool/Config.in"
|
||||
|
||||
comment "graphic libraries"
|
||||
|
11
package/jhead/Config.in
Normal file
11
package/jhead/Config.in
Normal file
@ -0,0 +1,11 @@
|
||||
config BR2_PACKAGE_JHEAD
|
||||
bool "jhead"
|
||||
depends on BR2_USE_WCHAR
|
||||
help
|
||||
Jhead is a program for manipulating settings and thumbnails
|
||||
in Exif jpeg headers used by most Digital Cameras.
|
||||
|
||||
http://www.sentex.net/~mwandel/jhead/
|
||||
|
||||
comment "jhead requires a toolchain with WCHAR support"
|
||||
depends on !BR2_USE_WCHAR
|
16
package/jhead/jhead-use-ldflags.patch
Normal file
16
package/jhead/jhead-use-ldflags.patch
Normal file
@ -0,0 +1,16 @@
|
||||
Make jhead use LDFLAGS for the final link.
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
|
||||
diff -Nura jhead-2.97.orig/makefile jhead-2.97/makefile
|
||||
--- jhead-2.97.orig/makefile 2013-03-27 09:22:38.759966389 -0300
|
||||
+++ jhead-2.97/makefile 2013-03-27 09:25:06.290691745 -0300
|
||||
@@ -14,7 +14,7 @@
|
||||
${CC} $(CFLAGS) -c $< -o $@
|
||||
|
||||
jhead: $(objs) jhead.h
|
||||
- ${CC} -o jhead $(objs) -lm
|
||||
+ ${CC} $(LDFLAGS) -o jhead $(objs) -lm
|
||||
|
||||
clean:
|
||||
rm -f $(objs) jhead
|
20
package/jhead/jhead.mk
Normal file
20
package/jhead/jhead.mk
Normal file
@ -0,0 +1,20 @@
|
||||
#############################################################
|
||||
#
|
||||
# jhead
|
||||
#
|
||||
#############################################################
|
||||
|
||||
JHEAD_VERSION = 2.97
|
||||
JHEAD_SITE = http://www.sentex.net/~mwandel/jhead
|
||||
JHEAD_LICENSE = Public Domain
|
||||
JHEAD_LICENSE_FILES = readme.txt
|
||||
|
||||
define JHEAD_BUILD_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
|
||||
endef
|
||||
|
||||
define JHEAD_INSTALL_TARGET_CMDS
|
||||
$(INSTALL) -m 0755 -D $(@D)/jhead $(TARGET_DIR)/usr/bin/jhead
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user