From 664c370d0b64df43b98dca93429c56ad0ed2c4a6 Mon Sep 17 00:00:00 2001
From: Adam Duskett <Aduskett@gmail.com>
Date: Fri, 31 Jul 2020 13:40:57 -0700
Subject: [PATCH] package/libselinux: enable kernel selinux support for f2fs
 images

If BR2_TARGET_ROOTFS_F2FS is selected, enable the following kernel options:
  - CONFIG_F2FS_FS_XATTR
  - CONFIG_F2FS_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/libselinux/libselinux.mk | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/package/libselinux/libselinux.mk b/package/libselinux/libselinux.mk
index 44d9ec3657..c16dcdf1d0 100644
--- a/package/libselinux/libselinux.mk
+++ b/package/libselinux/libselinux.mk
@@ -122,6 +122,9 @@ define LIBSELINUX_LINUX_CONFIG_FIXUPS
 		$(call KCONFIG_ENABLE_OPT,CONFIG_EXT3_FS_SECURITY))
 	$(if $(BR2_TARGET_ROOTFS_EXT2_4),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_EXT4_FS_SECURITY))
+	$(if $(BR2_TARGET_ROOTFS_F2FS),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_XATTR)
+		$(call KCONFIG_ENABLE_OPT,CONFIG_F2FS_FS_SECURITY))
 endef
 
 $(eval $(generic-package))