luaposix: New package

Luaposix is a Lua frontend to posix functions.

Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Assaf Inbal 2013-06-20 07:40:50 +03:00 committed by Peter Korsgaard
parent a869bf8c84
commit 6618ab9436
4 changed files with 43 additions and 0 deletions

View File

@ -321,6 +321,7 @@ source "package/luacrypto/Config.in"
source "package/luaexpat/Config.in"
source "package/luaexpatutils/Config.in"
source "package/luafilesystem/Config.in"
source "package/luaposix/Config.in"
source "package/luasocket/Config.in"
source "package/lua-ev/Config.in"
source "package/lua-msgpack-native/Config.in"

View File

@ -0,0 +1,11 @@
config BR2_PACKAGE_LUAPOSIX
bool "luaposix"
help
luaposix is a POSIX binding, including curses, for Lua 5.1
and 5.2; Like most libraries it simply binds to C APIs on
the underlying system, so it won't work on a non-POSIX
system. However, it does try to detect the level of POSIX
conformance of the underlying system and bind only available
APIs
https://github.com/luaposix/luaposix

View File

@ -0,0 +1,16 @@
Checking the Lua version inside the headers requires compiling a small
C program. However, autoconf will raise an error when attempting to do so
while cross-compiling. Hence, this specific test is removed.
Signed-off-by: Assaf Inbal <shmuelzon@gmail.com>
--- a/configure.ac 2013-06-20 07:23:27.943091833 +0300
+++ b/configure.ac 2013-06-20 07:23:30.644441710 +0300
@@ -105,7 +105,7 @@
dnl Lua 5.1 or 5.2
AX_PROG_LUA(501, 503)
AX_LUA_HEADERS
-AX_LUA_HEADERS_VERSION(501, 503)
+#AX_LUA_HEADERS_VERSION(501, 503)
AC_SUBST(LUA)
AC_SUBST(LUA_INCLUDE)

View File

@ -0,0 +1,15 @@
################################################################################
#
# luaposix
#
################################################################################
LUAPOSIX_VERSION = 5.1.20
LUAPOSIX_SITE = https://github.com/downloads/luaposix/luaposix
LUAPOSIX_LICENSE = MIT
LUAPOSIX_LICENSE_FILES = COPYING
LUAPOSIX_DEPENDENCIES = lua host-lua
LUAPOSIX_CONF_OPT = --libdir="/usr/lib/lua" --datarootdir="/usr/share/lua"
LUAPOSIX_AUTORECONF = YES
$(eval $(autotools-package))