package/python-aiohttp-remotes: bump to version 1.2.0

Migrate from distutils to flit package infrastructure.

Add a patch fixing incorrect flit requires/build-backend in
pyproject.toml.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
James Hilliard 2022-12-12 08:06:10 -07:00 committed by Thomas Petazzoni
parent 7e4b0d8be5
commit 65d14c82db
3 changed files with 37 additions and 5 deletions

View File

@ -0,0 +1,32 @@
From 3d39ee9a03a1c96b8e798dc6acf98165da31da1f Mon Sep 17 00:00:00 2001
From: James Hilliard <james.hilliard1@gmail.com>
Date: Fri, 11 Mar 2022 12:59:53 -0700
Subject: [PATCH] Fix flit_core build requires/backend.
Only flit_core should be required by pyproject.toml, the regular flit
package is the pep517 frontend which is not what should be set for the
build system.
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[Upstream status:
https://github.com/aio-libs/aiohttp-remotes/pull/355]
---
pyproject.toml | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/pyproject.toml b/pyproject.toml
index 214d64d..8c6b882 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
-requires=["flit"]
-build-backend="flit.buildapi"
+requires=["flit_core"]
+build-backend="flit_core.buildapi"
[tool.flit.metadata]
module="aiohttp_remotes"
--
2.38.1

View File

@ -1,5 +1,5 @@
# md5, sha256 from https://pypi.org/pypi/aiohttp-remotes/json
md5 da13880f25ec3b9cf98c7baff92835a2 aiohttp_remotes-1.1.0.tar.gz
sha256 e44f2c5fd5fc3305477c89bb25f14570589100cc58c48b36745d4239839d3174 aiohttp_remotes-1.1.0.tar.gz
md5 c46a71df656e7f1e111684ced68a85d0 aiohttp_remotes-1.2.0.tar.gz
sha256 f95c3a6be5e2de746a85ce9af49ec548da6db8378d7e81bb171ec77b13562a6c aiohttp_remotes-1.2.0.tar.gz
# Locally computed sha256 checksums
sha256 4e7d0edf250abe2a28027788b8c55a53d1b5c9ff961b8a00643c76aed637ba13 LICENSE

View File

@ -4,10 +4,10 @@
#
################################################################################
PYTHON_AIOHTTP_REMOTES_VERSION = 1.1.0
PYTHON_AIOHTTP_REMOTES_VERSION = 1.2.0
PYTHON_AIOHTTP_REMOTES_SOURCE = aiohttp_remotes-$(PYTHON_AIOHTTP_REMOTES_VERSION).tar.gz
PYTHON_AIOHTTP_REMOTES_SITE = https://files.pythonhosted.org/packages/e3/fc/5523010172e2d8685a8934fbb49d564118c9ebc1e4233a62b77310f979db
PYTHON_AIOHTTP_REMOTES_SETUP_TYPE = distutils
PYTHON_AIOHTTP_REMOTES_SITE = https://files.pythonhosted.org/packages/54/05/7c4be6171cc78a13171a4f89e5d308c4a636bdd8ee36101367e99e410ed8
PYTHON_AIOHTTP_REMOTES_SETUP_TYPE = flit
PYTHON_AIOHTTP_REMOTES_LICENSE = MIT
PYTHON_AIOHTTP_REMOTES_LICENSE_FILES = LICENSE