package/ipcalc: bump to version 1.0.1
- Drop patches (already in version) - Update indentation in hash file (two spaces) https://gitlab.com/ipcalc/ipcalc/-/blob/1.0.1/NEWS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
289a15f33b
commit
657de04a2f
@ -1,49 +0,0 @@
|
||||
From 322294d7bf61f9fdf0e45e9b6c6013a7c6a35bfd Mon Sep 17 00:00:00 2001
|
||||
From: Derrick Lyndon Pallas <derrick@meter.com>
|
||||
Date: Wed, 14 Oct 2020 18:25:54 +0000
|
||||
Subject: [PATCH] Do not fail to build if ronn is missing
|
||||
|
||||
If ruby-ronn is missing, we can not compile the man page from markdown but
|
||||
that should not prevent the application from building.
|
||||
|
||||
Signed-off-by: Derrick Lyndon Pallas <derrick@meter.com>
|
||||
---
|
||||
meson.build | 23 ++++++++++++-----------
|
||||
1 file changed, 12 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index a2169fc..981d4a4 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -72,16 +72,17 @@ ipcalc = executable('ipcalc',
|
||||
install : true
|
||||
)
|
||||
|
||||
-ronn = find_program('ronn', required: true)
|
||||
-
|
||||
-ipcalc_1 = custom_target(
|
||||
- 'ipcalc.1',
|
||||
- output : 'ipcalc.1',
|
||||
- input : 'ipcalc.1.md',
|
||||
- command : [ronn, '--pipe', '-r', '@INPUT@'],
|
||||
- capture: true,
|
||||
- install_dir: join_paths(get_option('mandir'), 'man1'),
|
||||
- install: true
|
||||
-)
|
||||
+ronn = find_program('ronn', required: false)
|
||||
+if ronn.found()
|
||||
+ ipcalc_1 = custom_target(
|
||||
+ 'ipcalc.1',
|
||||
+ output : 'ipcalc.1',
|
||||
+ input : 'ipcalc.1.md',
|
||||
+ command : [ronn, '--pipe', '-r', '@INPUT@'],
|
||||
+ capture: true,
|
||||
+ install_dir: join_paths(get_option('mandir'), 'man1'),
|
||||
+ install: true
|
||||
+ )
|
||||
+endif
|
||||
|
||||
subdir('tests')
|
||||
--
|
||||
2.28.0
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 7795c02fb1e0f5fdbdf949007e52684c590235d4 Mon Sep 17 00:00:00 2001
|
||||
From: Derrick Lyndon Pallas <derrick@meter.com>
|
||||
Date: Wed, 14 Oct 2020 18:40:38 +0000
|
||||
Subject: [PATCH] Include stdarg for va_list
|
||||
|
||||
While several function signatures use va_list, stdarg was never included.
|
||||
This fixes that.
|
||||
|
||||
Signed-off-by: Derrick Lyndon Pallas <derrick@meter.com>
|
||||
---
|
||||
ipcalc.h | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/ipcalc.h b/ipcalc.h
|
||||
index 0e81320..a220dc5 100644
|
||||
--- a/ipcalc.h
|
||||
+++ b/ipcalc.h
|
||||
@@ -20,6 +20,8 @@
|
||||
#ifndef _IPCALC_H
|
||||
#define _IPCALC_H
|
||||
|
||||
+#include <stdarg.h> /* for va_list */
|
||||
+
|
||||
#if defined(USE_GEOIP)
|
||||
void geo_ip_lookup(const char *ip, char **country, char **ccode, char **city, char **coord);
|
||||
int geo_setup(void);
|
||||
--
|
||||
2.28.0
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 d7aca371335ab3e35364bcfe34cd0229db005be8bebb9236608ec318cb3f7748 ipcalc-1.0.0.tar.bz2
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
sha256 dac080c0773cc14c1d6f818899351d2286cace85751dd9dc704944e54c2c3565 ipcalc-1.0.1.tar.bz2
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
IPCALC_VERSION = 1.0.0
|
||||
IPCALC_VERSION = 1.0.1
|
||||
IPCALC_SITE = $(call gitlab,ipcalc,ipcalc,$(IPCALC_VERSION))
|
||||
IPCALC_SOURCE = ipcalc-$(IPCALC_VERSION).tar.bz2
|
||||
IPCALC_LICENSE = GPL-2.0+
|
||||
|
Loading…
Reference in New Issue
Block a user