package/fluent-bit: bump to version 2.0.9

- Release Notes:

    https://fluentbit.io/announcements/v2.0.9/

- Patch dropped, as it is upstream:

    7bcb502ebd

Signed-off-by: Thomas Devoogdt <thomas.devoogdt@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas Devoogdt 2023-02-11 19:25:43 +01:00 committed by Peter Korsgaard
parent 98e0452ebb
commit 656af31891
3 changed files with 2 additions and 29 deletions

View File

@ -1,27 +0,0 @@
From 7bcb502ebdcd647d6b83c972805e734ad522eb1a Mon Sep 17 00:00:00 2001
From: Thomas Devoogdt <thomas.devoogdt@barco.com>
Date: Mon, 30 Jan 2023 09:10:37 +0100
Subject: [PATCH] CMakeLists.txt: only require a C compiler
Fluent-bit is mostly written in C,
so don't require CXX in the top-level project.
Signed-off-by: Thomas Devoogdt <thomas.devoogdt@barco.com>
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7adb02de..3ff7360d8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.12)
-project(fluent-bit)
+project(fluent-bit C)
# CMP0069 ensures that LTO is enabled for all compilers
cmake_policy(SET CMP0069 NEW)
--
2.30.2

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 8ff5566389033669feabc9c69a5c6f417dad5c8b066454388e6a706507262acf fluent-bit-2.0.8.tar.gz
sha256 393ad4a6ced48c327607653d610ef273843085a17b6e5c8013877abdf31e6945 fluent-bit-2.0.9.tar.gz
sha256 0d542e0c8804e39aa7f37eb00da5a762149dc682d7829451287e11b938e94594 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
FLUENT_BIT_VERSION = 2.0.8
FLUENT_BIT_VERSION = 2.0.9
FLUENT_BIT_SITE = $(call github,fluent,fluent-bit,v$(FLUENT_BIT_VERSION))
FLUENT_BIT_LICENSE = Apache-2.0
FLUENT_BIT_LICENSE_FILES = LICENSE