iw: add support for libnl-3.0

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Yegor Yefremov 2011-04-28 09:23:51 +02:00 committed by Peter Korsgaard
parent fec53c73cf
commit 644d8808d2

View File

@ -0,0 +1,47 @@
---
Makefile | 10 ++++++++++
1 file changed, 10 insertions(+)
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,7 @@
NL1FOUND := $(shell $(PKG_CONFIG) --atleast-version=1 libnl-1 && echo Y)
NL2FOUND := $(shell $(PKG_CONFIG) --atleast-version=2 libnl-2.0 && echo Y)
+NL3FOUND := $(shell $(PKG_CONFIG) --atleast-version=3 libnl-3.0 && echo Y)
ifeq ($(NL1FOUND),Y)
NLLIBNAME = libnl-1
@@ -35,6 +36,12 @@
NLLIBNAME = libnl-2.0
endif
+ifeq ($(NL3FOUND),Y)
+CFLAGS += -DCONFIG_LIBNL20
+LIBS += -lnl-genl
+NLLIBNAME = libnl-3.0
+endif
+
ifeq ($(NLLIBNAME),)
$(error Cannot find development files for any supported version of libnl)
endif
@@ -53,6 +60,8 @@
all: version_check $(ALL)
version_check:
+ifeq ($(NL3FOUND),Y)
+else
ifeq ($(NL2FOUND),Y)
else
ifeq ($(NL1FOUND),Y)
@@ -60,6 +69,7 @@
$(error No libnl found)
endif
endif
+endif
VERSION_OBJS := $(filter-out version.o, $(OBJS))