usb_modeswitch: Bump to version 1.1.2

And correct kconfig dependency.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Gustavo Zacarias 2010-04-22 15:58:16 -03:00 committed by Peter Korsgaard
parent 23ff3c2786
commit 63b8666409
5 changed files with 40 additions and 37 deletions

View File

@ -2,7 +2,12 @@
Fixes all over the tree.
Updated/fixed packages: mplayer, xdriver_xf86-video-openchrome
Updated/fixed packages: mplayer, xdriver_xf86-video-openchrome,
usb_modeswitch
Issues resolved (http://bugs.uclibc.org):
#985: Bump usb_modeswitch package to 1.1.0
2010.05-rc1, Released May 3rd, 2010:

View File

@ -1,5 +1,6 @@
config BR2_PACKAGE_USB_MODESWITCH
bool "usb_modeswitch"
select BR2_PACKAGE_LIBUSB
select BR2_PACKAGE_LIBUSB_COMPAT
help
USB mode switcher.

View File

@ -1,29 +0,0 @@
---
Makefile | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
Index: usb_modeswitch-1.0.7/Makefile
===================================================================
--- usb_modeswitch-1.0.7.orig/Makefile
+++ usb_modeswitch-1.0.7/Makefile
@@ -1,8 +1,8 @@
PROG = usb_modeswitch
VERS = 1.0.7
STRIP = strip
-CC = gcc
-CCFLAGS = -l usb -Wall
+CC ?= gcc
+CFLAGS += -l usb -Wall
RM = /bin/rm -f
OBJS = usb_modeswitch.c
PREFIX = $(DESTDIR)/usr
@@ -12,8 +12,7 @@
.PHONY: clean
all: $(PROG)
$(PROG): $(OBJS)
- $(CC) $(CCFLAGS) -o $(PROG) $(OBJS)
- $(STRIP) $(PROG)
+ $(CC) $(CFLAGS) -o $(PROG) $(OBJS)
clean:
$(RM) ./usb_modeswitch

View File

@ -0,0 +1,23 @@
diff -Nura usb-modeswitch-1.1.2.orig/Makefile usb-modeswitch-1.1.2/Makefile
--- usb-modeswitch-1.1.2.orig/Makefile 2010-04-17 15:27:11.000000000 -0300
+++ usb-modeswitch-1.1.2/Makefile 2010-04-22 15:05:32.363471807 -0300
@@ -1,6 +1,6 @@
PROG = usb_modeswitch
VERS = 1.1.2
-CC = gcc
+CC ?= gcc
CFLAGS += -Wall -l usb
RM = /bin/rm -f
OBJS = usb_modeswitch.c
@@ -23,8 +23,9 @@
install: all
install -d $(SBINDIR)
install --mode=755 usb_modeswitch $(SBINDIR)/usb_modeswitch
- install --mode=755 usb_modeswitch.tcl $(UDEVDIR)/usb_modeswitch
- install --mode=644 usb_modeswitch.conf $(ETCDIR)/usb_modeswitch.conf
+ #install --mode=755 usb_modeswitch.tcl $(UDEVDIR)/usb_modeswitch
+ #install --mode=644 usb_modeswitch.conf $(ETCDIR)/usb_modeswitch.conf
+ install -d $(MANDIR)
install --mode=644 usb_modeswitch.1 $(MANDIR)/usb_modeswitch.1

View File

@ -4,23 +4,26 @@
#
#############################################################
USB_MODESWITCH_VERSION = 1.0.7
USB_MODESWITCH_SOURCE = usb_modeswitch-$(USB_MODESWITCH_VERSION).tar.bz2
USB_MODESWITCH_VERSION = 1.1.2
USB_MODESWITCH_SOURCE = usb-modeswitch-$(USB_MODESWITCH_VERSION).tar.bz2
USB_MODESWITCH_SITE = http://www.draisberghof.de/usb_modeswitch
USB_MODESWITCH_DEPENDENCIES = libusb-compat
define USB_MODESWITCH_BUILD_CMDS
rm $(@D)/usb_modeswitch
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
endef
define USB_MODESWITCH_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
$(INSTALL) -D $(@D)/usb_modeswitch.setup -m 0644 \
$(TARGET_DIR)/etc/usb_modeswitch.setup
endef
define USB_MODESWITCH_CLEAN_CMDS
rm -f $(TARGET_DIR)/usr/sbin/usb_modeswitch
rm -f $(TARGET_DIR)/etc/usb_modeswitch.conf
rm -f $(TARGET_DIR)/usr/sbin/usb_modeswitch
rm -f $(TARGET_DIR)/etc/usb_modeswitch.setup
rm -f $(TARGET_DIR)/usr/share/man/man1/usb_modeswitch.1
endef
$(eval $(call GENTARGETS,package,usb_modeswitch))