package/libpng: bump version to 1.6.42
Release notes: https://raw.githubusercontent.com/pnggroup/libpng/v1.6.42/ANNOUNCE Removed patch which disabled pngfix and png-fix-itxt tools and use the new upstream-provided configure option --disable-tools instead:22ad62c25e
71475b064f
Updated license hash due to copyright year bump:0dfe422e9f
Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
96a7db5a4b
commit
632d8f25b7
@ -676,7 +676,6 @@ package/liboping/0004-Fix-compile-error-on-GCC-7.patch Upstream
|
||||
package/liboping/0005-src-oping.c-always-use-s-style-format-for-printf-sty.patch Upstream
|
||||
package/libp11/0001-src-p11_attr.c-fix-build-with-gcc-4.8.patch Upstream
|
||||
package/libplatform/0001-cmake-require-c-11-as-the-minimum-standard.patch Upstream
|
||||
package/libpng/0001-Disable-pngfix-and-png-fix-itxt.patch Upstream
|
||||
package/libpthsem/0001-fix-build-on-linux-3.x-host.patch Upstream
|
||||
package/libressl/0001-always-expose-SSL_OP_NO_TLSv1_3.patch Upstream
|
||||
package/libroxml/0001-src-roxml_mem.h-add-missing-extern.patch Upstream
|
||||
|
@ -1,47 +0,0 @@
|
||||
From 60c3ee917c8e7a4760b1ef7c3dc2b44a615150d3 Mon Sep 17 00:00:00 2001
|
||||
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
Date: Thu, 26 May 2016 16:26:18 -0300
|
||||
Subject: [PATCH] Disable pngfix and png-fix-itxt
|
||||
|
||||
Disable the new pngfix and png-fix-itxt tools: they take up space, fail
|
||||
to build on some oddball toolchain configurations and aren't
|
||||
expected/needed in a non-interactive embedded system.
|
||||
|
||||
[Julien: update for 1.6.25]
|
||||
Signed-off-by: Julien Boibessot <julien.boibessot@armadeus.com>
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
Makefile.in | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 7212951..3430dca 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -18,7 +18,7 @@ check_PROGRAMS += timepng
|
||||
endif
|
||||
|
||||
# Utilities - installed
|
||||
-bin_PROGRAMS= pngfix png-fix-itxt
|
||||
+bin_PROGRAMS=
|
||||
|
||||
# This ensures that pnglibconf.h gets built at the start of 'make all' or
|
||||
# 'make check', but it does not add dependencies to the individual programs,
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index a66f6aa..4e67782 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -104,7 +104,7 @@ check_PROGRAMS = pngtest$(EXEEXT) pngunknown$(EXEEXT) \
|
||||
pngstest$(EXEEXT) pngvalid$(EXEEXT) pngimage$(EXEEXT) \
|
||||
pngcp$(EXEEXT) $(am__EXEEXT_1)
|
||||
@HAVE_CLOCK_GETTIME_TRUE@am__append_1 = timepng
|
||||
-bin_PROGRAMS = pngfix$(EXEEXT) png-fix-itxt$(EXEEXT)
|
||||
+bin_PROGRAMS =
|
||||
@PNG_ARM_NEON_TRUE@am__append_2 = arm/arm_init.c\
|
||||
@PNG_ARM_NEON_TRUE@ arm/filter_neon.S arm/filter_neon_intrinsics.c \
|
||||
@PNG_ARM_NEON_TRUE@ arm/palette_neon_intrinsics.c
|
||||
--
|
||||
2.7.3
|
||||
|
@ -1,4 +1,4 @@
|
||||
# From https://sourceforge.net/p/png-mng/mailman/message/37860896/
|
||||
sha256 535b479b2467ff231a3ec6d92a525906fb8ef27978be4f66dbe05d3f3a01b3a1 libpng-1.6.40.tar.xz
|
||||
# From https://sourceforge.net/p/png-mng/mailman/message/58731120/
|
||||
sha256 c919dbc11f4c03b05aba3f8884d8eb7adfe3572ad228af972bb60057bdb48450 libpng-1.6.42.tar.xz
|
||||
# Locally computed:
|
||||
sha256 5c0bb4b05b1354ae7c173532b6702ea68b611047ff9b91c4d3af77da39c195d9 LICENSE
|
||||
sha256 7317e078e2d3b5d7ba5a6159e650945153262b44b76f6700f8e9edb261c5143e LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBPNG_VERSION = 1.6.40
|
||||
LIBPNG_VERSION = 1.6.42
|
||||
LIBPNG_SERIES = 16
|
||||
LIBPNG_SOURCE = libpng-$(LIBPNG_VERSION).tar.xz
|
||||
LIBPNG_SITE = http://downloads.sourceforge.net/project/libpng/libpng$(LIBPNG_SERIES)/$(LIBPNG_VERSION)
|
||||
@ -15,6 +15,7 @@ LIBPNG_INSTALL_STAGING = YES
|
||||
LIBPNG_DEPENDENCIES = host-pkgconf zlib
|
||||
HOST_LIBPNG_DEPENDENCIES = host-pkgconf host-zlib
|
||||
LIBPNG_CONFIG_SCRIPTS = libpng$(LIBPNG_SERIES)-config libpng-config
|
||||
LIBPNG_CONF_OPTS = --disable-tools
|
||||
|
||||
ifeq ($(BR2_ARM_CPU_HAS_NEON)$(BR2_aarch64),y)
|
||||
LIBPNG_CONF_OPTS += --enable-arm-neon
|
||||
|
Loading…
Reference in New Issue
Block a user