luajit: bump to version 2.0.5
Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
b5219885ce
commit
62bf7468a4
@ -14,11 +14,11 @@ Index: b/Makefile
|
||||
-INSTALL_TSYMNAME= luajit
|
||||
+INSTALL_TNAME= luajit
|
||||
INSTALL_ANAME= libluajit-$(ABIVER).a
|
||||
INSTALL_SONAME= libluajit-$(ABIVER).so.$(MAJVER).$(MINVER).$(RELVER)
|
||||
INSTALL_SOSHORT= libluajit-$(ABIVER).so
|
||||
@@ -58,7 +57,6 @@
|
||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
INSTALL_SOSHORT1= libluajit-$(ABIVER).so
|
||||
INSTALL_SOSHORT2= libluajit-$(ABIVER).so.$(MAJVER)
|
||||
@@ -59,7 +58,6 @@
|
||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT1)
|
||||
INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT2)
|
||||
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
||||
-INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
|
||||
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
|
||||
|
@ -1,22 +0,0 @@
|
||||
fix the following runtime error :
|
||||
luajit: error while loading shared libraries: libluajit-5.1.so.2: cannot open shared object file: No such file or directory
|
||||
|
||||
by creating two symbolic links:
|
||||
libluajit-5.1.so -> libluajit-5.1.so.2.0.3
|
||||
libluajit-5.1.so.2 -> libluajit-5.1.so.2.0.3
|
||||
|
||||
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
|
||||
|
||||
Index: b/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -55,7 +55,7 @@
|
||||
INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL_ANAME)
|
||||
INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
|
||||
INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
-INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
|
||||
+INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT).$(MAJVER)
|
||||
INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
|
||||
INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)
|
||||
|
@ -1,2 +1,2 @@
|
||||
# Hashes from: http://luajit.org/download.html
|
||||
md5 dd9c38307f2223a504cbfb96e477eca0 LuaJIT-2.0.4.tar.gz
|
||||
md5 48353202cbcacab84ee41a5a70ea0a2c LuaJIT-2.0.5.tar.gz
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LUAJIT_VERSION = 2.0.4
|
||||
LUAJIT_VERSION = 2.0.5
|
||||
LUAJIT_SOURCE = LuaJIT-$(LUAJIT_VERSION).tar.gz
|
||||
LUAJIT_SITE = http://luajit.org/download
|
||||
LUAJIT_LICENSE = MIT
|
||||
|
Loading…
Reference in New Issue
Block a user