package/rtl8189fs: fix build with big endian
Add local patch to allow to override CFLAGS and undefine CONFIG_LITTLE_ENDIAN by default and use the correct endianness according to target architecture. Fixes: http://autobuild.buildroot.net/results/fe67db3884573ef750eda9d0dccd5f97b3ae698e Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
96a54b0907
commit
624814f4ec
@ -0,0 +1,41 @@
|
||||
From f48d99fab8b79e573850067a3ff2d8c16aa95ce1 Mon Sep 17 00:00:00 2001
|
||||
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
Date: Wed, 28 Sep 2022 21:17:17 +0200
|
||||
Subject: [PATCH] Makefile: move 'EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)' at the
|
||||
end of EXTRA_FLAGS assignment
|
||||
|
||||
At the moment USER_EXTRA_CFLAGS can't override local Makfile EXTRA_CFLAGS
|
||||
since it's assigned at the beginning of the Makefile. For example it's not
|
||||
possible to undefine the hardcoded CONFIG_LITTLE_ENDIAN and this doesn't
|
||||
allow to build these modules for big endian architectures. So let's move
|
||||
the assignment of USER_EXTRA_CFLAGS to EXTRA_CFLAGS after the last
|
||||
EXTRA_CFLAGS assignment.
|
||||
|
||||
Upstream: https://github.com/jwrdegoede/rtl8189ES_linux/pull/101
|
||||
|
||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
---
|
||||
Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index dfca305..6f91d0a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,4 +1,3 @@
|
||||
-EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
|
||||
EXTRA_CFLAGS += -O1
|
||||
#EXTRA_CFLAGS += -O3
|
||||
#EXTRA_CFLAGS += -Wall
|
||||
@@ -2208,6 +2207,8 @@ ifneq ($(USER_MODULE_NAME),)
|
||||
MODULE_NAME := $(USER_MODULE_NAME)
|
||||
endif
|
||||
|
||||
+EXTRA_CFLAGS += $(USER_EXTRA_CFLAGS)
|
||||
+
|
||||
ifneq ($(KERNELRELEASE),)
|
||||
|
||||
########### this part for *.mk ############################
|
||||
--
|
||||
2.34.1
|
||||
|
@ -8,10 +8,15 @@ RTL8189FS_VERSION = 75a566a830037c7d1309c5a9fe411562772a1cf2
|
||||
RTL8189FS_SITE = $(call github,jwrdegoede,rtl8189ES_linux,$(RTL8189FS_VERSION))
|
||||
RTL8189FS_LICENSE = GPL-2.0
|
||||
|
||||
RTL8189FS_USER_EXTRA_CFLAGS = \
|
||||
-UCONFIG_LITTLE_ENDIAN \
|
||||
-DCONFIG_$(call qstrip,$(BR2_ENDIAN))_ENDIAN
|
||||
|
||||
RTL8189FS_MODULE_MAKE_OPTS = \
|
||||
CONFIG_RTL8189FS=m \
|
||||
KVER=$(LINUX_VERSION_PROBED) \
|
||||
KSRC=$(LINUX_DIR)
|
||||
KSRC=$(LINUX_DIR) \
|
||||
USER_EXTRA_CFLAGS="$(RTL8189FS_USER_EXTRA_CFLAGS)"
|
||||
|
||||
ifeq ($(BR2_ENABLE_RUNTIME_DEBUG),)
|
||||
RTL8189FS_MODULE_MAKE_OPTS += CONFIG_RTW_DEBUG=n
|
||||
|
Loading…
Reference in New Issue
Block a user