xlib_libXpm: fix build on noMMU architectures

Add a patch to libXpm to fix build on noMMU architectures.

Fixes:

  http://autobuild.buildroot.org/results/c57/c571b0a9d9f36a445ea36a4bd609154f9a9bddd5/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas Petazzoni 2014-05-17 18:53:30 +02:00 committed by Peter Korsgaard
parent 382eef528e
commit 5ff8a7156b
2 changed files with 23 additions and 0 deletions

View File

@ -0,0 +1,21 @@
Allow usage when fork() is not available
When fork() is not available, we need to define NO_ZPIPE so that
libXpm doesn't try to fork/exec to use a pipe to uncompress compressed
.xpm files. There is obviously a loss of functionality, but loading
uncompressed .xpm files should continue to work.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/configure.ac
===================================================================
--- a/configure.ac
+++ b/configure.ac
@@ -22,6 +22,7 @@
# Checks for library functions
AC_CHECK_FUNCS([strlcat])
+AC_CHECK_FUNC([fork],[], AC_DEFINE(NO_ZPIPE))
# Obtain compiler/linker options for dependencies
PKG_CHECK_MODULES(XPM, xproto x11)

View File

@ -10,6 +10,8 @@ XLIB_LIBXPM_SITE = http://xorg.freedesktop.org/releases/individual/lib
XLIB_LIBXPM_LICENSE = MIT
XLIB_LIBXPM_LICENSE_FILES = COPYING
XLIB_LIBXPM_INSTALL_STAGING = YES
# we patch configure.ac
XLIB_LIBXPM_AUTORECONF = YES
XLIB_LIBXPM_DEPENDENCIES = xlib_libX11 xlib_libXext xlib_libXt xproto_xproto \
host-gettext