From 5f71fc1f19c21676f029b63499e0341a89cf2049 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Thu, 4 Nov 2010 20:31:25 +0100
Subject: [PATCH] Remove support for shared configuration cache

The configuration cache shared between packages, while being in
principle a nice idea to speed-up the configuration of packages by
avoiding repetitive identical checks, turned out to be unreliable due
to the subtle differences between similar but not identical checks in
different packages. After spending some time trying to fix those, we
concluded that supporting the shared configuration cache is definitely
too hard and too unreliable, and that we'd better get rid of it
altogether.

This patch therefore removes the shared configuration cache
infrastructure and usage.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
 CHANGES                                            |  3 +++
 Config.in                                          | 14 --------------
 Makefile                                           |  9 ---------
 configs/arm_nptl_toolchain_defconfig               |  1 -
 configs/arm_toolchain_defconfig                    |  1 -
 configs/at91rm9200df_defconfig                     |  1 -
 configs/at91rm9200df_ext_bare_defconfig            |  1 -
 configs/at91rm9200df_ext_defconfig                 |  1 -
 configs/at91sam9260dfc_defconfig                   |  1 -
 configs/at91sam9260dfc_ext_bare_defconfig          |  1 -
 configs/at91sam9260dfc_ext_defconfig               |  1 -
 configs/at91sam9261ek_defconfig                    |  1 -
 configs/at91sam9261ek_ext_bare_defconfig           |  1 -
 configs/at91sam9261ek_ext_defconfig                |  1 -
 configs/at91sam9263ek_defconfig                    |  1 -
 configs/at91sam9263ek_ext_bare_defconfig           |  1 -
 configs/at91sam9263ek_ext_defconfig                |  1 -
 configs/at91sam9g20dfc_defconfig                   |  1 -
 configs/at91sam9g20dfc_ext_bare_defconfig          |  1 -
 configs/at91sam9g20dfc_ext_defconfig               |  1 -
 configs/atngw100-base_defconfig                    |  1 -
 configs/atngw100_defconfig                         |  1 -
 configs/atstk1005_defconfig                        |  1 -
 configs/atstk100x_defconfig                        |  1 -
 configs/i386_defconfig                             |  1 -
 configs/i686_defconfig                             |  1 -
 configs/integrator926_defconfig                    |  1 -
 configs/integrator926_huge_defconfig               |  1 -
 docs/buildroot.html                                |  7 -------
 package/Makefile.autotools.in                      |  3 ---
 package/fontconfig/fontconfig.mk                   |  1 -
 package/gamin/gamin.mk                             |  2 --
 package/haserl/haserl.mk                           |  2 --
 package/libxml2/libxml2.mk                         |  2 --
 package/multimedia/alsa-lib/alsa-lib.mk            |  2 --
 package/ng-spice-rework/ng-spice-rework.mk         |  2 --
 package/rpm/rpm.mk                                 |  2 --
 package/sqlite/sqlite.mk                           |  2 --
 .../xserver_xorg-server/xserver_xorg-server.mk     |  1 -
 39 files changed, 3 insertions(+), 74 deletions(-)

diff --git a/CHANGES b/CHANGES
index ac4cf60aab..32bc6a7185 100644
--- a/CHANGES
+++ b/CHANGES
@@ -16,6 +16,9 @@
 	Download handling reworked and support for git/svn downloads
 	added.
 
+	Removed experimental shared config.cache support, as it is
+	too unreliable.
+
 	A convenience Makefile wrapper is created when using
 	out-of-tree building, similar to how it is done for the kernel.
 
diff --git a/Config.in b/Config.in
index b5d4084525..a41cd3ef50 100644
--- a/Config.in
+++ b/Config.in
@@ -256,20 +256,6 @@ config BR2_HAVE_DEVFILES
 	  Install headers and static libraries in the
 	  target filesystem
 
-menu "Advanced"
-
-config BR2_CONFIG_CACHE
-	bool "Use a central configure cache file (EXPERIMENTAL)"
-	help
-	  Notice: This is experimental and known to break with certain
-	  package combinations.
-
-	  This determines if a central config cache is used by
-	  packages, reducing the configure time for packages as each
-	  one caches its findings.
-
-endmenu
-
 endmenu
 
 source "toolchain/Config.in"
diff --git a/Makefile b/Makefile
index 3664c96030..18ca8b33d4 100644
--- a/Makefile
+++ b/Makefile
@@ -447,15 +447,6 @@ external-deps:
 show-targets:
 	@echo $(TARGETS)
 
-ifeq ($(BR2_CONFIG_CACHE),y)
-# drop configure caches if configuration is changed
-$(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache: $(CONFIG_DIR)/.config
-	rm -f $@
-	touch $@
-
-$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
-endif
-
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 all: menuconfig
diff --git a/configs/arm_nptl_toolchain_defconfig b/configs/arm_nptl_toolchain_defconfig
index d7b26a5b08..e167bc34a0 100644
--- a/configs/arm_nptl_toolchain_defconfig
+++ b/configs/arm_nptl_toolchain_defconfig
@@ -155,7 +155,6 @@ BR2_OPTIMIZE_2=y
 #
 # Advanced
 #
-# BR2_CONFIG_CACHE is not set
 
 #
 # Toolchain
diff --git a/configs/arm_toolchain_defconfig b/configs/arm_toolchain_defconfig
index 37426ae634..d4642d96b3 100644
--- a/configs/arm_toolchain_defconfig
+++ b/configs/arm_toolchain_defconfig
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91rm9200df_defconfig b/configs/at91rm9200df_defconfig
index ac5bfa3c38..de061ac6bd 100644
--- a/configs/at91rm9200df_defconfig
+++ b/configs/at91rm9200df_defconfig
@@ -165,7 +165,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91rm9200df_ext_bare_defconfig b/configs/at91rm9200df_ext_bare_defconfig
index 608460da08..522daffbcf 100644
--- a/configs/at91rm9200df_ext_bare_defconfig
+++ b/configs/at91rm9200df_ext_bare_defconfig
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91rm9200df-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91rm9200df_ext_defconfig b/configs/at91rm9200df_ext_defconfig
index 26ec527859..d030b1ef7f 100644
--- a/configs/at91rm9200df_ext_defconfig
+++ b/configs/at91rm9200df_ext_defconfig
@@ -171,7 +171,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91rm9200df-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9260dfc_defconfig b/configs/at91sam9260dfc_defconfig
index 50fa8effe8..1740e13ea5 100644
--- a/configs/at91sam9260dfc_defconfig
+++ b/configs/at91sam9260dfc_defconfig
@@ -178,7 +178,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9260dfc_ext_bare_defconfig b/configs/at91sam9260dfc_ext_bare_defconfig
index 9977e42eb5..bbaadfbd87 100644
--- a/configs/at91sam9260dfc_ext_bare_defconfig
+++ b/configs/at91sam9260dfc_ext_bare_defconfig
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9260dfc_ext_defconfig b/configs/at91sam9260dfc_ext_defconfig
index b46b8b0f53..1df49261cc 100644
--- a/configs/at91sam9260dfc_ext_defconfig
+++ b/configs/at91sam9260dfc_ext_defconfig
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9261ek_defconfig b/configs/at91sam9261ek_defconfig
index 2ef1748522..f4c075551f 100644
--- a/configs/at91sam9261ek_defconfig
+++ b/configs/at91sam9261ek_defconfig
@@ -181,7 +181,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9261ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9261ek_ext_bare_defconfig b/configs/at91sam9261ek_ext_bare_defconfig
index 6837f41255..ec86baef30 100644
--- a/configs/at91sam9261ek_ext_bare_defconfig
+++ b/configs/at91sam9261ek_ext_bare_defconfig
@@ -163,7 +163,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9261ek-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9261ek_ext_defconfig b/configs/at91sam9261ek_ext_defconfig
index 1f64123358..39b5019bc4 100644
--- a/configs/at91sam9261ek_ext_defconfig
+++ b/configs/at91sam9261ek_ext_defconfig
@@ -182,7 +182,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9261ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9263ek_defconfig b/configs/at91sam9263ek_defconfig
index df559da2d0..cfa8742e08 100644
--- a/configs/at91sam9263ek_defconfig
+++ b/configs/at91sam9263ek_defconfig
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9263ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9263ek_ext_bare_defconfig b/configs/at91sam9263ek_ext_bare_defconfig
index 8143318507..54755ce35e 100644
--- a/configs/at91sam9263ek_ext_bare_defconfig
+++ b/configs/at91sam9263ek_ext_bare_defconfig
@@ -162,7 +162,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9263ek-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9263ek_ext_defconfig b/configs/at91sam9263ek_ext_defconfig
index d044d05669..56605d9610 100644
--- a/configs/at91sam9263ek_ext_defconfig
+++ b/configs/at91sam9263ek_ext_defconfig
@@ -181,7 +181,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9263ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9g20dfc_defconfig b/configs/at91sam9g20dfc_defconfig
index 723932780a..dc9b600ff2 100644
--- a/configs/at91sam9g20dfc_defconfig
+++ b/configs/at91sam9g20dfc_defconfig
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam92g20ek-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9g20dfc_ext_bare_defconfig b/configs/at91sam9g20dfc_ext_bare_defconfig
index a63706e890..c43c6f9be2 100644
--- a/configs/at91sam9g20dfc_ext_bare_defconfig
+++ b/configs/at91sam9g20dfc_ext_bare_defconfig
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9g20dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/at91sam9g20dfc_ext_defconfig b/configs/at91sam9g20dfc_ext_defconfig
index 02dd6b4ecb..e61234b507 100644
--- a/configs/at91sam9g20dfc_ext_defconfig
+++ b/configs/at91sam9g20dfc_ext_defconfig
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9g20dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/atngw100-base_defconfig b/configs/atngw100-base_defconfig
index ec3d4a0df6..2b790153d5 100644
--- a/configs/atngw100-base_defconfig
+++ b/configs/atngw100-base_defconfig
@@ -112,7 +112,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/atngw100_defconfig b/configs/atngw100_defconfig
index 6d8293c557..ec87a09d2a 100644
--- a/configs/atngw100_defconfig
+++ b/configs/atngw100_defconfig
@@ -108,7 +108,6 @@ BR2_OPTIMIZE_S=y
 #
 # Advanced
 #
-# BR2_CONFIG_CACHE is not set
 
 #
 # Toolchain
diff --git a/configs/atstk1005_defconfig b/configs/atstk1005_defconfig
index d0ec24d85c..6212e2bbdd 100644
--- a/configs/atstk1005_defconfig
+++ b/configs/atstk1005_defconfig
@@ -111,7 +111,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/atstk100x_defconfig b/configs/atstk100x_defconfig
index 6ee8f11dba..ce509442b7 100644
--- a/configs/atstk100x_defconfig
+++ b/configs/atstk100x_defconfig
@@ -111,7 +111,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/i386_defconfig b/configs/i386_defconfig
index 672b694660..80100d604b 100644
--- a/configs/i386_defconfig
+++ b/configs/i386_defconfig
@@ -113,7 +113,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/i686_defconfig b/configs/i686_defconfig
index 5b1b56fac3..4a128e8024 100644
--- a/configs/i686_defconfig
+++ b/configs/i686_defconfig
@@ -113,7 +113,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/integrator926_defconfig b/configs/integrator926_defconfig
index d7ccc65331..fc2dccfd3b 100644
--- a/configs/integrator926_defconfig
+++ b/configs/integrator926_defconfig
@@ -110,7 +110,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/configs/integrator926_huge_defconfig b/configs/integrator926_huge_defconfig
index f88fcc7bd3..c56b628009 100644
--- a/configs/integrator926_huge_defconfig
+++ b/configs/integrator926_huge_defconfig
@@ -110,7 +110,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="$(BOARD_NAME)-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
diff --git a/docs/buildroot.html b/docs/buildroot.html
index a94e7befa3..0a0114a3b7 100644
--- a/docs/buildroot.html
+++ b/docs/buildroot.html
@@ -1269,13 +1269,6 @@ LIBFOO_POST_PATCH_HOOKS += LIBFOO_POST_PATCH_FIXUP
       not. Valid values are <code>YES</code> and <code>NO</code>. By
       default, the value is <code>YES</code></li>
 
-      <li><code>LIBFOO_USE_CONFIG_CACHE</code> tells whether the configure
-      script should use the central configure cache, which caches test
-      results from previous configure scripts. Usually, this variable should
-      be left to its default value. Only packages having issues with the
-      configure cache, can set this variable to the <code>NO</code> value
-      (but this is more of a work-around than a fix)</li>
-
       <li><code>LIBFOO_INSTALL_STAGING_OPT</code> contains the make options
       used to install the package to the staging directory. By default, the
       value is <code>DESTDIR=$$(STAGING_DIR) install</code>, which is
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 3e21369379..7d04e44012 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -64,7 +64,6 @@ $(2)_MAKE_ENV			?=
 $(2)_MAKE_OPT			?=
 $(2)_AUTORECONF			?= NO
 $(2)_AUTORECONF_OPT		?=
-$(2)_USE_CONFIG_CACHE           ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
 $(2)_INSTALL_STAGING_OPT	?= DESTDIR=$$(STAGING_DIR) install
 $(2)_INSTALL_TARGET_OPT		?= DESTDIR=$$(TARGET_DIR)  install
 $(2)_CLEAN_OPT			?= clean
@@ -88,7 +87,6 @@ define $(2)_CONFIGURE_CMDS
 	$$(TARGET_CONFIGURE_ARGS) \
 	$$($$(PKG)_CONF_ENV) \
 	./configure \
-		$$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/tgt-config.cache",) \
 		--target=$$(GNU_TARGET_NAME) \
 		--host=$$(GNU_TARGET_NAME) \
 		--build=$$(GNU_HOST_NAME) \
@@ -112,7 +110,6 @@ define $(2)_CONFIGURE_CMDS
 		LDFLAGS="$$(HOST_LDFLAGS)" \
                 $$($$(PKG)_CONF_ENV) \
 		./configure \
-		$$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/host-config.cache",) \
 		--prefix="$$(HOST_DIR)/usr" \
 		--sysconfdir="$$(HOST_DIR)/etc" \
 		$$($$(PKG)_CONF_OPT) \
diff --git a/package/fontconfig/fontconfig.mk b/package/fontconfig/fontconfig.mk
index 6cbe2eafe7..a875e7490a 100644
--- a/package/fontconfig/fontconfig.mk
+++ b/package/fontconfig/fontconfig.mk
@@ -7,7 +7,6 @@ FONTCONFIG_VERSION = 2.6.0
 FONTCONFIG_SOURCE = fontconfig-$(FONTCONFIG_VERSION).tar.gz
 FONTCONFIG_SITE = http://fontconfig.org/release
 FONTCONFIG_AUTORECONF = YES
-FONTCONFIG_USE_CONFIG_CACHE = NO
 FONTCONFIG_INSTALL_STAGING = YES
 FONTCONFIG_INSTALL_TARGET = YES
 # This package does not like using the target cflags for some reason.
diff --git a/package/gamin/gamin.mk b/package/gamin/gamin.mk
index db2769213c..f0600b27c4 100644
--- a/package/gamin/gamin.mk
+++ b/package/gamin/gamin.mk
@@ -19,8 +19,6 @@ GAMIN_CONF_ENV = have_abstract_sockets=no
 
 ifneq ($(BR2_LARGEFILE),y)
 GAMIN_CONF_ENV += CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
-# the above doesn't work with shared config.cache
-GAMIN_USE_CONFIG_CACHE = NO
 endif
 
 GAMIN_DEPENDENCIES = libglib2
diff --git a/package/haserl/haserl.mk b/package/haserl/haserl.mk
index 79f02410f1..a8585e827b 100644
--- a/package/haserl/haserl.mk
+++ b/package/haserl/haserl.mk
@@ -11,8 +11,6 @@ HASERL_INSTALL_TARGET:=YES
 
 # force haserl 0.8.0 to use install-sh so stripping works
 HASERL_CONF_ENV = ac_cv_path_install=./install-sh
-# the above doesn't interact nicely with a shared cache, so disable for now
-HASERL_USE_CONFIG_CACHE = NO
 ifeq ($(BR2_PACKAGE_HASERL_WITH_LUA),y)
 	HASERL_CONF_OPT += --with-lua=$(STAGING_DIR) \
 		--with-lua-headers=$(STAGING_DIR)
diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index 820f4656dc..387dce3c50 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -13,8 +13,6 @@ LIBXML2_LIBTOOL_PATCH = NO
 
 ifneq ($(BR2_LARGEFILE),y)
 LIBXML2_CONF_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
-# the above doesn't work with shared config.cache
-LIBXML2_USE_CONFIG_CACHE = NO
 endif
 
 LIBXML2_CONF_OPT = --with-gnu-ld --enable-shared \
diff --git a/package/multimedia/alsa-lib/alsa-lib.mk b/package/multimedia/alsa-lib/alsa-lib.mk
index ee9d9bc5d6..a3d5fe4a87 100644
--- a/package/multimedia/alsa-lib/alsa-lib.mk
+++ b/package/multimedia/alsa-lib/alsa-lib.mk
@@ -67,8 +67,6 @@ endif
 
 ALSA_LIB_CONF_ENV = CFLAGS="$(ALSA_LIB_CFLAGS)" \
 		    LDFLAGS="$(TARGET_LDFLAGS) -lm"
-# the above doesn't work with shared config.cache
-ALSA_LIB_USE_CONFIG_CACHE = NO
 
 define ALSA_LIB_UNINSTALL_TARGET_CMDS
 	-rm -f $(TARGET_DIR)/usr/lib/libasound.so*
diff --git a/package/ng-spice-rework/ng-spice-rework.mk b/package/ng-spice-rework/ng-spice-rework.mk
index 7515d255d2..113b59dee9 100644
--- a/package/ng-spice-rework/ng-spice-rework.mk
+++ b/package/ng-spice-rework/ng-spice-rework.mk
@@ -11,8 +11,6 @@ NG_SPICE_REWORK_INSTALL_STAGING = NO
 NG_SPICE_REWORK_INSTALL_TARGET = YES
 
 NG_SPICE_REWORK_CONF_OPT = CFLAGS="-I$(STAGING_DIR)/usr/include"
-# the above doesn't work with shared config.cache
-NG_SPICE_REWORK_USE_CONFIG_CACHE = NO
 
 NG_SPICE_REWORK_DEPENDENCIES = xserver_xorg-server xlib_libXaw
 
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
index 0104f1719a..778982a722 100644
--- a/package/rpm/rpm.mk
+++ b/package/rpm/rpm.mk
@@ -12,8 +12,6 @@ RPM_DEPENDENCIES = zlib beecrypt neon popt
 
 RPM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/beecrypt -I$(STAGING_DIR)/usr/include/neon -DHAVE_MUTEX_THREAD_ONLY" \
 		ac_cv_va_copy=yes 
-# the above doesn't work with shared config.cache
-RPM_USE_CONFIG_CACHE = NO
 
 RPM_CONF_OPT = --disable-build-versionscript --disable-rpath \
 	--without-selinux \
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index cc74fd74ed..847e77c8ec 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -15,8 +15,6 @@ ifneq ($(BR2_LARGEFILE),y)
 # --disable-largefile is passed, breaking the build. Work around it by
 # simply adding it to CFLAGS for configure instead
 SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
-# changing CFLAGS doesn't work with config.cache
-SQLITE_USE_CONFIG_CACHE = NO
 endif
 
 SQLITE_CONF_OPT =	--enable-shared \
diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
index d9ea57083c..fed8c10f81 100644
--- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
@@ -11,7 +11,6 @@ XSERVER_XORG_SERVER_MAKE = $(MAKE1) # make install fails with parallel make
 XSERVER_XORG_SERVER_AUTORECONF = NO
 XSERVER_XORG_SERVER_LIBTOOL_PATCH = NO
 XSERVER_XORG_SERVER_INSTALL_STAGING = YES
-XSERVER_XORG_SERVER_USE_CONFIG_CACHE = NO # overrides CFLAGS
 XSERVER_XORG_SERVER_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install install-data
 
 XSERVER_XORG_SERVER_DEPENDENCIES = 	\