package/iprutils: Add IBM Power RAID utilities
[Thomas: add patch to allow passing CFLAGS from the environment, use TARGET_CONFIGURE_OPTS instead of manually passing CC/LD, add upstream URL in Config.in, use the Makefile install target instead of open-coding the installation in iprutils.mk.] Signed-off-by: Jeremy Kerr <jk@ozlabs.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
1acff22d5e
commit
5e3ded0d75
@ -1071,6 +1071,7 @@ endif
|
||||
source "package/cpuload/Config.in"
|
||||
source "package/dsp-tools/Config.in"
|
||||
source "package/htop/Config.in"
|
||||
source "package/iprutils/Config.in"
|
||||
source "package/keyutils/Config.in"
|
||||
source "package/kmod/Config.in"
|
||||
source "package/lxc/Config.in"
|
||||
|
12
package/iprutils/Config.in
Normal file
12
package/iprutils/Config.in
Normal file
@ -0,0 +1,12 @@
|
||||
config BR2_PACKAGE_IPRUTILS
|
||||
bool "iprutils"
|
||||
select BR2_PACKAGE_NCURSES
|
||||
select BR2_PACKAGE_NCURSES_TARGET_PANEL
|
||||
select BR2_PACKAGE_NCURSES_TARGET_FORM
|
||||
select BR2_PACKAGE_NCURSES_TARGET_MENU
|
||||
select BR2_PACKAGE_LIBSYSFS
|
||||
select BR2_PACKAGE_PCIUTILS
|
||||
help
|
||||
System utilities for IBM Power RAID devices
|
||||
|
||||
http://sourceforge.net/projects/iprdd/
|
30
package/iprutils/iprutils-01-dont-use-gettext.patch
Normal file
30
package/iprutils/iprutils-01-dont-use-gettext.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 0aa3952890e14f5447147ae4d0d37c515e4fefea Mon Sep 17 00:00:00 2001
|
||||
From: Jeremy Kerr <jk@ozlabs.org>
|
||||
Date: Fri, 26 Jul 2013 13:07:22 +0800
|
||||
Subject: [PATCH] iprconfig: Don't use gettext
|
||||
|
||||
... since we don't have any translations.
|
||||
|
||||
Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
|
||||
---
|
||||
iprconfig.h | 4 +---
|
||||
1 file changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/iprconfig.h b/iprconfig.h
|
||||
index 867b5ac..a9cdf5e 100644
|
||||
--- a/iprconfig.h
|
||||
+++ b/iprconfig.h
|
||||
@@ -11,9 +11,7 @@
|
||||
*
|
||||
**/
|
||||
|
||||
-#include <libintl.h>
|
||||
-
|
||||
-#define _(string) gettext(string)
|
||||
+#define _(string) (string)
|
||||
#define __(string) (string)
|
||||
#define EXIT_FLAG 0x8000 /* stops at given screen on exit call */
|
||||
#define CANCEL_FLAG 0x4000 /* stops at given screen on quit call */
|
||||
--
|
||||
1.7.10.4
|
||||
|
20
package/iprutils/iprutils-02-use-environment-cflags.patch
Normal file
20
package/iprutils/iprutils-02-use-environment-cflags.patch
Normal file
@ -0,0 +1,20 @@
|
||||
Allow CFLAGS to be extended from the environment
|
||||
|
||||
We also remove -g, since we don't necessarily want to build with
|
||||
debugging symbols. Buildroot will add -g if needed.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: b/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -9,7 +9,7 @@
|
||||
|
||||
include version.mk
|
||||
|
||||
-CFLAGS = -g -Wall $(IPR_DEFINES)
|
||||
+override CFLAGS += -Wall $(IPR_DEFINES)
|
||||
UTILS_VER = $(IPR_MAJOR_RELEASE).$(IPR_MINOR_RELEASE).$(IPR_FIX_LEVEL)
|
||||
TAR = cd .. && tar -zcpf iprutils-$(UTILS_VER)-src.tgz --exclude CVS --exclude applied-patches --exclude series --exclude txt --exclude pc --exclude patches --exclude debug --exclude *~* iprutils
|
||||
|
22
package/iprutils/iprutils.mk
Normal file
22
package/iprutils/iprutils.mk
Normal file
@ -0,0 +1,22 @@
|
||||
################################################################################
|
||||
#
|
||||
# iprutils
|
||||
#
|
||||
################################################################################
|
||||
|
||||
IPRUTILS_VERSION = 2.3.15
|
||||
IPRUTILS_SITE = http://downloads.sourceforge.net/project/iprdd/iprutils%20for%202.6%20kernels/$(IPRUTILS_VERSION)
|
||||
IPRUTILS_SOURCE = iprutils-$(IPRUTILS_VERSION)-src.tgz
|
||||
IPRUTILS_DEPENDENCIES = ncurses libsysfs pciutils
|
||||
IPRUTILS_LICENSE = Common Public License Version 1.0
|
||||
IPRUTILS_LICENSE_FILES = LICENSE
|
||||
|
||||
define IPRUTILS_BUILD_CMDS
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all
|
||||
endef
|
||||
|
||||
define IPRUTILS_INSTALL_TARGET_CMDS
|
||||
$(MAKE) $(TARGET_CONFIGURE_OPTS) INSTALL_MOD_PATH=$(TARGET_DIR) -C $(@D) install
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user